Bug 74992 - wrong mouse type assigned and problems without the mouse.
wrong mouse type assigned and problems without the mouse.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 10:15 EDT by Eugene Kanter
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-10-03 10:15:56 EDT
How Reproducible:

always

Steps to Reproduce:
1. have IMPS/2 mouse configured.
2. shut down, replace video card, reboot, let kudzu autoconfigure for new video
(all seems to work fine up to this point).
3. start redhat-config-xfree86. move mouse pointer - jumps because uses PS/2
protocol.
4. restart redhat-config-xfree86, use keyboard only. configure different
resolution. The very last dialog appears in the corner and out of focus. Had to
kill X server. Fortunately new config file has been created by this time.


Actual Results:

New config file has PS/2 as mouse protocol.

Expected Results:

IMPS/2 as mouse protocol.

Additional Information:
	
edited XF86Config by hand, adding IM in front of PS/2. next
redhat-config-xfree86 run is normal.
Comment 1 Alexander Larsson 2002-10-08 09:05:46 EDT
notting: kudzu runs --reconfig. This means it will throw away all current X
config, not just the gfx part. I'm not sure what to do about this.
Comment 2 Eugene Kanter 2002-10-08 09:40:10 EDT
I see two bugs here, one might be kudzu related.
1. redhat-config-xfree86 should place _all_ dialog in the middle of the screen.
This is needed for mouseless operation.
2. kudzu/redhat-config-xfree86 should consult /etc/sysconfig/mouse before
restetting X configuration. There is a variable "XMOUSETYPE" which clearly says
what kind of mouse should be used.
Comment 3 Alexander Larsson 2002-10-08 10:51:26 EDT
I fixed issue 1 in CVS. But reading the r-c-xfree86 code it looks like it's
supposed to read XMOUSETYPE from /etc/sysconfig/mouse already.
Comment 4 Brent Fox 2003-01-06 02:33:06 EST
Yes, but redhat-config-xfree86 was looking for mouse.info["XMOUSETYPE"] before
it called mouse.read(), which always returned "None" for the type.  Therefore it
would always default to PS/2.  I've changed the code around so that we call
mouse.read() first.  This should fix the problem, but it needs to be tested.

This should be fixed in redhat-config-xfree86-0.7.1-3.  QA, please verify.
Comment 5 Brent Fox 2003-05-25 10:31:09 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.