Bug 74993 - can't boot win2k after upgrade to 8.0
can't boot win2k after upgrade to 8.0
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 10:33 EDT by John Killian O'Brien
Modified: 2007-03-26 23:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-30 11:08:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lilo.conf (267 bytes, text/plain)
2002-10-03 10:34 EDT, John Killian O'Brien
no flags Details

  None (edit)
Description John Killian O'Brien 2002-10-03 10:33:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
After upgrading from RH7.3 to 8.0 I can no longer boot my MS windows 2000 partition.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Download iso's for RH 8.0 and save to hard disk.
2.Create boot disk and run installer as per web-pages
3.Follow instructions for upgrading an existing installation
4.Reboot and try to start Win2K
	

Actual Results:  I use lilo. I get the graphical page listing linux and win2000.
If I select win2000 I get a message...
"Invalid system disk
 Replace the disk and then press any key"
There are no floppys or CD's in any of the drives. When I press a key I'm
brought back to the lilo screen and from then selecting win2000 has no effect.

Expected Results:  Windows 2000 should boot up. There were no problems with RH7.3

Additional info:

I've attached /etc/lilo.conf

I've tried tinkering with this but couldn't fix it.

If I change the address for Win2K to other=/dev/hdb and try to start
windows I get a blank screen except for the message...
"Loading win2000"
Nothing else happens and I have to reset.

Booting linux works fine.

I have two ide disks, one for each OS. On the windows disk there are two
partitions; dosc = ntfs with the os and dosd = vfat for archive and moving files
between the two. The dosd partition is still fine.

The upgrade went fine. I've used this procedure for several upgrades. The only
thing new was being asked should the swap space be increased - I said yes.
Comment 1 John Killian O'Brien 2002-10-03 10:34:34 EDT
Created attachment 78364 [details]
lilo.conf
Comment 2 Jeff Peterson 2002-10-05 00:44:26 EDT
When the person answered "yes" to increasing swap space, the install procedure
increased the swap space into and wrote over the dos partition; hence, the dos
partiton is trashed. You will have to recreate and format the dos partition as
well as reload the windows software.
Comment 3 Jeremy Katz 2002-10-05 09:37:34 EDT
Can you attach /etc/lilo.conf.rpmsave?
Comment 4 John Killian O'Brien 2002-10-07 05:21:08 EDT
The upgrade didn't create /etc/lilo.conf.rpmsave 
I did a 'find . -name "*.rpmsave"' and only came up with four files, 
two of which predate the upgrade. 
 
I too suspected that what japeter suggested above might be the case, but don't 
konw how to check that.
Comment 5 Jeremy Katz 2002-10-07 10:25:47 EDT
We default to putting additional swap space in Linux partitions as a swap file,
so I highly doubt that japeter is correct there.

Did you manually add the map-drive information to the lilo.conf yourself? 
Generally, all you need for lilo is
other=/dev/hdb
  label=win2000
Comment 6 John Killian O'Brien 2002-10-07 11:50:11 EDT
Ok, good. It makes sense that anaconda wouldn't invade other partitions for    
swap space. I can rule that out then.    
    
I got one thing backward in my original post. /etc/lilo.conf already has    
other=/dev/hdb and this gives the "Invalid system disk" error. Changing the    
line to hdb1 gives the "Loading win2000" freeze.    
    
Yes, I created the lilo.conf entry for Win2000 when we installed the new disk 
but didn't make any changes when I upgraded. I just now tried commenting out 
the lines after the two you quote but it had no effect.    
    
I doubt that it's relevant but here's how I added the second disk to my system    
a few months ago. Our (MS windows) sysadmin installed the new disk as the    
master and put win2000 on it. Our local linux expert then swapped the two    
disks around (not forgetting to change jumper switches) and did a clean    
reinstall of RH7.3 from CDs onto the old disk. We added the lilo.conf entries    
and everything worked fine.    
    
When I upgraded, I saved the ISOs onto /dev/hdb2 and read them from there.  
Would that have any bearing?   
Comment 7 John Killian O'Brien 2002-10-10 08:55:47 EDT
I confirmed today that the windows installation is intact by removing the  
linux disk and configuring the windows disk as master. I was able to start up  
win2000 without any difficulty.  
  
Comment 8 Jeremy Katz 2002-10-24 17:43:11 EDT
Did you upgrade to a newer version of lilo?  You might also want to look at
trying grub instead of lilo.
Comment 9 John Killian O'Brien 2002-10-30 11:08:26 EST
lilo is 21.4.4-20 which is, I presume, what came with RH7.3   
   
Yeah, I've been putting off trying grub because I couldn't find a big-font,   
small-words how-to for exactly my configuration, but I bit the bullet today   
and...   
	...it worked! I can boot windows again.   
   
Actually what happens is that I see my grub.conf settings and then the same   
message as before, "Invalid system disk Replace disk and then press any key",   
but this time when I press a key windows does boot.   
   
I'll leave it to you to close the bug, as far as I'm concerned it's resolved.
Comment 10 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.