Bug 74995 - Erratic behavior with USB keyboard.
Erratic behavior with USB keyboard.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 10:55 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg on Redhat 8.0 Dell Precision 530 with USB keyboard (14.91 KB, text/plain)
2002-12-12 09:23 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-10-03 10:55:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020712

Description of problem:
When using USB keyboard with kernel 2.4.18-14 on a Dell Precision 530 I am
receiving erratic behavior.  Such as characters repeating many times.  This
behavior exhists in X as well as in console mode.  I am using the U.S. Keyboard
located in /lib/kdb/keymaps/i386/qwerty/us.map.gz.  If you disable repeat keys
in X the behavior changes to keys not being registered sometimes when you type.
 Example:  You may have to type the letter "r" several times before it is
regestered.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Redhat 8.0 custom everything on Dell Precision 530
2.Make sure keyboard is a USB device
3.Edit files or enter commands from the command line in X or console mode.
	

Actual Results:  Keys repeat many times or are not registered at all.

Expected Results:  Pressing a key ehco's that key only once unless held down.

Additional info:

Replacing the keyboard with a PS/2 keyboard fixes the problem.
Comment 1 Aaron VanDevender 2002-10-10 00:43:30 EDT
This is probably a symptom of the USB subsystem not being properly detected. The
USB HID drivers don't get loaded properly and so it defaults to a half broken
failure mode of the BIOS providing a USB keyboard to PS2 bridge. If the kernel
were to properly detect the USB system and load the HID drivers, the keyboard
would function properly.

This is likely a DUP of bug <a
href=https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75596>75596</a>
Comment 2 Brian Welliver 2002-10-28 06:43:15 EST
I am having this same problems on a Dell 8100 using the Dell USB keyboard. 
worked in 7.3 but not 8.0.  If I can be any help please let me know.
Comment 3 Need Real Name 2002-12-11 11:09:05 EST
Same problem here, latest kernel, same kind of machine.
Comment 4 Pete Zaitcev 2002-12-11 15:24:44 EST
Sorry for the delay, being swamped with RHAS work here...

This has nothing to do with EHCI as far as I can tell, so not a dup 75596.
The guess about BIOS would sound exactly right, erratic events are
symptom of "USB legacy" support interfering ... except that old kernel worked!
So, I don't think it's BIOS either.

Someone please capture dmesg before and after USB keyboard was atteched,
and a couple of keystrokes were made. PLEASE DO NOT DROP dmesg INTO COMMENTS BOX.
Comment 5 Need Real Name 2002-12-12 09:23:15 EST
Created attachment 88586 [details]
dmesg on Redhat 8.0 Dell Precision 530 with USB keyboard
Comment 6 Need Real Name 2002-12-12 09:25:04 EST
The dmesg attachment was made with only a USB keyboard attached, because it's all I have 
here.

Mark
Comment 7 david 2002-12-12 13:21:39 EST
I've seen this behavior, too. I'm running Redhat 8.0 on a Dell Inspiron 8000. I
normally use a USB keyboard, but I am quite sure I've seen this happen when I've
been using the built-in keyboard (and USB keyboard is detached). I used to think
that this was a VMWare problem, because I most often see the problem show up in
my VMWare virtual machine (running WinME). However, just yesterday I noticed it
happening in X. With a little experimentation, it seemed to happen more often if
I typed quickly.
Comment 8 Need Real Name 2002-12-13 07:44:38 EST
Well, some good news.  Dell released version A09 of the firmware for the Precision 530.  I installed the firmware this morning, and it seems so far that the keyboard issues, at least for this machine, have gone away.  No repeats, no non-inputs when issuing keystrokes.


Mark
Comment 9 Brian Welliver 2002-12-13 08:03:39 EST
I have been using BIOS version A09 (latest available) on my Dell 8100 for over 
6 months and still have the keyboard problem, probably not the same as version 
A09 on the Dell 530.
Comment 10 Pete Zaitcev 2002-12-13 09:50:42 EST
Correct, T- and A- revisions are meaningful within a family only.
For instance, all Napa based machines will have same A11.
It is pretty hard to gather what boxes use what families though,
so it's best to consider these numbers unique for every model.
Comment 11 Ron 2003-01-18 02:40:15 EST
Same problem on a Gateway 300SE, USB keyboard/mouse.
Oddly enough, it worked fine on a previous upgrade
from 7.3 to 8.0, but not a fresh install of 8.0.  The
only difference I can think of was the hard drive, however
in the installation it worked on, system load was high
until after the first login via gdm, then out, then 
back in, and all would work fine from then on.  I also
noticed the mouse would sometimes fail to work unless
unplugged, then plugged back in, but not all the time.

USB issue?
Comment 12 Need Real Name 2003-01-18 09:53:44 EST
Hate to be the bearer of bad news, but the "fix" with the bios update didn't work as well as hoped.  I had to go back to a standard keyboard with the ps2 type adapter.  So, still sitting on about a dozen P4 machines that need to be built, utilizing USB keyboards.  Any progress in a patch for this behavior?  BTW, I did also notice the same erratic behavior with the mouse on a few occasions.  Unplugging, then replugging it back in did seem to fix it until another reboot.
Comment 13 Need Real Name 2003-03-11 11:43:28 EST
Any progress on this bug?  I still have 11 machines waiting to be used, with USB keyboards.
Comment 14 Tim Keitt 2003-03-19 14:12:20 EST
I see similar erratic keyboard behavior (runaway repeats, especially using
up-arrow in gnome-terminal, keyboard lockups, keyboard-mouse lockups; I've run
all Dell diagnostics to check for hardware problems) on my Dell Precision 620
with a _ps2_ keyboard. Is this a Dell BIOS issue? (There are no BIOS updates
available from Dell for the 620.)
Comment 15 John Swinbank 2003-04-03 17:25:47 EST
I'm seeing similar problems on a homebuilt machine with an Asus P4B motherboard
(BIOS revision 1012) with a Dell RT7D10 USB keyboard. It's not reliably
reproducable, but keys will apparently become "sticky" with large numbers of
repeats for a single keypress.

I see this with both the Red Hat 8.0 default 2.4.18-14 kernel and my own
custom-compiled 2.4.21-pre5-ac3. It occurs when the kernel is compiled with
either CONFIG_USB_UHCI or CONFIG_USB_UHCI_ALT. Disabling legacy USB support in
the BIOS did not stop the problem happening.

The identical keyboard, running on a Dell Precision 530 under Red hat 7.3
(kernel 2.4.18-27.7.xsmp) works with no problems.
Comment 16 Pete Zaitcev 2004-04-19 12:11:02 EDT
Steven, tried Fedora Core 1 yet?
Comment 17 Bugzilla owner 2004-09-30 11:39:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.