Bug 74996 - wget instructions fail for older versions of wget
Summary: wget instructions fail for older versions of wget
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tammy Fox
QA Contact: Fanny Augustin
URL: https://rhn.redhat.com/network/channe...
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-03 14:57 UTC by Need Real Name
Modified: 2009-08-20 03:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 14:36:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-03 14:57:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; .NET 
CLR 1.0.3705)

Description of problem:
The page https://rhn.redhat.com/network/channel/download_isos.pxt recommends 
the use of wget for downloading ISOs, via the command "wget -
c 'very_long_url'".  This command fails for older versions of wget, such as 
RedHat 7.0's wget-1.5.3-10, so I think you should change the documentation on 
this page.

The error message displayed by wget is:

Connecting to https:21... 
https: Host not found

I think your documentation should add a sentence like this: "If you experience 
problems with wget, try upgrading to the latest version of wget at 
http://www.gnu.org/software/wget/wget.html."



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use RedHat 7.0 with the latest patches.
2. Visit https://rhn.redhat.com/network/channel/download_isos.pxt with a web 
browser.
3. Right-click on an ISO link and copy the URL to the copy/paste buffer.
4. Type "/usr/bin/wget -c " and paste the ISO URL onto the command line, within 
single quotes.
5. Press ENTER.
6. Get an error message like this:
           => `Psyche-i386-disc1.iso'
Connecting to https:21... 
https: Host not found

	

Actual Results:             => `Psyche-i386-disc1.iso'
Connecting to https:21... 
https: Host not found

Expected Results:  wget should have downloaded the selected ISO.  Later 
versions of wget such as 1.8.2 work fine. That's why you should update your doc.

Additional info:

Comment 1 Tammy Fox 2002-10-09 14:36:49 UTC
It looks like the page says to use curl instead of wget now.

Comment 2 Josef Komenda 2002-10-14 18:28:08 UTC
Since rhn now officially advocates CURL instead of wget, this bug is no longer
valid -- closing.


Note You need to log in before you can comment on or make changes to this bug.