This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 749976 - krb5-devel via libselinux-devel depends on i686 package, breaking install on x86_64
krb5-devel via libselinux-devel depends on i686 package, breaking install on ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-29 07:15 EDT by Marcus Ilgner
Modified: 2011-10-31 10:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-31 10:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Ilgner 2011-10-29 07:15:11 EDT
Trying to install krb5-devel, yum fails because of i686 package dependencies


> sudo yum install krb5-devel.x86_64
[...]
Resolving Dependencies
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.9.1-15.fc16 will be installed
--> Processing Dependency: krb5-libs = 1.9.1-15.fc16 for package: krb5-devel-1.9.1-15.fc16.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.9.1-15.fc16.x86_64
--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.9.1-15.fc16.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.9.1-15.fc16.x86_64
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.2-1.fc16 will be installed
---> Package krb5-libs.i686 0:1.9.1-15.fc16 will be installed
--> Processing Dependency: libcom_err.so.2 for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libdl.so.2 for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libresolv.so.2(GLIBC_2.2) for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libresolv.so.2 for package: krb5-libs-1.9.1-15.fc16.i686
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.9.1-15.fc16.i686
---> Package libcom_err-devel.x86_64 0:1.41.14-2.fc15 will be installed
---> Package libselinux-devel.x86_64 0:2.1.5-5.1.fc16 will be installed
--> Processing Dependency: libsepol-devel >= 2.1.0-1 for package: libselinux-devel-2.1.5-5.1.fc16.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.1.5-5.1.fc16.x86_64
--> Running transaction check
---> Package glibc.i686 0:2.14.90-13 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.14.90-13.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.14.90-13.i686
---> Package keyutils-libs.i686 0:1.5.2-1.fc16 will be installed
---> Package libcom_err.i686 0:1.41.14-2.fc15 will be installed
---> Package libselinux.i686 0:2.1.5-5.1.fc16 will be installed
---> Package libsepol-devel.x86_64 0:2.1.1-1.fc16 will be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.12.10-4.fc16 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: krb5-libs-1.9.1-15.fc16.i686 != krb5-libs-1.9.1-17.fc16.x86_64
Error: Protected multilib versions: libselinux-2.1.5-5.1.fc16.i686 != libselinux-2.1.6-4.fc16.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.12.10-4.fc16.i686 != nss-softokn-freebl-3.12.10-6.fc16.x86_64
Comment 1 Marcus Ilgner 2011-10-29 10:43:55 EDT
I found two of the RPMs manually but libselinux-2.1.6-4.fc16.i686 doesn't seem to be available.
Comment 2 Alon Levy 2011-10-30 06:00:52 EDT
The problem is with libselinux-devel, this is the output after installing some of the dependencies manually to reduce the unimportant packages in the output:

$ sudo yum install libselinux-devel
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libselinux-devel.x86_64 0:2.1.5-5.1.fc16 will be installed
--> Processing Dependency: libselinux = 2.1.5-5.1.fc16 for package: libselinux-devel-2.1.5-5.1.fc16.x86_64
--> Running transaction check
---> Package libselinux.i686 0:2.1.5-5.1.fc16 will be installed
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: libselinux-2.1.5-5.1.fc16.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: libselinux-2.1.5-5.1.fc16.i686
--> Processing Dependency: libdl.so.2 for package: libselinux-2.1.5-5.1.fc16.i686
--> Processing Dependency: ld-linux.so.2 for package: libselinux-2.1.5-5.1.fc16.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: libselinux-2.1.5-5.1.fc16.i686
--> Processing Dependency: libc.so.6(GLIBC_2.8) for package: libselinux-2.1.5-5.1.fc16.i686
--> Running transaction check
---> Package glibc.i686 0:2.14.90-14 will be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.14.90-14.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.14.90-14.i686
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.12.10-4.fc16 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: libselinux-2.1.5-5.1.fc16.i686 != libselinux-2.1.6-4.fc16.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.12.10-4.fc16.i686 != nss-softokn-freebl-3.12.10-6.fc16.x86_64

I'm moving to libselinux component.
Alon
Comment 3 Alon Levy 2011-10-30 07:51:14 EDT
workaround: Rebuild the libselinux package from fedpkg:

fedpkg clone libselinux
cd libselinux
git co -b f16 origin/f16
fedpkg srpm
rpmbuild --rebuild <output>

Resulting package: libselinux-devel-2.1.6-4.fc16.x86_64

So apparently there is a difference between the package built by me on f16 and the one build with koji.
Comment 4 Daniel Walsh 2011-10-31 10:58:55 EDT
I think you need to enable-testing to get the package.

yum update libselinux-* --enablerepo=updates-testing

Note You need to log in before you can comment on or make changes to this bug.