Bug 749985 - F16 RC1 Live-CD test - some errors to look at
F16 RC1 Live-CD test - some errors to look at
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lxde-common (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-10-29 10:47 EDT by jurek.bajor
Modified: 2012-07-20 12:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-01 13:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (97.66 KB, text/plain)
2011-10-29 10:47 EDT, jurek.bajor
no flags Details
/var/log/lxdm.log (7.60 KB, text/plain)
2011-10-29 10:51 EDT, jurek.bajor
no flags Details
/var/log/dracut.log (98.93 KB, text/plain)
2011-10-29 10:52 EDT, jurek.bajor
no flags Details
~/.session-errors (2.04 KB, text/plain)
2011-10-29 10:54 EDT, jurek.bajor
no flags Details

  None (edit)
Description jurek.bajor 2011-10-29 10:47:43 EDT
Created attachment 530784 [details]
/var/log/messages

Description of problem:
There are various errors to look at.
See Additional Info for comments and attachments.
Version-Release number of selected component (if applicable):
Installed Packages
imsettings-lxde.i686 1.2.5-3.fc16                  @koji-override-0/$releasever
lxde-common.noarch   0.5.5-0.3.20110328git87c368d7.fc16
                                                   @koji-override-0/$releasever

How reproducible:
Start F16.

Steps to Reproduce:
1. as above
2.
3.
  
Actual results:
See attachments.

Expected results:


Additional info:

Regarding Live-CD:
- the very first starting menu, or rather the submenus, have random characters
  highlighted. If the intention was to offer menu selection by highlighted
  char, then it should be corrected. Otherwise, it is a messed up display.
- after selecting Install to Hard Drive from desktop, there appears very
  quickly a window with some info regarding "installation media present" (?)
  before the actual installation screen is displayed.
  Either that "quick" window should be stopped for the user to contemplate and
  make some decision, or it should not be displayed at all.
- Restart/Shutdown or Reboot after Install (to Hard Disk) do not reject (or
  offer to reject) the CD from a CD drive

/var/log/messages:
...
Oct 29 14:10:45 localhost firstboot[911]: Window manager warning: Failed to load theme "Adwaita": Failed to find a valid file for theme Adwaita
...
Oct 29 14:10:50 localhost firstboot[911]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x400031 (firstboot)
Oct 29 14:10:50 localhost firstboot[911]: Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
...
Oct 29 14:15:43 localhost firstboot[911]: Window manager warning: Fatal IO error 11 (Resource temporarily unavailable) on display ':9'.
...

/var/log/dracut.log:
...
I: Possible missing firmware "ct2fw.bin" for kernel module "bfa.ko"
I: Possible missing firmware "ctfw.bin" for kernel module "bfa.ko"
I: Possible missing firmware "cbfw.bin" for kernel module "bfa.ko"
...
I: Possible missing firmware "isci/isci_firmware.bin" for kernel module "isci.ko"
...
I: Possible missing firmware "ql2400_fw.bin" for kernel module "qla2xxx.ko"
I: Possible missing firmware "ql2322_fw.bin" for kernel module "qla2xxx.ko"
I: Possible missing firmware "ql2300_fw.bin" for kernel module "qla2xxx.ko"
I: Possible missing firmware "ql2200_fw.bin" for kernel module "qla2xxx.ko"
I: Possible missing firmware "ql2100_fw.bin" for kernel module "qla2xxx.ko"
...

/var/log/lxdm.log:
NOTE: it would be good to show what is the source of these "Message".
...
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
** Message: add 0x840adc0

** Message: prepare greeter on :0

** Message: start greeter on :0

** Message: greeter 0 session 0x840adc0

** Message: user 0 session 0x840adc0 cmd USER_LIST

(lxdm-greeter-gtk: ...
...

~/.xsession-errors
cp: cannot stat `/usr/share/lxde/pcmanfm/pcmanfm.conf': No such file or directo
ry
Openbox-Message: Unable to find a valid menu file "/usr/share/lxde/openbox/menu
.xml"
...
Comment 1 jurek.bajor 2011-10-29 10:51:56 EDT
Created attachment 530785 [details]
/var/log/lxdm.log
Comment 2 jurek.bajor 2011-10-29 10:52:48 EDT
Created attachment 530786 [details]
/var/log/dracut.log
Comment 3 jurek.bajor 2011-10-29 10:54:09 EDT
Created attachment 530787 [details]
~/.session-errors
Comment 4 jurek.bajor 2011-10-29 11:10:02 EDT
/var/log/messages:
...
Oct 29 14:16:30 localhost pulseaudio[1343]: module-alsa-card.c: Failed to find a working profile.
Oct 29 14:16:30 localhost pulseaudio[1343]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id="29" name="platform-thinkpad_acpi" card_name="alsa_card.platform-thinkpad_acpi" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1""): initialization failed.
...

I am not sure if this is LXDE spin related or pure pulseaudio problem (a new BZ
report to be created).
JB
Comment 5 Christoph Wickert 2011-10-29 11:13:58 EDT
(In reply to comment #0)
> - the very first starting menu, or rather the submenus, have random characters
>   highlighted. If the intention was to offer menu selection by highlighted
>   char, then it should be corrected. Otherwise, it is a messed up display.

I don't understand what you mean, sorry.

> - after selecting Install to Hard Drive from desktop, there appears very
>   quickly a window with some info regarding "installation media present" (?)
>   before the actual installation screen is displayed.

This is a bug in anaconda, but I cannot find the report atm. This has nothing to do with LXDE.

>   Either that "quick" window should be stopped for the user to contemplate and
>   make some decision, or it should not be displayed at all.
> - Restart/Shutdown or Reboot after Install (to Hard Disk) do not reject (or
>   offer to reject) the CD from a CD drive
> 
> /var/log/messages:
> ...
> Oct 29 14:10:45 localhost firstboot[911]: Window manager warning: Failed to
> load theme "Adwaita": Failed to find a valid file for theme Adwaita

Bug in firstboot or in adwaita, if there is a but at all.

> Oct 29 14:10:50 localhost firstboot[911]: Window manager warning: Buggy client
> sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x400031
> (firstboot)
> Oct 29 14:10:50 localhost firstboot[911]: Window manager warning:
> meta_window_activate called by a pager with a 0 timestamp; the pager needs to
> be fixed.
> ...
> Oct 29 14:15:43 localhost firstboot[911]: Window manager warning: Fatal IO
> error 11 (Resource temporarily unavailable) on display ':9'.

-> firstboot

> /var/log/dracut.log:
> ...
> I: Possible missing firmware "ct2fw.bin" for kernel module "bfa.ko"
> I: Possible missing firmware "ctfw.bin" for kernel module "bfa.ko"
> I: Possible missing firmware "cbfw.bin" for kernel module "bfa.ko"
> ...
> I: Possible missing firmware "isci/isci_firmware.bin" for kernel module
> "isci.ko"
> ...
> I: Possible missing firmware "ql2400_fw.bin" for kernel module "qla2xxx.ko"
> I: Possible missing firmware "ql2322_fw.bin" for kernel module "qla2xxx.ko"
> I: Possible missing firmware "ql2300_fw.bin" for kernel module "qla2xxx.ko"
> I: Possible missing firmware "ql2200_fw.bin" for kernel module "qla2xxx.ko"
> I: Possible missing firmware "ql2100_fw.bin" for kernel module "qla2xxx.ko"

No bug. "I" means info, dracut just warns that some firmware *might* be missing. I don't know if we cannot ship it or if it is not required, if you are really interested file a bug against dracut.

Bugs like this one have *absoltely* nothing do do with LXDE, please file them against the appropriate components.

> /var/log/lxdm.log:
> NOTE: it would be good to show what is the source of these "Message".
> ...
> (==) Using system config directory "/usr/share/X11/xorg.conf.d"
> ** Message: add 0x840adc0
> 
> ** Message: prepare greeter on :0
> 
> ** Message: start greeter on :0
> 
> ** Message: greeter 0 session 0x840adc0
> 
> ** Message: user 0 session 0x840adc0 cmd USER_LIST
> 
> (lxdm-greeter-gtk: ...

All of these are normal debug messages. What is the problem?

> ~/.xsession-errors
> cp: cannot stat `/usr/share/lxde/pcmanfm/pcmanfm.conf': No such file or directo
> ry

Should be fixed long ago. Need to look into it.

> Openbox-Message: Unable to find a valid menu file "/usr/share/lxde/openbox/menu
> .xml"

Need to look into that one, too.

However it is way to late to change anything for F16. Only GNOME and KDE count as blocking desktops, Xfce and LXDE not. Without a blocker bug I cannot get any packages into F16 any longer. For more info see https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process

Please file your bug earlier next time.
Comment 6 Christoph Wickert 2011-10-29 11:16:36 EDT
(In reply to comment #4)
> /var/log/messages:
> ...
> Oct 29 14:16:30 localhost pulseaudio[1343]: module-alsa-card.c: Failed to find
> a working profile.
> Oct 29 14:16:30 localhost pulseaudio[1343]: module.c: Failed to load  module
> "module-alsa-card" (argument: "device_id="29" name="platform-thinkpad_acpi"
> card_name="alsa_card.platform-thinkpad_acpi" tsched=yes ignore_dB=no
> card_properties="module-udev-detect.discovered=1""): initialization failed.
> ...
> 
> I am not sure if this is LXDE spin related or pure pulseaudio problem (a new BZ
> report to be created).
> JB

This is a bug in pulseaudio. If you are unsure, please test with the GNOME media before filing a bug against LXDE. Please don't blame LXDE for everything but file bugs against the right packages.
Comment 7 jurek.bajor 2011-10-29 13:14:00 EDT
(In reply to comment #5)
> ...

There is one more LXDE related error message in:
~/.xsession-errors
...
lxpanel: can't load netstat plugin
...

I will file different BZ reports for the other components.
JB
Comment 8 Christoph Wickert 2011-10-31 10:19:35 EDT
Ok, I found one problem with Pulseaudio: PA could not be started and so there was no mixer icon on the panel. This is the same problem you already reported in bug 713292 but I only fixed it on the lxde-common-package but not in the kickstart. Did that now in http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commit;h=c33e3c38 and the fix is included in the RC2 image.
Comment 9 jurek.bajor 2011-10-31 13:00:44 EDT
Question:
There used to be Suspend and Hibernate in a menu (Logout menu, I believe).
What is the state of it ?
JB
Comment 10 Christoph Wickert 2011-10-31 18:26:48 EDT
Good catch, upower was not installed. If it's installed, the menu entries show up. Fixed in http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commit;h=eced8733
Comment 11 Adam Williamson 2011-10-31 20:17:46 EDT
+1 NTH, clearly we want working power management in teh LXDE spin.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Christoph Wickert 2011-10-31 20:39:26 EDT
Actually it's not only that, notifications were missing, too, because notification-daemon was not being started.

Jurek, I am now marking this bug as MODIFIED. We fixed pulseaudio, notifcations and power-management. This is all we can do for F16.

The remaining issues are not in LXDE. If you have filed bugs for them, please add them in the "See also" field. The only thing that is in LXDE is the problem you mentioned in comment 7. I have filed bug 750400 for this.
Comment 13 jurek.bajor 2011-11-01 04:17:08 EDT
Added BZs to See Also.
JB
Comment 14 Christoph Wickert 2011-11-01 13:56:01 EDT
I have tested all their(In reply to comment #12)
> We fixed pulseaudio, notifcations and power-management.

I have tested these 3 with RC3 and everything is fine. Closing.
Comment 15 jurek.bajor 2011-11-01 14:06:11 EDT
Added
https://bugzilla.redhat.com/show_bug.cgi?id=750598
to See Also.
Comment 16 Adam Williamson 2011-11-01 15:58:43 EDT
Retrospectively accepting as NTH for F16 final, after we already pulled it into RC3. half-assed process ftw!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 jurek.bajor 2011-11-02 04:36:41 EDT
Christoph,

one more question (I ask it here before considering opening a new BZ).

With regard to LXDE and Graphical Login Manager;

should the Quit menu (bottom right corner) have
Suspend
Hibernate
as well, in addition the the current
Reboot
Shutdown

This would provide consistency between inside and outside of LXDM.
I hope it can be done, of course.

JB
Comment 18 Christoph Wickert 2011-11-02 04:47:26 EDT
Jurek, this is a feature request rather than a bug report. Feature requests are better filed in the upstream bug tracker in order to directly reach the developers and other interested users.

There is an update for LXDM that I still need to package but I don't think it offers power management. Please file a feature request at sourceforge.net/tracker/?atid=894872&group_id=180858
Comment 19 jurek.bajor 2011-11-02 05:09:24 EDT
(In reply to comment #18)
> Jurek, this is a feature request rather than a bug report. Feature requests are
> better filed in the upstream bug tracker in order to directly reach the
> developers and other interested users.
> 
> There is an update for LXDM that I still need to package but I don't think it
> offers power management. Please file a feature request at
> sourceforge.net/tracker/?atid=894872&group_id=180858

Added a new item 3432169 there.
JB
Comment 20 Jan Pokorný 2012-07-03 12:10:52 EDT
It seems to me that F17 with LXDE again misses notification-daemon
at startup.

If anyone can check my observation (or nobody responds shortly),
I'll file a new bug.
Comment 21 Jan Pokorný 2012-07-19 16:00:01 EDT
re Comment 20:

To clarify it, I meant F17 LXDE when installed from live DVD
(which looks like compilation of live CDs).
I am not sure whether the mentioned missing notifications
(notification-daemon not running) were meant as in "live session"
or as in "when installed on disk", but my test installation from
the same F17 DVD into VM confirmed me that notification-daemon
is not being launched automatically despite being installed
by default.

So I am probably heading towards filing a new bug.
The only thing that baffles me is commit [1] which indicates
it should be solved?  Or is it a regression in F17?
I cannot see /usr/libexec/notification-daemon in
/etc/xdg/lxsession/LXDE/autostart in that fresh installation...

Note You need to log in before you can comment on or make changes to this bug.