Bug 750106 - Please update clamz to 0.5; currently packaged version is no longer compatible with Amazon
Summary: Please update clamz to 0.5; currently packaged version is no longer compatibl...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clamz
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jim Radford
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-31 01:52 UTC by D. Wagner
Modified: 2011-11-05 01:27 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-11-05 01:27:19 UTC


Attachments (Terms of Use)

Description D. Wagner 2011-10-31 01:52:09 UTC
Description of problem:

Can you update clamz to the latest version (0.5)?

Amazon has changed the version of their cloud player .amz files.  The version of clamz packaged in F14 does not support Amazon's new file format.  The newest version of clamz (0.5) does support these new file formats.

At present, I get the following error message when using the version of clamz packaged with Fedora:

$ clamz Amazon-MP3-1320025448.amz 
ERROR: Invalid base64 data in AMZ file 'Amazon-MP3-1320025448.amz'

0 of 1 AMZ files downloaded successfully.


Version-Release number of selected component (if applicable):

clamz-0.4-3.fc14.x86_64


How reproducible: 100% reproducible.


Steps to Reproduce:
1. Download an .amz file from Amazon cloud player, by clicking to download an album.
2. Run clamz on that .amz file, as shown above.

Comment 1 D. Wagner 2011-10-31 01:52:34 UTC
Oh, I forgot to mention: for more detail, see the bug report at the clamz project:

https://code.google.com/p/clamz/issues/detail?id=29

Comment 2 Fedora Update System 2011-10-31 03:10:27 UTC
clamz-0.5-0.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/clamz-0.5-0.fc16

Comment 3 Fedora Update System 2011-10-31 03:11:20 UTC
clamz-0.5-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/clamz-0.5-0.fc15

Comment 4 Fedora Update System 2011-10-31 03:12:01 UTC
clamz-0.5-0.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/clamz-0.5-0.fc14

Comment 5 Fedora Update System 2011-10-31 03:13:04 UTC
clamz-0.5-0.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clamz-0.5-0.el6

Comment 6 Jim Radford 2011-10-31 03:26:09 UTC
Thanks for your report.  If you wouldn't mind, please test one of the above RPMs.

Comment 7 D. Wagner 2011-10-31 04:26:25 UTC
Works perfectly for me.  I've entered this via bodhi.  Thank you much, I do appreciate it!

Comment 8 Fedora Update System 2011-10-31 21:24:12 UTC
clamz-0.5-0.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-11-02 00:08:22 UTC
clamz-0.5-0.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-11-02 06:56:03 UTC
clamz-0.5-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-11-05 01:27:19 UTC
clamz-0.5-0.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.