Bug 750170 - [KDE?] Writer does not show text colors
[KDE?] Writer does not show text colors
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-31 05:04 EDT by Pavel Alexeev
Modified: 2012-02-28 11:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-28 11:32:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Test document with blue text which shown as black (8.62 KB, application/vnd.oasis.opendocument.text)
2011-10-31 05:04 EDT, Pavel Alexeev
no flags Details
Screenshot of problem (70.39 KB, image/png)
2011-11-11 04:05 EST, Pavel Alexeev
no flags Details
what I see (388.73 KB, image/png)
2011-11-11 08:04 EST, Caolan McNamara
no flags Details

  None (edit)
Description Pavel Alexeev 2011-10-31 05:04:09 EDT
Created attachment 530926 [details]
Test document with blue text which shown as black

Description of problem:
If I setup text colors other than black it does not shown in Writer. Neiter if I set it via style or direct for text.

What more interesting - it applied, and for example if I export document into PDF it shown.

Version-Release number of selected component (if applicable):
$ rpm -qa 'libreoffice*'
libreoffice-langpack-en-3.4.3.2-15.fc16.x86_64
libreoffice-core-3.4.3.2-15.fc16.x86_64
libreoffice-graphicfilter-3.4.3.2-15.fc16.x86_64
libreoffice-gdb-debug-support-3.4.3.2-15.fc16.x86_64
libreoffice-presenter-screen-3.4.3.2-15.fc16.x86_64
libreoffice-calc-3.4.3.2-15.fc16.x86_64
libreoffice-pdfimport-3.4.3.2-15.fc16.x86_64
libreoffice-writer-3.4.3.2-15.fc16.x86_64
libreoffice-opensymbol-fonts-3.4.3.2-15.fc16.noarch
libreoffice-debuginfo-3.4.3.2-15.fc16.x86_64
libreoffice-impress-3.4.3.2-15.fc16.x86_64
libreoffice-langpack-ru-3.4.3.2-15.fc16.x86_64
libreoffice-draw-3.4.3.2-15.fc16.x86_64
libreoffice-math-3.4.3.2-15.fc16.x86_64
libreoffice-xsltfilter-3.4.3.2-15.fc16.x86_64
libreoffice-ure-3.4.3.2-15.fc16.x86_64
libreoffice-kde-3.4.3.2-15.fc16.x86_64

How reproducible:
Always
Comment 1 Caolan McNamara 2011-11-08 06:42:51 EST
Opened in F-16, and it's blue as expected. So, what's your environment, KDE or GNOME ?, attach a screenshot maybe.
Comment 2 Pavel Alexeev 2011-11-11 04:05:35 EST
Created attachment 532999 [details]
Screenshot of problem

Its amazing! I had not may even amazing what it may be possible.

What Interesting, I open it in XFCE session at home and it also shown as blue.
Comment 3 Caolan McNamara 2011-11-11 08:04:20 EST
Created attachment 533062 [details]
what I see

Installed KDE as well, no configuration, just defaults. Works fine. I presume we're *sure* this affects LibreOffice only, i.e. you don't have a global problem there with that shade of blue :-) How about other colors, red, slightly different blue, etc.
Comment 4 Pavel Alexeev 2011-11-13 09:40:14 EST
Any text colors does not shown. Background color shows well.
Comment 5 Caolan McNamara 2012-01-16 09:21:50 EST
is it just writer, how about e.g. calc ?
Comment 6 Pavel Alexeev 2012-01-20 17:25:22 EST
Calc was work well.
Comment 7 Caolan McNamara 2012-02-28 11:32:05 EST
Sorry, this one just baffles me but I can't reproduce it to make a guess as to what the problem might be :-( Its definitely a weird one.

Note You need to log in before you can comment on or make changes to this bug.