Bug 75019 - Oddities handling accented characters
Oddities handling accented characters
Status: CLOSED DUPLICATE of bug 41991
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 15:32 EDT by James Turner
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Turner 2002-10-03 15:32:14 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
tcsh-6.12-2 (from Null) behaves oddly when you use various characters with 
grave and other accents: 
 
1. Pressing tab to complete a filename containing accented characters 
2. Pasting a string containing accented characters into tcsh 
 
 
Version-Release number of selected component (if applicable): 
tcsh-6.12-2 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
These examples are all based on the Italian "Cio e errata" ("this is 
wrong/incorrect"). The o and the initial e should both have grave accents - 
which are not shown in the bug report in case it messes things up :) 
 
Tab completion bug(s): 
 
Create two files in a directory on their own by typing (with the accents): 
 
   mkdir test_dir 
   cd test_dir 
   touch Cio\ e\ errata.1.txt 
   touch Cio\ e\ errata.2.txt 
 
Type "cat " and press tab. The command line now incorrectly reads as follows: 
 
Actual behaviour:    cat Cio e errata. 
Expected correct behaviour:  cat Cio\ e\ errata. 
 
If things were working correctly, you should be able to press "1" then tab a 
second time to complete the filename, however this doesn't work - the shell 
misinterprets this as three seperate filenames. 
 
A further problem appears to relate to confusion between single/double-byte 
characters. 
 
Press CTRL+U to delete any current input on the shell (if any), then once more 
type "cat " and press tab. The command line should now once more read "cat Cio 
e errata." 
 
Next, press the backspace key eight times. 
 
Actual result: Cio e 
                   ^ 
                   Cursor is here 
 
Expected result: Cio e 
                       ^ 
                       Cursor is here 
 
After pressing the backspace key once more 
 
Actual result: Cioe 
                 ^ 
                 Cursor is here 
 
Expected result: Cio e 
                      ^ 
                      Cursor is here. 
 
Then, pressing the right arrow: 
 
Actual result: cat Cioe 
                       ^ 
                       Cursor is here 
 
Expected result: No effect, same as the previous expected result. 
 
After pressing backspace once more (two characters are deleted at once): 
 
Actual result: cat Ci 
                     ^ 
                     Cursor is here 
 
Expected result: cat Cio  
                         ^ 
                         Cursor is here 
 
Pasting text bug: 
 
In the same test directory as above, type ls, then use the mouse to highlight 
the words "Cio e errata.1.txt" 
 
Click with the middle mouse button the shell prompt to paste the filename. 
 
Expected result: Cio e errata.1.txt 
 
Actual result (Konsole from kdebase-3.0.3-3, 11pt Luxi Mono Regular as the 
font): Ceo   errata.1.txt 
 
Actual result (Linux console, kernel 2.4.18-10 built by Red Hat or 
gnome-terminal-2.0.1-2, 11pt Luxi mono regular as the font): Ci oe 
errata.1.txt 
 
 
Additional info: 
 
Output from "locale" command: 
 
LANG=en_GB.iso885915 
LC_CTYPE="en_GB.iso885915" 
LC_NUMERIC="en_GB.iso885915" 
LC_TIME="en_GB.iso885915" 
LC_COLLATE="en_GB.iso885915" 
LC_MONETARY="en_GB.iso885915" 
LC_MESSAGES="en_GB.iso885915" 
LC_PAPER="en_GB.iso885915" 
LC_NAME="en_GB.iso885915" 
LC_ADDRESS="en_GB.iso885915" 
LC_TELEPHONE="en_GB.iso885915" 
LC_MEASUREMENT="en_GB.iso885915" 
LC_IDENTIFICATION="en_GB.iso885915" 
LC_ALL= 
 
Output from "cat /etc/sysconfig/i18n" command: 
 
LANG="en_GB.iso885915" 
SUPPORTED="en_GB.iso885915:en_GB:en" 
# SYSFONT="lat0-sun16" 
# SYSFONTACM="iso15" 
SYSFONT="lat9-16" 
CHARSET="8859-15"
Comment 1 James Turner 2002-10-03 15:51:29 EDT
All of the above work fine in bash-2.05a-13 (from Null) with configuration as 
specified.
Comment 2 Miloslav Trmač 2004-08-17 09:50:03 EDT

*** This bug has been marked as a duplicate of 41991 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.