Bug 750191 - Wrong LINT1/NMI ACPI and mptable descriptors
Wrong LINT1/NMI ACPI and mptable descriptors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: seabios (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Karen Noel
Virtualization Bugs
:
Depends On:
Blocks: 738565
  Show dependency treegraph
 
Reported: 2011-10-31 06:09 EDT by Avi Kivity
Modified: 2013-01-09 19:28 EST (History)
5 users (show)

See Also:
Fixed In Version: seabios-0.6.1.2-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:01:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Avi Kivity 2011-10-31 06:09:25 EDT
Description of problem:

Windows requires an NMI descriptor so it knows the NMI button is connected to LINT1, or it will not enable NMIs.


Version-Release number of selected component (if applicable):
0.6.1.2-7.el6

How reproducible:
Always

Steps to Reproduce:
1. Configure Windows to generate a memory dump on NMI
2. Run under qemu-kvm-0.12.1.2-2.201.el6 or later
3. Generate an NMI
  
Actual results:

Windows does not dump memory


Expected results:

Windows dumps memory


Additional info:
Comment 2 juzhang 2011-10-31 06:24:46 EDT
Just kindly reminder,when we verify this bug,had better associate with Bug 738565 - [FJ6.2 Bug]: Failed to capture kdump due to redundant NMIs
Comment 5 FuXiangChun 2011-11-03 04:46:15 EDT
Reproduced with qemu-kvm-0.12.1.2-2.172.el6.x86_64 and
seabios-0.6.1.2-4.el6.x86_64

Result:
Can not got dump files

Tested with  qemu-kvm-0.12.1.2-2.208.el6.x86_64 and
seabios-0.6.1.2-8.el6.x86_64.
I tried the following windows systems

Results:
Guest name      status

Win2008-64      can get dumps memory files
Win7-64         can get dumps memory files
Winxp           can not get dumps memory files.

Questions:
for now,still winxp failed to get dumps memory files.would you please tell us
why?xp guest handle nmi mechanism or this issue is still not fixed very
well,the more details,the better.thanks
Comment 6 FuXiangChun 2011-11-07 08:42:55 EST
for winxp guest, i according to below link to change registry. after booting guest, hit Ctrl_R + scrolllock+scrolllock to trigger BSOD and can get memory dump files.  Use inject_nmi could trigger a BSOD but without any memory dumped.
https://redmine.englab.nay.redhat.com/issues/8219
Comment 7 FuXiangChun 2011-11-07 21:32:09 EST
base above result, this bug is fixed. (In reply to comment #6)
> for winxp guest, i according to below link to change registry. after booting
> guest, hit Ctrl_R + scrolllock+scrolllock to trigger BSOD and can get memory
> dump files.  Use inject_nmi could trigger a BSOD but without any memory dumped.
> https://redmine.englab.nay.redhat.com/issues/8219

(In reply to comment #6)
> for winxp guest, i according to below link to change registry. after booting
> guest, hit Ctrl_R + scrolllock+scrolllock to trigger BSOD and can get memory
> dump files.  Use inject_nmi could trigger a BSOD but without any memory dumped.
> https://redmine.englab.nay.redhat.com/issues/8219

thanks for Avi vadim's help, after I used below link and email provide method to re-modify registry of winxp/win2003, they can get dumps memory files when send NMI from host to guest.

http://support.microsoft.com/kb/927069

final testing result:

   Guest name      status

  Win2008-64      can get dumps memory files
  Win7-64         can get dumps memory files
  Winxp           can get dumps memory files.
  win2003-64      can get dumps memory files.

base above testing result, this bug is fixed in qemu-kvm-0.12.1.2-2.208.el6.x86_64 and
seabios-0.6.1.2-8.el6.x86_64.
Comment 9 errata-xmlrpc 2011-12-06 12:01:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1680.html

Note You need to log in before you can comment on or make changes to this bug.