Bug 750243 - pth causes gpgme to fail build on arm
pth causes gpgme to fail build on arm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pth (Show other bugs)
15
arm Linux
unspecified Severity high
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2011-10-31 08:55 EDT by ajayr
Modified: 2011-10-31 18:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.7-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-31 17:38:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to disable fortify source on arm platforms (1.14 KB, patch)
2011-10-31 08:55 EDT, ajayr
no flags Details | Diff

  None (edit)
Description ajayr 2011-10-31 08:55:10 EDT
Created attachment 530970 [details]
Patch to disable fortify source on arm platforms

Description of problem:

Cannot build gpgme against pth on arm platforms

Version-Release number of selected component (if applicable):
2.0.7-10

How reproducible:
always


Steps to Reproduce:
1. try building gpgme on arm
2.
3.
  
Actual results:
fails to configure

Expected results:


Additional info:
http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=14122

is the working build in f13 & f14 which has not been applied in git

also see the same bug on ubuntu
https://bugs.launchpad.net/ubuntu/+source/pth/+bug/599862
Comment 1 Chris Tyler 2011-10-31 17:38:51 EDT
Patched spec for 2.0.7-12 in f15/f16/master branches and queued on Moji for armv5tel prebuild.
Comment 2 Michael Schwendt 2011-10-31 18:24:49 EDT
It's unlikely that -12 will build due to polluting pth-config. Try -13, please.

Note You need to log in before you can comment on or make changes to this bug.