Bug 75030 - floppy drive fails to mount floppy disk
floppy drive fails to mount floppy disk
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2002-10-03 16:43 EDT by NILMONI DEB
Modified: 2008-08-01 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description NILMONI DEB 2002-10-03 16:43:17 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3) 
Description of problem: 
This is an IBM laptop (T22, 2647-9EU) with modular bay. It detected the cdrom 
just fine and installed redhat-8.0. But when the floppy drive is put into the 
bay, and a floppy (readable in other linux machines) is placed in it, it 
always fails to mount. The drive is ok as win2000 can read floppy from that 
During boot (as shown by "dmesg"), the floppy drive is detected as: 
ide-floppy driver 0.99.newide 
Partition check: 
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 > 
Floppy drive(s): fd0 is 1.44M 
FDC 0 is a National Semiconductor PC87306 
NET4: Frame Diverter 0.46 
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize 
ide-floppy driver 0.99.newide 
When I replaced the cd-drive with the floppy-drive, it automatically deleted 
the cdrom entry from /etc/fstab (which is good) but did not create an entry 
for the floppy device in /etc/fstab (which is bad !). So I manually added an 
entry such as: 
/dev/fd0   /mnt/floppy             auto    noauto,user,sync 0 0 
and tried to read a floppy but it failed to mount it with dmesg giving these 
end_request: I/O error, dev 02:00 (floppy), sector 0 
end_request: I/O error, dev 02:00 (floppy), sector 0 
end_request: I/O error, dev 02:00 (floppy), sector 2 
end_request: I/O error, dev 02:00 (floppy), sector 4 
end_request: I/O error, dev 02:00 (floppy), sector 6 
I have tried mounting a floppy as root and as non-root user and the problem is 
always there. I can't even create a boot floppy now !! 
Version-Release number of selected component (if applicable): 
How reproducible: 
Steps to Reproduce: 
1. Just try mounting a floppy (as root or non-root user) 
Actual Results:  It will fail to mount a floppy 
Expected Results:  Should mount the floppy just fine. 
Additional info:
Comment 1 Todd Cassell 2002-10-04 12:50:43 EDT
I have a Digital laptop and have had the exact same problem.
Comment 2 John R Leddy 2003-01-04 06:13:11 EST
Is this in any way connected to bug74080 & bug80949 ?
Comment 3 NILMONI DEB 2003-01-04 14:07:01 EST
Not quite. In my case, the floppy was MS windows readable on the same laptop, 
which means it was definitely not ext2 formatted. Its also readable just fine on linux 
on other machines. Therefore, its not: 
        - a problem of corrupt floppy disk 
        - a problem of bad floppy drive 
        - ext2 file system specific 
Comment 4 NILMONI DEB 2003-05-02 14:18:54 EDT
The same problem is present in redhat 9 on the same laptop (IBM T22). 
Comment 5 Chris 2003-10-10 05:58:31 EDT
This bug seems to be rather old. A quick search on http://www.ask.com for
"end_request: I/O error, dev 02:00 (floppy)" will reveal a multitude of reports,
some dating back to 1996! The most disgraceful thing about this bug is that it
hangs the whole system! Also, which is also very bad, it corrupts data on the
floppy. For me it happens on a brand new machine running under RedHat 9. It is
so annoying that I am seriously considering blowing the Linux partition away and
going back to Windos.
Comment 6 perry 2004-04-11 11:58:41 EDT
This error;

kernel: end_request: I/O error, dev 02:00 (floppy), sector 0

is happening to me using Redhat 9. Previously, I had Version 8.0
installed with no problems.  

A check of my device permissions shows;

brw-rw----    1 fs01     floppy     2,   0 Jan 30  2003 /dev/fd0

which is normal as far as I can tell.
Comment 7 Bugzilla owner 2004-09-30 11:39:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.