This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 750351 - expired subscriptions are still bound to the consumer
expired subscriptions are still bound to the consumer
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Solaris
unspecified Severity medium
: ---
: ---
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-10-31 15:25 EDT by blittle
Modified: 2015-05-14 11:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Since IT is triggering refresh pools off of expiry, the solution was to unbind expired subscriptions during refresh pools. Refresh pools will now remove any expired subscriptions, along with any of its associated pools, and will revoke consumer's entitlements from these pools.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:03:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description blittle 2011-10-31 15:25:59 EDT
Description of problem:
expired subscriptions are still binded to the consumer

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:

Environment- https://rails-fte.gss.devlab.phx1.redhat.com/management/consumers/

login-rhn-cservice-acarter
pw-redhat

1. Created a rhui consumer.

2. Add a 60 day Supported Red Hat Update Infrastructure for Cloud Providers Evaluation subscription that expired on 10/28/11.

3. On 10/31/11, I noticed the 60 day Supported Red Hat Update Infrastructure for Cloud Providers Evaluation subscription was removed from the main subscription list.

4.  When I viewed the the rhui consumer list seven consumers still had the expired subscription displayed on the details page.  All the consumers have the name "cloud1".
  
Actual results:
Expired subscriptions display on consumer details page after expiration.

Expected results:
Expired subscriptions should be purged on the expiration date.

Additional info:
Comment 3 Michael Stead 2011-11-08 14:54:19 EST
Not 100% sure what is being requested here.

Are we looking to have expired entitlements filtered? or be automatically revoked by candlepin?

Would marking them as expired on the web UI be another option? This seems like it could be useful.
Comment 4 Amanda Carter 2011-11-08 15:11:45 EST
This bug is regarding subscriptions that are bound to a consumer, not the Available Subscription list. The subscription should no longer be bound to the consumer when it has passed its expiration date. 

Revocation should already be handled.
Comment 5 Michael Stead 2011-11-15 17:42:13 EST
Fix submitted in:

master: ba62d784d2d3befb0a0d4f35b229bccead431696
0.4: 69de6445fe9e79f7be6783c884401ea3b6aeff29

See technical details.
Comment 6 Michael Stead 2011-11-15 17:42:13 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Since IT is triggering refresh pools off of expiry, the solution was to unbind expired subscriptions during refresh pools.

Refresh pools will now remove any expired subscriptions, along with any of its associated pools, and will revoke consumer's entitlements from these pools.
Comment 8 Bryan Kearney 2012-07-17 09:03:45 EDT
Marking all community bugs modified or beyong as closed.

Note You need to log in before you can comment on or make changes to this bug.