Bug 75036 - bind 9.2.1-1.7x.2 assertion failure on SMP
bind 9.2.1-1.7x.2 assertion failure on SMP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 17:08 EDT by bill parducci
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-04 11:05:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bill parducci 2002-10-03 17:08:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
bind fails with error: exiting (due to assertion failure)

server running kernel 2.4.18-10smp #1 SMP

per rhn server has all latest updates

server on a private network (no internet access), so DOS is not likely

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. load bind from init script
2. wait for a day
3. sift through rubble
	

Actual Results:  named[1698]: task.c:395: REQUIRE((((task) != ((void *)0)) &&
(((const isc__magic_t*)(task))->magic == ((('T') << 24 | ('A') << 16 | ('S') <<
8 | ('K')))))) failed

named[1698]: exiting (due to assertion failure)


Expected Results:  no rubble :o)

Additional info:

named[1918]: starting BIND 9.2.1 -u named
named[1918]: using 2 CPUs
named[1921]: loading configuration from '/etc/named.conf'
named[1921]: no IPv6 interfaces found
named[1921]: listening on IPv4 interface lo, 127.0.0.1#53
named[1921]: listening on IPv4 interface eth0, 192.168.252.224#53
Comment 1 Need Real Name 2002-12-06 13:05:25 EST
I received the following from ISC in response to a bug report I sent them
regarding the very same symptoms:

> There is a known race condition in lib/dns/adb.c which can
> result in this assertion.  The work around is to disable
> threads when named is built.
> 
> Note more than one bug may result in the same error message being
> produced as the error is actually at a higher level and is only
> detected by lower level functions.  The only way to determine it
> it is the same bug, when the lower level function is called in
> multiple places, is to get a stack backtrace.
Comment 2 Daniel Walsh 2003-03-04 11:05:18 EST
Check this out in the latest release with new threads package.


Note You need to log in before you can comment on or make changes to this bug.