Bug 75040 - Mozilla has incomplete requirements on gtk+
Mozilla has incomplete requirements on gtk+
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-10-03 17:50 EDT by Göran Uddeborg
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-11-03 09:47:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2002-10-03 17:50:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The gtk requirements of mozilla are met by as old packages as gtk+-1.2.8-7 from
Red Hat 7.0.  Trying that combination, however, fails because a symbol
gtk_style_get_prop_experimental is referred but not defined.

Version-Release number of selected component (if applicable): 1.0.1-24

How reproducible:

Steps to Reproduce:
1.Install gtk+-1.2.8-7 and mozilla-1.0.1-24
2.Start "mozilla -iconic" (for some reason I don't understand, giving the
non-functional argument -iconic results in a better error message)

Actual Results:  /usr/lib/mozilla-1.0.1/mozilla-bin: relocation error:
/usr/lib/mozilla-1.0.1/components/libgfx_gtk.so: undefined symbol:

Additional info:

Package gtk+-1.2.9-4 from Red Hat 7.1 obviously has this symbol defined.  An
appropriate "requires" would be "gtk+ > 1.2.8" I assume.
Comment 1 Göran Uddeborg 2003-10-26 15:08:08 EST
I guess this bug is irrelevant today.  Mozilla 1.4 does not use gtk+ at all.  I
guess it is replaced by the dependency on gtk2.

So this can be closed with a "wontfix", I guess.  (Or maybe "currentrelease", in
a way.  Anyway, the bug can be closed.)
Comment 2 Christopher Blizzard 2003-11-03 09:47:43 EST
Marking WONTFIX since we don't need gtk+ anymore (we use gtk2 instead.)

Note You need to log in before you can comment on or make changes to this bug.