Bug 750527 - Tab order differs on different platforms
Tab order differs on different platforms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-01 09:39 EDT by Kamil Páral
Modified: 2013-07-04 08:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-17 07:29:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
32b firstboot (37.13 KB, image/png)
2011-11-01 09:39 EDT, Kamil Páral
no flags Details
64b firsboot (37.19 KB, image/png)
2011-11-01 09:40 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2011-11-01 09:39:01 EDT
Description of problem:
i686 version of firstboot has tabs in a different order than x86_64 version of firstboot. The tabs "Date and Time" and "Create User" are swapped. See screenshots.

I don't think that's intentional and I believe the UI should look the same regardless of platform.

Version-Release number of selected component (if applicable):
firstboot-16.4-1.fc16.i686
firstboot-16.4-1.fc16.x86_64
Comment 1 Kamil Páral 2011-11-01 09:39:35 EDT
Created attachment 531132 [details]
32b firstboot
Comment 2 Kamil Páral 2011-11-01 09:40:01 EDT
Created attachment 531133 [details]
64b firsboot
Comment 3 Josef Skladanka 2011-11-01 10:18:50 EDT
IMHO the problem caused by the fact, that firstboot modules create_user.py and date.py have the same priority.

Next, even though the comment in firstboot/module.py says, that all modules with the same priority are sorted alphabeticaly, it is IMHO not true, because the fistboot/loader.py reads the modules from hard drive (which means in order according to their inode, not alphabeticaly) @line 62, and then the list of 'successfully loaded' modules is sorted just by the priority @line 112.

These two combined IMHO cause the fact that the 32b firstboot and 64b firstboot have different order of modules.
Comment 4 Kamil Páral 2011-11-01 10:27:36 EDT
OK, so the bug is in inode order, so it can manifest itself even with two different installations on the same architecture.

BTW, I believe there is no reason to have two modules with the same priority and sort them then according to alphabet, which gives different results for different languages. It seems like a bad idea to me. Use different priorities for all the modules so that it looks the same regardless of inode order and regardless of localization.

Note You need to log in before you can comment on or make changes to this bug.