Bug 75064 - krb5-libs does not add entry via chkconfig --add
Summary: krb5-libs does not add entry via chkconfig --add
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krb5   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-04 03:07 UTC by Stephen John Smoogen
Modified: 2007-04-18 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 17:17:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen John Smoogen 2002-10-04 03:07:39 UTC
Description of Problem:

It would seem that chkconfig needs to be used for various entries to show up in
/etc/init.d/

Doing a perusal of RPMS that didnt implement this I found:

service kdcrotate supports chkconfig, but is not referenced in any runlevel (run
'chkconfig --add kdcrotate')

Comment 1 Stephen John Smoogen 2002-10-04 16:28:18 UTC
New feature of RH 8.0 not to add items that arent needed. 

Needs to be documented in updated RELEASE-NOTES or known issues. Let technical
support add it to their DB.

Thanks Bill Nottingham.

Comment 2 Need Real Name 2003-03-26 00:29:40 UTC
The problem below is probably related since it looks like a post-install script
deficiency.

I upgraded a stock 8.0 system to the latest patches and lost ssh login
capability. I traced the problem to a lack of the krb5 library entries in
/etc/ld.so.cache. sshd worked initially so I assume that the entries were there
when the system was first installed. The assumption is that the rpm -F of the
krb packages removed the entries and neglected to add the new entries.

'ldconfig /usr/kerberos/lib' got things going again.

Comment 3 Bill Nottingham 2006-08-07 18:51:13 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.

Comment 4 Stephen John Smoogen 2006-08-26 17:17:54 UTC
This should have been fixed a long time ago.. or at least an entry from the
person  at Red Hat that it was being looked at. I am closing because its not
worth tracking anymore.


Note You need to log in before you can comment on or make changes to this bug.