Bug 75088 - grub incorrectly setup by installer - hang on restart with raid/hpt
grub incorrectly setup by installer - hang on restart with raid/hpt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 06:48 EDT by Mark Cooke
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-04 06:48:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2002-10-04 06:48:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020918

Description of problem:
KT7A-RAID, set in bios to boot from highpoint.

Software raid setup, with a raid-1 /boot, raid-0 / on two disks on the highpoint.
A backup hard disk is on the primary chain.

Having run the install, the reboot produced a hang before the grub graphical
screen was loaded, with just GRUB on the screen.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Install, with bios set to boot from ATA100 not HDD-0
2.Reboot at end of install


Actual Results:  Machine hung at a GRUB prompt, instead of starting RedHat

Expected Results:  Machine should have shown the graphical grub loader

Additional info:

I worked around this by booting rescue and chrooting to the system, then using
the grub command line directly to fix grub to boot from HDD-0 and changed the
bios to boot from hdd-0 instead of the highpoint.

Haven't tried reproducing it as it would have taken another hour to install RH8
again.  Can't see any reason it wouldn't be totally repeatable though.

Motherboard is a KT7A-RAID v1.3.
hda is a CD
hdb is a DVD/CD-RW
hdc is an 80G backup disk
hde is a 40G with raid0 and raid1
hdg is a 40G with raid0 and raid1
Comment 1 Jeremy Katz 2002-10-05 10:20:50 EDT
It is not possible on the majority of x86 systems to determine the order of boot
drives after a system has booted.  If your primary boot device is not the first
IDE drive on your system (eg, hda), you need to select to configure advanced
boot loader options in the installer and reorder the drives appropriately.

Note You need to log in before you can comment on or make changes to this bug.