Bug 750897 - user without inventory manager role cannot view resources in the resource tree
user without inventory manager role cannot view resources in the resource tree
Status: CLOSED DUPLICATE of bug 751091
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon30-sprint8
  Show dependency treegraph
 
Reported: 2011-11-02 14:06 EDT by Mike Foley
Modified: 2011-11-03 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 12:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error in UI (24.22 KB, image/png)
2011-11-02 14:06 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-11-02 14:06:25 EDT
Created attachment 531418 [details]
error in UI

Description of problem:  user without inventory manager role cannot view resources in the resource tree


Version-Release number of selected component (if applicable):
RHQ after 10/19/2011

How reproducible:
100%.  jay and mfoley

Steps to Reproduce:
1.  create role without inventory manager permission
2.  create a group ...with some resources
3.  add the group to the role
4.  create a user ... with this role
5.  navigate to resource tree --> all resources
6.  click on an item
7.  observe error (see attachment)
  
Actual results:
error.  see attachment

Expected results:
ability to view resource


Additional info:
Comment 1 Heiko W. Rupp 2011-11-03 12:45:18 EDT
Closing this one, as 751091 has more detailed instructions on how to test


[17:24:28] <jshaughn> mfoley|lunch: I didn't see https://bugzilla.redhat.com/show_bug.cgi?id=750897, I think you can mark that as a duplicate of the one I created, https://bugzilla.redhat.com/show_bug.cgi?id=751091

*** This bug has been marked as a duplicate of bug 751091 ***

Note You need to log in before you can comment on or make changes to this bug.