Bug 750981 - gedit spell checker plugin instsll should also install dictionary for system default language
gedit spell checker plugin instsll should also install dictionary for system ...
Status: CLOSED DUPLICATE of bug 750986
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-03 01:12 EDT by collura
Modified: 2012-08-01 04:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 04:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description collura 2011-11-03 01:12:55 EDT
Description of problem:

  gedit spellchecker plugin in installed by default with gedit but 
  without a spell check dictionary 
  so whatever you type gets marked as mispelled.

  if gedit is installed with spellchecker plugin then there should pull 
  in the dictionar(y/ies) for the system default language(s) as well.

  the tools-set_language doesnt seem to have any listed 
  languages to select by default.

  since default seems to be no language selected 
  seems like everything i typed aside from ';' was 
  considered mispelled lol.  

  installed a hunspell-$2digit_country_code dictionary rpm 
  so then languages are listed in the gedit-tools-set_language list
  the next time you open gedit.

  then could select a language to check spelling against
  so not everything you type shows as being mispelled
  assuming you can type in that language. ;')

  
Version-Release number of selected component (if applicable):

  in fc16-gnome-rc2 :

    gedit-2:3.2.1-1.fc16 (64bit)
    gedit-plugins-3.2.0-1.fc16 (64bit)

How reproducible:

 always

Steps to Reproduce:
1. install gedit
2. select no language from empty list of languages in gedit-tools-set_language
3. correctly type something in the tongue of the system default language
4. watch the red wiggly underline decry your typing as mispelt.
  
Actual results:

 all system-default-languagey worden you correctly type be marked as mispelled

Expected results:

 worden you correctly type in the system-default-language
 not be marked as beink mispelt.

Additional info:
Comment 1 Caolan McNamara 2012-08-01 04:51:08 EDT

*** This bug has been marked as a duplicate of bug 750986 ***

Note You need to log in before you can comment on or make changes to this bug.