Bug 75099 - character set line drawing G0 G1 G2 G3
character set line drawing G0 G1 G2 G3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: termcap (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Raszyk
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 11:27 EDT by Eric
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version: termcap 5.4 Release 7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 12:30:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric 2002-10-04 11:27:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; MSNIA; Windows 98; MSNIA)

Description of problem:
The line drawing character sets are not available under RedHat 8.0.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. From command line, echo desire line drawing ESC mode and character:
2.     #  echo -e "ESC[12mMMMMMMM ESC[10m"
     or
       # echo -e "^Nqqqqqqq^O"
3. 

Actual Results:  Line drawing characters are not displayed.

Expected Results:  Either command should set character mode and echo 
appropriate line drawing character.

Additional info:

It apears that the termcap entries are the same for linux| console| and xterm| 
as previous versions of RedHat.  I'm not sure exactly where the problem is, 
whether it's termcap or somewhere else.

This capability should be available on any type of installation to support 
third party software.
Comment 1 Scott Navarre 2003-02-27 06:59:49 EST
  I believe it has to do with RH 8.0's new default unicode font system.

  This also causes display problems in third-party software BASIS Pro5 
(www.basis.com), a "Business BASIC" interpreter which uses termcap.  Pro5 works 
fine in RH 7.1, but in RH 8.0 it no longer displays line drawing characters and 
no longer allows for characters to be bold (set to be brighter than other 
characters).
  I have found a few workarounds...

  If you enter the following:
# echo -e \\033%@
it will set the current console screen to use the default character set (ISO 
646/ISO 8859-1), allowing line drawing characters to again be displayed 
properly.

  The problem with character brightness seems more complicated.  If you enter 
the following command:
# setfont
it sets the linux console to use the default font without unicode, which allows 
brightness to work again (even when doing a 'man').
  The problem is that when you log into another console screen, it does its 
default 'setfont <something>' when logging in, which resets the font across all 
console screens, which has the effect of resetting the font for the first 
screen on which you entered the 'setfont' workaround before -- this can cause 
some unreadable characters to appear when switching back to the first screen.
  To illustrate, try the following:
1) Log in to tty1 as 'root' and leave tty2 with a "login" prompt.
2) # man echo
3) Notice that the text in the 'man' page is all gray.
4) Exit 'man'.
5) # setfont
6) # man echo
7) Now see that the 'man' page is properly displayed (gray w/ white highlights).
8) Then with 'man' still running on tty1, switch to tty2 and login as 'root'.
9) Now go back to tty1 and see that the brightness has disappeared and some 
characters are unreadable, but when you scroll the man page down (to put the 
unreadable characters off-screen) and then back up again, it fixes those bad 
characters -- although the brightess is still gone.
10) Now go to tty2 and enter 'setfont' on that screen.
11) Finally, go back to tty1 and scroll the man page down and back up to see 
the brightness return.

  When combining these 2 work arounds:
# echo -e \\033%@
# setfont
it causes everything in Pro5 to display properly -- line drawing characters and 
brightness problems are both fixed.
  But if not in Pro5 and using both these commands, then doing something from 
the linux console shell (like a 'man echo') will cause the characters which are 
highlighted on the 'man' page to be unreadable.

  And even though these 2 commands temporarily fix display problems in Pro5, 
because 'setfont' is used if you log into another console screen and come back 
to the Pro5 screen: the brightness is lost for good, and other characters are 
garbled until the screen is redrawn by whatever BASIC program is running.
Comment 2 Petr Raszyk 2006-01-12 12:30:55 EST
I have not tried your example in Red Hat Linux 8.0
but it works fine in FEDORA CORE 4.
That is why I am not able to say where 'a possible bug' was.
I will close this 'issue': Fixed in current release.

Launch at the command prompt: nohup xterm &
Launch at the command prompt: export LANG=en_US
Launch at the command prompt: export TERM=xterm
Launch at the command prompt: tput smacs
Launch at the command prompt: qqqqqqqqq
Launch at the command prompt: <Enter-key>
Launch at the command prompt: tput sgr0

NOTE: a) 'tput' reads terminfo-database (not /etc/termcap).
      b)  /etc/termcap should not be used
      c) Launch at the command prompt (for more info):
         man tput
         man termcap
         man terminfo



Note You need to log in before you can comment on or make changes to this bug.