Bug 751131 - Systemd-logind hangs after F14->F16 upgrade
Systemd-logind hangs after F14->F16 upgrade
Status: CLOSED DUPLICATE of bug 737731
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
16
All Linux
high Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-03 11:54 EDT by Richard Marko
Modified: 2016-01-31 21:21 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 12:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Marko 2011-11-03 11:54:49 EDT
Description of problem:
GDM login and su - both hang.

Version-Release number of selected component (if applicable):
systemd-36-3.fc16.x86_64
dbus-1.4.10-3.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install and fully update F14 (livecd-desktop)
2. Preupgrade to F16
3. Log-in
  
Actual results:
Log-in (and su -) takes more then 25 seconds

Expected results:
No delay

Additional info:
/var/log/messages:

Nov  3 18:00:38 localhost dbus[843]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Nov  3 18:00:38 localhost dbus-daemon[843]: dbus[843]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Nov  3 18:00:38 localhost systemd-logind[1603]: Failed to open /sys/class/tty/tty0/active: No such file or directory
Nov  3 18:00:38 localhost systemd-logind[1603]: Failed to fully start up daemon: No such file or directory
Nov  3 18:00:38 localhost systemd[1]: systemd-logind.service: main process exited, code=exited, status=1
Nov  3 18:00:38 localhost systemd[1]: Unit systemd-logind.service entered failed state.
Nov  3 18:01:03 localhost dbus[843]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Nov  3 18:01:03 localhost dbus-daemon[843]: dbus[843]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Nov  3 18:01:06 localhost dbus-daemon[843]: ** Message: No devices in use, exit
Comment 1 Richard Marko 2011-11-03 12:00:37 EDT
GRUB problem - after preupgrade system is still running grub 0.97 which is missing F16 entries.

Reassigning to preupgrade.

# uname -a
Linux localhost.localdomain 2.6.35.14-100.fc14.x86_64 #1 SMP Fri Oct 21 18:40:08 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Comment 2 Richard Marko 2011-11-03 12:08:21 EDT

*** This bug has been marked as a duplicate of bug 737731 ***

Note You need to log in before you can comment on or make changes to this bug.