Bug 7512 - redhat 6.1 Samba is not working!
redhat 6.1 Samba is not working!
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
: 7560 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-02 11:02 EST by y2ktux
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-31 13:28:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description y2ktux 1999-12-02 11:02:56 EST
In redhat 6.0 you could include samba and make sure that it was running and
the system would present itself to the NT network with a workgroup and the
machine name without even touching etc/smb.conf

Something is different a service is missing or not started and the
workgroup and server never appear in the network.

I have had a service request in for 4 days at a level 2.  Service request
number 127514 .... it has not been assigned a problem number or a
resolution time frame.   This box was waiting to go into production for
Print services.  It has now been replaced by an NT machine.  Tell me what I
have done wrong PLEASE!
Comment 1 Bill Nottingham 1999-12-02 12:38:59 EST
What does your /etc/hosts look like?
Comment 2 y2ktux 1999-12-03 11:15:59 EST
# Begining of  My /etc/hosts looks as follows:

127.0.0.1       localhost.localdomain    localhost
10.0.0.90       prtbldg2.adc_domain      prtbldg2
10.0.10.41      adc_smb1.adc_domain      adc_smb1

10.0.10.1       dewaal1.adc_domain       dewaal1
10.0.10.5       dewwaal5.adc_domain      dewaal5

# EOF
In 6.0 Redhat.... Out of the box a myworkgroup workgroup is seen on the network
as soon as the smb daemon is started.  With nothing being done to either
/etc/hosts or /etc/smb.conf

After many days of work we cannot get any 6.1 redhat server to show any presence
on the network.   Even in testing on a two system network.  The devices can be
telneted into logon to and successfully controlled.

What name service is broken.... not configured.... not installed?  I installed
everything and both nmb and smb services are running as per top.

The problem is that this server does not broadcast its presence to the network
neighborhood.
Comment 3 Bill Nottingham 1999-12-06 12:17:59 EST
What happens if you change the 'interfaces' line in /etc/smb.conf
to reflect the interfaces you are using?
Comment 4 stearnscomputer 1999-12-07 11:37:59 EST
I am having the same problem with somba rh6.1. Upgraded 6.0 to 6.1 and used
backup smb. conf server worked ok. However new system loaded with 6.1 will not
work tried usinf the smb.conf from upgraded system no go. have tried about
everything I can think of. thought it must be my problem. can't believe RH
would send out a release of sombe twice 5.2 and 6.1 that was not tested. got
burnt on both.
please help!!
Comment 5 Rex Dieter 1999-12-07 12:10:59 EST
Just to throw in my $0.02.  I've been using samba heavily ever since version
2.0.3, (and now using samba-2.0.6-1 from rawhide), and have found each release
to function very well.

In my experience, most samba problems, including the ones mentioned here, seem
to have more to do with samba/network misconfigurations rather than a broken
samba binary distribution.

Perhaps you should read up on samba's documentation, (see
http://us2.samba.org/samba/docs) especially those parts (in smb.conf manpage)
pertaining to "preferred master", "remote browse sync", and "wins server".  If
you have a hardcore NT network, I'd suggest configuring an NT server as a WINS
server, and configure all client machines (including samba) as WINS clients.
Comment 6 Michel Nolf 1999-12-08 09:51:59 EST
I had the same problem. After a brand new installation of RH 6.1, no way to see
the Samba in the browse list.
I found some strange message in the log.nmbd saying that nmbd could not define
the name on my Wins server (an NT box).
I run the Netmon on NT and didn't see any traffing related to SMB coming out of
my Linux.
I define the interface in smb.conf and everything works correctly: registration
in the wins serever and browse list annoncement.
This is really annoying as the ip address of my Linux in given by DHCP.
It seems that this is solve in the next release of Samba where the interface
can be definded using the device name but I didn't test it yet.
Comment 7 Bill Nottingham 1999-12-08 18:17:59 EST
*** Bug 7560 has been marked as a duplicate of this bug. ***If your /etc/hosts has something like:

127.0.0.1 localhost localhost.localdomain <some hostname>

try removing the other hostname.
Comment 8 Jimmy Selgen 1999-12-16 04:14:59 EST
It's the same problem here :(.... Samba doesnt report itself to the network...
shares are working ok (a \\<servername> will still list the shares on
the server), but domain network login's doesnt work.

something has gone terribly wrong from 6.0 to 6.1... In 6.0 i had absolutely no
problems connecting to my linux box...
Comment 9 Jimmy Selgen 1999-12-25 06:00:59 EST
Hmmm... i think i fixed it...
set the interfaces=<your ip network>

now i can make domain logon's, see shares and all

Jimmy
Comment 10 flynn 2000-01-31 12:55:59 EST
Had the same problem today.
log.nmb reports pbs : libsmb/nmblib.c:send_udp(754)
Packet send failed to xxxx(137)ERRNO=Paramhtre invalide
it's in a "sendto" call and the actual errno value is 22 despite the fact that
all parms from this call look correct.

Removing <some hostname> from /etc/hosts in line :
127.0.0.1 localhost localhost.localdomain <some hostname>
fixes it (as I read from notting's comment above).
Flynn

Note You need to log in before you can comment on or make changes to this bug.