Bug 75120 - X11 startup hangs if home on NFS mount
Summary: X11 startup hangs if home on NFS mount
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-04 16:59 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 21:52:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-04 16:59:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When a user's home directory is located on a NIS mounted file system, starting
up the X server/desktop will cause a blank screen with a curser icon.  Startup
will never completes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount a NFS directory using NIS.
2.create a new user, placing its home directory on the NIS server.
3.log out, then re-login as the new user.
4. execute a "startx" if needed (not logging in graphical mode).
	

Actual Results:  From a graphical login, a blank blue screen with an arrow mouse
pointer.
From a "startx", a black screen with a "X" mouse pointer.

Expected Results:  The desktop should come up.

Additional info:

No errors in X log.  No errors in system log.  Happens on both SMP and UP IA32
P4 systems.  NFS server is a RH linux 7.2 system (Dell 6300).

Comment 1 Need Real Name 2002-10-04 17:06:43 UTC
Sorry about typo; should be "NFS mounted directory".

Also, we hard-mount, not automount, the file system for the test.

Comment 2 Mike A. Harris 2002-10-05 22:07:08 UTC
Is anything else NFS mounted?  Could you provide the output of the
mount command showing all mount points?

Comment 3 Alan Cox 2002-10-05 22:11:28 UTC
I'm doing NFS /home with 8.0 and no problems. What else is NFS mounted.

What happens if you do:

X :0 &
(switch to text mode)
DISPLAY=:0 xterm
in the xterm
Xnest :1
DISPLAY=:1 gnome-session

- that will firstly test basic X stuff, then let you see the session start up
both text and graphics at once




Comment 4 Mike A. Harris 2002-10-06 01:51:38 UTC
Please note, that /tmp must not be on NFS.

Comment 5 Need Real Name 2002-10-07 21:02:38 UTC
Followed the proceedure, but....

at "Xnest :1", the graphic display reset to a blank grey screen with
a "x" mouse curser.  No window was available/accessable to start the
gnome session.

So, I swithed to another virtual terminal, logged in as the same test
user, and issued the "DISPLAY=:1 gnome-session" command from there.

At which time, nothing happened (except the prompt did not come back,
since it was pending the command completeion).

Switching to the graphic display shows the same blank screen with
a mouse curser.


Comment 6 Need Real Name 2002-10-07 21:52:29 UTC
Further info:

Our main server (the one that fails) is RH 7.1, not 7.2.

Tested with home directories mounted from RH 7.3, Irix 6.5.15, and
Solaris 5.6 systems; all work (although the RH 7.3 system starts
slowest despite being on the most powerful computer).




Comment 7 Mike A. Harris 2002-11-03 10:28:02 UTC
Starting "Xnest :1" is doing what is expected. You should get a stipple
patterned background with an X cursor.  No clients should be started since
no clients were requested to be started.

I'm unable to reproduce the problem you are describing.  Alan has mentioned
it works for him ok also, and I've had 2 others confirm it works for them
too.  I must conclude that you're either misconfiguring something, or you
aren't doing things 100% correctly.  This sounds like more of a technical
support issue than a bug to me.  Please try the xpert@xfree86.org mailing
list for configuration/usage assistance.

Closing bug 'WORKSFORME'


Note You need to log in before you can comment on or make changes to this bug.