Bug 751246 - Example script: group app deployment
Example script: group app deployment
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: CLI (Show other bugs)
4.3
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: JON 3.0.0,RHQ 4.3.0
Assigned To: Lukas Krejci
Mike Foley
:
Depends On:
Blocks: jon30-sprint8 756250
  Show dependency treegraph
 
Reported: 2011-11-03 22:34 EDT by Charles Crouch
Modified: 2015-02-01 18:27 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 756250 (view as bug list)
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2011-11-03 22:34:38 EDT
Need a CLI script which will do the all of the following steps:

1) Use the bundles sub system to provision a new app to a group of JBAS servers. 
2) Schedule for immediate execution a group operation to shut the JBAS servers down one at a time
3) Schedule for immediate execution a group operation to start them up one at a time

The script should just require the name of the group to deploy to and the application bundle .zip
Comment 1 Lukas Krejci 2011-11-15 06:34:27 EST
Note that because of the nature of the bundle API, it is not enough to supply just the name of the group and the bundle zip to create an application in JBAS - we need to a) create destination for deploying the app to and b) supply the bundle deployment configuration. Please look inside the scripts (when you install the CLI, they are present in the $CLI_HOME/samples directory) to review their documentation.

master: http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=6fa90ab75091ba17e9ac07dbd5c95d73c60c0adc
release_jon3.x: http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=c66ac42423a93a24efb161d20db26eb8be587647

    [BZ 751246] - Sample scripts for deploying apps to JBAS.
    
    bundles.js contains generic functions to deploy stuff using the bundle
    subsystem.
    
    deploy-to-and-restart-JBAS.js - contains functions to create and update
    applications deployed to JBAS instances in a group with a sub-sequential
    restart of the JBAS instances.
Comment 2 Lukas Krejci 2011-11-15 10:05:11 EST
master: http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=8145ed069b7e2839e7ed29593ed814dfbc2e91ab

release_jon3.x: http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=9bbdb09472c5735fb43d8e1a7f2ce4ffd98f1f8f

    [BZ 751246] - do NOT include implicit resources in the list of resource
    group members when determining the group member ids in the script.
Comment 3 Mike Foley 2011-11-17 11:30:28 EST
sample code exists in CLI download .zip in the samples folder.  jon 3 branch.
Comment 4 Mike Foley 2012-02-07 14:26:25 EST
marking VERIFIED JON 3 bugs to CLOSED/CURRENTRELEASE
Comment 5 Mike Foley 2012-02-07 14:28:03 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.