This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 751268 - Upgrading or reinstalling kernel throw error message "grubby fatal error: unable to find a suitable template"
Upgrading or reinstalling kernel throw error message "grubby fatal error: una...
Status: CLOSED DUPLICATE of bug 730357
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 02:29 EDT by Jaroslav Pulchart
Modified: 2011-11-25 10:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 10:24:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
reinstall log (1.40 KB, text/plain)
2011-11-04 02:29 EDT, Jaroslav Pulchart
no flags Details
grub2 menu.lst post-transaction (749 bytes, text/plain)
2011-11-04 20:08 EDT, Julian Sikorski
no flags Details
proper file (5.37 KB, text/plain)
2011-11-04 20:09 EDT, Julian Sikorski
no flags Details
Newer grub.cfg (2.58 KB, text/plain)
2011-11-14 03:10 EST, Julian Sikorski
no flags Details

  None (edit)
Description Jaroslav Pulchart 2011-11-04 02:29:08 EDT
Description of problem:
Upgrading or reinstalling kernel throw this error message "grubby fatal error: unable to find a suitable template"

Version-Release number of selected component (if applicable):
F16

How reproducible:
easy

Steps to Reproduce:
1. boot to older kernel (for example 3.1.0-5)
2. reinstall the new kernel (for example 3.1.0-7) by this command
   $ yum reinstall kernel -y 2>&1 | tee reinstall.log
  
Actual results:
reinstall.log include this error message: "grubby fatal error: unable to find a suitable template"

Expected results:
kernel upgrade/reinstall without error

Additional info:
tested on 2x nodes i686 and x86_64, booth of them were upgraded from F15 to F16
Comment 1 Jaroslav Pulchart 2011-11-04 02:29:48 EDT
Created attachment 531700 [details]
reinstall log
Comment 2 Julian Sikorski 2011-11-04 20:08:02 EDT
Created attachment 531862 [details]
grub2 menu.lst post-transaction

I just hit the same problem. Yet, the new grub config seems fine, saving for the lack of failsafe entry for the new kernel.
Comment 3 Julian Sikorski 2011-11-04 20:09:51 EDT
Created attachment 531863 [details]
proper file
Comment 4 Jaroslav Pulchart 2011-11-05 04:04:32 EDT
Yes, "failsafe" entry is missing. 

I'm also "confused" from 
printing 'Loading Fedora (3.1.0-1.fc16.x86_64)' in each boot even if the kernel version is different:

menuentry 'Fedora (3.1.0-7.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
  ...
  echo 'Loading Fedora (3.1.0-1.fc16.x86_64)'
  ...
}
Comment 5 Jaroslav Pulchart 2011-11-06 03:15:48 EST
I created 2x new bugs about grub.cfg: 751604, 751603

I don't know is they are relative to this issue or not.
Comment 6 Julian Sikorski 2011-11-14 03:10:51 EST
Created attachment 533453 [details]
Newer grub.cfg

Even with no failsafe entries in grub.cfg at the start of the transaction this issue still happens.
And same as in comment 4, the "Loading Fedora" line announces an incorrect kernel.
Comment 7 Mads Kiilerich 2011-11-25 10:24:44 EST

*** This bug has been marked as a duplicate of bug 730357 ***

Note You need to log in before you can comment on or make changes to this bug.