Bug 751294 - yum does not write to stderr raised exception by plugin, which inherit from YumBaseError.
Summary: yum does not write to stderr raised exception by plugin, which inherit from Y...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools   
(Show other bugs)
Version: 5.7
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Stephen Herr
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords: Patch
: 996453 (view as bug list)
Depends On: 595837
Blocks: 1049888 751292
TreeView+ depends on / blocked
 
Reported: 2011-11-04 08:51 UTC by Miroslav Suchý
Modified: 2014-09-16 00:25 UTC (History)
11 users (show)

Fixed In Version: rhn-client-tools-0.4.20.1-8-el5
Doc Type: Bug Fix
Doc Text:
Cause: An error class in rhn-client-tools did not correctly sub-class the yum errors. Consequence: Some networking problems would throw a traceback instead of getting correctly logged or reported on the command line. Fix: Update the Error inheritance structure. Result: Errors should now get correctly logged and reported.
Story Points: ---
Clone Of: 595837
Environment:
Last Closed: 2014-09-16 00:25:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Subclass YumBaseError without defining __len__ = None. (706 bytes, patch)
2013-12-17 09:37 UTC, Zdeněk Pavlas
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1215 normal SHIPPED_LIVE rhn-client-tools bug fix update 2014-09-16 04:16:07 UTC

Comment 1 James Antill 2011-11-16 15:53:51 UTC
99% sure this will be a unicode thing ... as logger eats unicode instead of doing a Unicode exception.

Comment 2 Zdeněk Pavlas 2013-03-08 14:14:12 UTC
Quickly searched the code.. Seems this is the only place where Yum sends to_unicode() to logger.  Fixing this very likely fixes BZ 824663 too.

Comment 4 RHEL Product and Program Management 2013-05-01 06:41:14 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 5 Zdeněk Pavlas 2013-12-16 16:19:31 UTC
This is a bug in the subclass.

class Error(YumBaseError):
    ...
    def __getattr__(self, name):
        if name == 'errmsg':
            return self.value
        # >>> implicit "return None" here <<<

The Error instance is passed to the logging module which checks if the argument is a non-empty dictionary with something like: "if e and type(e) == dict".

The first test checks for the presence of __len__ method and tries to call it, raising "NoneType is not callable" error in turn.  We have to make sure __len__ is not defined by raising an AttributeError in __getattr__.

Comment 6 Zdeněk Pavlas 2013-12-17 09:37:55 UTC
Created attachment 837608 [details]
Subclass YumBaseError without defining __len__ = None.

Comment 7 Milan Zázrivec 2013-12-17 11:41:49 UTC
*** Bug 996453 has been marked as a duplicate of this bug. ***

Comment 8 Stephen Herr 2014-03-27 16:49:16 UTC
There is no direct analogue for this bug for spacewalk client tools because these Spacewalk master commits obsolete it:
33666946
c9f19840

Comment 13 errata-xmlrpc 2014-09-16 00:25:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1215.html


Note You need to log in before you can comment on or make changes to this bug.