Bug 75133 - playing music on smp results in hard freeze
playing music on smp results in hard freeze
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 14:42 EDT by Gene Czarcinski
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 10:30:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/proc/cpuinfo (864 bytes, text/plain)
2002-10-04 16:41 EDT, Gene Czarcinski
no flags Details
/proc/devices (403 bytes, text/plain)
2002-10-04 16:41 EDT, Gene Czarcinski
no flags Details
/proc/driver/emu10k1 info (469 bytes, text/plain)
2002-10-04 16:42 EDT, Gene Czarcinski
no flags Details
/proc/interrupts (721 bytes, text/plain)
2002-10-04 16:43 EDT, Gene Czarcinski
no flags Details
lspci (1.12 KB, text/plain)
2002-10-04 16:43 EDT, Gene Czarcinski
no flags Details
lspci -vv (7.50 KB, text/plain)
2002-10-04 16:44 EDT, Gene Czarcinski
no flags Details
lsmod (1.40 KB, text/plain)
2002-10-04 16:45 EDT, Gene Czarcinski
no flags Details
/proc/meminfo (603 bytes, text/plain)
2002-10-04 16:46 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2002-10-04 14:42:15 EDT
Description of Problem:
The system is a dual processor PIII and I have had the problem with an Ensoniq
sound card (ES1370 drive) and the SB Live sound card (emu10k1 driver).

Using various sound applications such as realplay, xmms, and mplayer, sometimes
the system will hang in a hard freeze (and sound loop) -- requires a hardware
reset or power cycle.  In addition, I also cannot ssh into the system from
another system.  Furthermore, I have this system on a Belkin KVM box and when it
hangs, I cannot use the keyboard or the Belkin switch to change to another
system ... hardware reset is the only way to get out.

When the system hangs, the sound "loops" with a usually short segment which will
repeat until the hardware reset.

As far as showing the problem, I have found that using xmms to play various ogg
files rip'ed from cds will demonstrate the problem.

Note that there is nothing in any of the logs to show the problem.

I suspect that the kernel is going into some kind of loop with everything disabled.

Note that I do not see the problem if I reboot and run the non-smp kernel.

Version-Release number of selected component (if applicable):
8.0, kernel-smp-2.4.18-14

How Reproducible:
yes but not predictable.  Somtimes it will run for hours before a freeze and
others only a couple of minutes.  Processor activity can be light or heavy.

Steps to Reproduce:
1. boot smp kernel
2. run some applications which will play lots of music.
3. 

Additional Information:
	
I do not know if just playing cd's will cause the problem but I doubt it.

There is really no way around this other than "don't do that" which just will
not work for me.
Comment 1 Gene Czarcinski 2002-10-04 16:40:25 EDT
The motherboard is a ABit VP6 with no on-board sound card ... the SB Live is a
pci card.  Other info attached.
Comment 2 Gene Czarcinski 2002-10-04 16:41:10 EDT
Created attachment 78724 [details]
/proc/cpuinfo
Comment 3 Gene Czarcinski 2002-10-04 16:41:59 EDT
Created attachment 78725 [details]
/proc/devices
Comment 4 Gene Czarcinski 2002-10-04 16:42:38 EDT
Created attachment 78726 [details]
/proc/driver/emu10k1 info
Comment 5 Gene Czarcinski 2002-10-04 16:43:15 EDT
Created attachment 78727 [details]
/proc/interrupts
Comment 6 Gene Czarcinski 2002-10-04 16:43:59 EDT
Created attachment 78728 [details]
lspci
Comment 7 Gene Czarcinski 2002-10-04 16:44:36 EDT
Created attachment 78729 [details]
lspci -vv
Comment 8 Gene Czarcinski 2002-10-04 16:45:50 EDT
Created attachment 78730 [details]
lsmod
Comment 9 Gene Czarcinski 2002-10-04 16:46:25 EDT
Created attachment 78732 [details]
/proc/meminfo
Comment 10 Gene Czarcinski 2002-10-05 19:20:44 EDT
Oh, not good, not good.  I put a fresh install of 7,3 on this system and applied
all errata including kernel-smp-2.4.18-10.

The problem occurs!  This looks bad!
Comment 11 Gene Czarcinski 2002-10-07 10:30:52 EDT
OK, I am going to leave this open for a while but I believe the problem is the
POS HPT370 controller that I am using.

Because the new DVD-RW drive I installed would not blank cdrw's, I installed a
fifth ide device on the builtin HPT370 controller.  While I was getting some
error message in /var/log/messages about the device, it did seem to operate
properly.  However, when I ran nmi_watchdog=1 and got the OOPS, it seemed to
point to this controllers driver.  Therefore, I have pulled the device and will
continue testing to see the freeze occurs again.  If it does not appear in a
week, I will close this report.
Comment 12 Gene Czarcinski 2002-10-10 05:43:05 EDT
no re-occurance ... closing

Note You need to log in before you can comment on or make changes to this bug.