Bug 751331 - Glibc AVX patches required for building PHP with PDO on Sandy Bridge CPU
Summary: Glibc AVX patches required for building PHP with PDO on Sandy Bridge CPU
Status: CLOSED DUPLICATE of bug 752122
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Andreas Schwab
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-04 11:37 UTC by Iain Kay
Modified: 2016-11-24 16:00 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-11-10 15:14:53 UTC


Attachments (Terms of Use)

Description Iain Kay 2011-11-04 11:37:11 UTC
Description of problem:
When attempting to build PHP with PDO (PHP Data Objects) module the resulting binary cannot execute when loading pdo module in php.ini.
Updating Glibc to 2.14.90-14 from Fedora 16 testing fixes the issue and allows PHP to execute.

Version-Release number of selected component (if applicable):
Glibc 2.12

How reproducible:
Build PHP with --enable-pdo and the resulting binary will not execute.

Steps to Reproduce:
1. Download PHP 5.3.8 from php.net, untar and enter directory.
2. Configure installation with --enable-pdo.
3. Build and install (make && make install)
4. Execute php and ask for version.
  
Actual results:
root@46-20-236-35 [~]# php -v
Illegal instruction
root@46-20-236-35 [~]# 


Expected results:
root@46-20-236-35 [~]# php -v
PHP 5.3.8 (cli) (built: Nov 4 2011 10:47:26) 
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
root@46-20-236-35 [~]# 

Additional info:
root@46-20-236-35 [~]# cat /usr/lib/php.ini | grep pdo
extension=pdo.so
extension=pdo_sqlite.so
extension=pdo_mysql.so
root@46-20-236-35 [~]#

Comment 2 Andreas Schwab 2011-11-04 12:14:49 UTC
Where does it crash?

Comment 3 Iain Kay 2011-11-04 12:23:38 UTC
The compilation doesn't crash per-sé it finishes with make status 0 and then the resulting binary of PHP is fine until loading PDO modules in php.ini.

The same build works fine on RHEL 5.5/5.6 with or without PDO.

cPanel (www.cpanel.net) Support put me on to the fact that it could be Glibc version, and after having patched that out with the f16 packages the build completes in the same way however loading the PDO module works fine.

The only way to tell that it has any issues at all are to execute the php application from the command line where one is presented with the error message: "Illegal instruction".

Comment 4 Andreas Schwab 2011-11-04 12:52:40 UTC
Where does it crash?

Comment 5 RHEL Product and Program Management 2011-11-08 06:47:21 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Andreas Schwab 2011-11-10 15:14:53 UTC

*** This bug has been marked as a duplicate of bug 752122 ***


Note You need to log in before you can comment on or make changes to this bug.