Bug 751339 - rpc.idmapd doesn't autoconfigure domain on startup
rpc.idmapd doesn't autoconfigure domain on startup
Status: CLOSED DUPLICATE of bug 748275
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 08:15 EDT by Jeff Layton
Modified: 2011-11-14 12:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-14 12:30:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2011-11-04 08:15:58 EDT
I recently switched my main workstation at home to f16. Since then, rpc.idmapd does not properly pick set the idmapping domain at boot time. If I go in after
booting and do a "service nfs-idmap restart" then it will work properly. It
also works properly if I set the domain explicitly in /etc/idmap.conf.

I suspect the problem is a boot-time ordering issue. rpc.idmapd is likely being started before the hostname is properly set on the machine. I'm not sure exactly how to fix this -- we may need some systemd expertise.

In any case -- perhaps it's time to move to the new idmapper anyway?
Comment 1 Steve Dickson 2011-11-14 12:30:36 EST

*** This bug has been marked as a duplicate of bug 748275 ***

Note You need to log in before you can comment on or make changes to this bug.