Bug 75147 - need to skip asking for boot disk creation when no floppy exists
Summary: need to skip asking for boot disk creation when no floppy exists
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-04 19:52 UTC by Tom Wood
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 05:00:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Wood 2002-10-04 19:52:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
anaconda shouldn't even ask about creating a boot disk when there's no
floppy/zip/ls100 in the machine.  Answering "yes" could ruin a newbie's day.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RHL.
2.Answer yes to create boot disk when you don't have a drive.
3.Sit in amazement as the install hangs ad nauseum.
	

Actual Results:  The system will hang.

Expected Results:  anaconda shouldn't even ask.

Additional info:

If I were a n00b, I'd be really disgusted that I'd gone through all that package
selection only to see my install hang.  Since I'm not a n00b but just plain old
st00pid, I worked around this with deft use of <ctrl-alt-f something or another>
and a well-placed kill -9.

Maybe by 8.1 I won't be able to shoot myself in the foot anymore...

Comment 1 Jeremy Katz 2002-10-07 15:18:12 UTC
Unfortunately, you can't really tell with any degree of certainty that there's
*not* a floppy drive connected on an x86 machine.  Even on machines without a
drive, the controller usually shows up and masquerades that a floppy is present.
 We'll try to make it more clear, though

Comment 2 Tom Wood 2002-10-07 17:47:07 UTC
Understood. Quote from linux/kernel/i386/i8259.c:

* Careful.. Not only is IRQ13 unreliable, but it is also
* leads to races. IBM designers who came up with it should
* be shot.

Now, if there were just some way to kill off an errant request to create a boot
disk that's user-friendly, we'd be better off than we are now...


Comment 3 Jeremy Katz 2003-07-09 05:00:13 UTC
We skip asking if we can't detect a floppy with kudzu now.

Comment 4 Tom Wood 2003-07-12 00:51:44 UTC
Wonderful - thank you.  Got a lot of machines now w/o floppies.


Note You need to log in before you can comment on or make changes to this bug.