Bug 751495 - 'setup-ds.pl -u' fails with undefined routine 'updateSystemD'
Summary: 'setup-ds.pl -u' fails with undefined routine 'updateSystemD'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Install/Uninstall
Version: 1.2.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks: 690319 389_1.2.10 746589 781506
TreeView+ depends on / blocked
 
Reported: 2011-11-04 21:47 UTC by Nathan Kinder
Modified: 2015-12-07 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 781506 (view as bug list)
Environment:
Last Closed: 2015-12-07 16:38:31 UTC


Attachments (Terms of Use)

Description Nathan Kinder 2011-11-04 21:47:17 UTC
During some testing, I tried to run 'setup-ds.pl -u' manually in offline mode using a local master build on F14.  I ran into this error:

-----------------------------------------------------------
Which update mode do you want to use? [quit]: offline
[04/Nov/2011:14:38:43 -0700] - check_and_set_import_cache: pagesize: 4096, pages: 1004304, procpages: 50596
[04/Nov/2011:14:38:44 -0700] - Import allocates 1606884KB import cache.
[04/Nov/2011:14:38:44 -0700] Upgrade DN Format - userRoot: Start upgrade dn format.
[04/Nov/2011:14:38:44 -0700] Upgrade DN Format - Instance userRoot in /var/lib/dirsrv/slapd-localhost/db/userRoot is up-to-date
Undefined subroutine &DSUpdate::updateSystemD called at /usr/lib64/dirsrv/perl/DSUpdate.pm line 419.
-----------------------------------------------------------

I believe this is blocking the upgrade code from performing further updates.

Comment 1 Rich Megginson 2011-11-04 23:23:46 UTC
commit 88450a966bbae99d6a7798d089ec3627e9bd3e5a
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Fri Nov 4 15:47:36 2011 -0600
    Reviewed by: nkinder (Thanks!)
    Branch: master
    Fix Description: needed to import that function from DSCreate
    Platforms tested: RHEL6 x86_64, Fedora 15
    Flag Day: no
    Doc impact: no

Comment 2 Rich Megginson 2012-01-10 20:18:11 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/239

Comment 3 Amita Sharma 2012-04-25 08:49:34 UTC
Tested the upgrade from RHEL 6.2 389-ds-base to RHEL 6.3 389-ds-base - Working
Fine, hence VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.