Bug 751553 - [abrt] starcal-1.9.4-1.fc15: preferences.py:450:__init__:RuntimeError: bad option type "Tune Hijri Monthes"
Summary: [abrt] starcal-1.9.4-1.fc15: preferences.py:450:__init__:RuntimeError: bad op...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: starcal
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hedayat Vatankhah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:be63bcee6dcdc0c8e74f9da1117...
: 759519 759523 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-05 12:38 UTC by Hosein Hamedi
Modified: 2012-01-31 22:03 UTC (History)
3 users (show)

Fixed In Version: starcal-1.9.4-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-31 22:01:43 UTC


Attachments (Terms of Use)

Description Hosein Hamedi 2011-11-05 12:38:05 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        
component:      starcal
executable:     /usr/share/starcal2/scal2/ui_qt/starcal2.py
kernel:         2.6.40.4-5.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        starcal-1.9.4-1.fc15
reason:         preferences.py:450:__init__:RuntimeError: bad option type "Tune Hijri Monthes"
time:           Sat Nov  5 16:01:40 2011
uid:            500
username:       hoseinit

backtrace:
:preferences.py:450:__init__:RuntimeError: bad option type "Tune Hijri Monthes"
:
:Traceback (most recent call last):
:  File "/usr/share/starcal2/scal2/ui_qt/starcal2.py", line 1713, in <module>
:    sys.exit(main())
:  File "/usr/share/starcal2/scal2/ui_qt/starcal2.py", line 1700, in main
:    mainWin = MainWin(trayMode=2)
:  File "/usr/share/starcal2/scal2/ui_qt/starcal2.py", line 1139, in __init__
:    self.prefDialog = preferences.PrefDialog(self)
:  File "/usr/share/starcal2/scal2/ui_qt/preferences.py", line 1702, in __init__
:    optl = ModuleOptionItem(mod, opt)
:  File "/usr/share/starcal2/scal2/ui_qt/preferences.py", line 450, in __init__
:    raise RuntimeError('bad option type "%s"'%t)
:RuntimeError: bad option type "Tune Hijri Monthes"
:
:Local variables in innermost frame:
:opt: ('button', 'Tune Hijri Monthes', 'hijri', 'tuneHijriMonthes')
:hboxw: <PyQt4.QtGui.QWidget object at 0x2165a70>
:self: <scal2.ui_qt.preferences.ModuleOptionItem instance at 0x2163a70>
:module: <module 'scal2.cal_modules.hijri' from '/usr/share/starcal2/scal2/cal_modules/hijri.pyc'>
:t: 'Tune Hijri Monthes'
:hbox: <PyQt4.QtGui.QHBoxLayout object at 0x2165b00>

comment:
:I have put it on my start up
:but after some months of working good it suddenly doesn't start at my start up

Comment 1 Noori 2011-11-05 17:52:55 UTC
Package: starcal-1.9.4-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
When starcal want to run in startup show this message. But when I run it again it runs correctly.

Comment 2 Hedayat Vatankhah 2011-11-08 21:09:59 UTC
So, it only fails at the startup, right? And the problem has been appeared just recently?

Comment 3 Noori 2011-11-10 16:51:30 UTC
Yes, this only appear at startup of recently release.

Comment 4 Hedayat Vatankhah 2011-11-16 08:04:46 UTC
Well, it seems to be a bug in starcal2-qt. I wonder why it is being started at the start of a session. Would you please give me the output of this command:
ls ~/.config/autostart/

Comment 5 Noori 2011-11-16 17:41:41 UTC
Yes,
[noori@nanopc ~]$ ls ~/.config/autostart/
artha.desktop   shutter.desktop   stardict.desktop
qstart.desktop  starcal2.desktop  vino-server.desktop

Comment 6 Hedayat Vatankhah 2011-12-02 09:40:54 UTC
Sorry, I missed your reply! 
This is interesting. Please provide the output of the following command too:
cat ~/.config/autostart/starcal2.desktop

Also, would you please rename /usr/bin/starcal2-qt to a temporary name and log in again to see if starcal runs?

Comment 7 Hedayat Vatankhah 2011-12-02 15:54:17 UTC
*** Bug 759523 has been marked as a duplicate of this bug. ***

Comment 8 Hedayat Vatankhah 2011-12-02 15:54:37 UTC
*** Bug 759519 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2012-01-23 18:38:39 UTC
starcal-1.9.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/starcal-1.9.4-3.fc16

Comment 10 Fedora Update System 2012-01-23 18:47:52 UTC
starcal-1.9.4-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/starcal-1.9.4-3.fc15

Comment 11 Fedora Update System 2012-01-24 01:41:34 UTC
Package starcal-1.9.4-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing starcal-1.9.4-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0852/starcal-1.9.4-3.fc16
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2012-01-31 22:01:43 UTC
starcal-1.9.4-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-01-31 22:03:48 UTC
starcal-1.9.4-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.