Bug 751563 - [abrt] spyder-2.0.12-1.fc16: startup.py:181:<module>:ImportError: No module named Shell
Summary: [abrt] spyder-2.0.12-1.fc16: startup.py:181:<module>:ImportError: No module n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spyder
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Novacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bf99d744a2fcc1dd2b64b9b9272...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-05 16:03 UTC by Vedran Miletić
Modified: 2016-12-01 00:30 UTC (History)
6 users (show)

Fixed In Version: spyder-2.1.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-19 01:37:58 UTC


Attachments (Terms of Use)

Description Vedran Miletić 2011-11-05 16:03:36 UTC
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        /usr/bin/python -u /usr/lib/python2.7/site-packages/spyderlib/widgets/externalshell/startup.pyc -pylab -q4thread -colors LightBG -xmode Plain
comment:        IPython can't import module named IPython.Shell
event_log:      2011-11-05-17:03:01> Smolt profile successfully saved
executable:     /usr/lib/python2.7/site-packages/spyderlib/widgets/externalshell/startup.pyc
kernel:         3.1.0-7.fc16.i686
reason:         startup.py:181:<module>:ImportError: No module named Shell
time:           Sat Nov  5 17:00:02 2011
uid:            1000
username:       vedranm

backtrace:
:startup.py:181:<module>:ImportError: No module named Shell
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/spyderlib/widgets/externalshell/startup.py", line 181, in <module>
:    import IPython.Shell
:ImportError: No module named Shell
:
:Local variables in innermost frame:
:__is_ipython: <function __is_ipython at 0x924cfb4>
:__remove_from_syspath__: <function __remove_from_syspath__ at 0x924d09c>
:__builtins__: <module '__builtin__' (built-in)>
:__package__: None
:sys: <module 'sys' (built-in)>
:runfile: <function runfile at 0x924d0d4>
:__umd__: None
:debugfile: <function debugfile at 0x924d1b4>
:__name__: '__main__'
:os: <module 'os' from '/usr/lib/python2.7/os.pyc'>
:__doc__: ''
:UserModuleDeleter: <class '__main__.UserModuleDeleter'>

smolt_data:
:
:
:General
:=================================
:UUID: be7bddfb-6eed-45ba-a984-b5a758fb327d
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_DK.UTF-8
:Platform: i686
:BogoMIPS: 3200.67
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Atom(TM) CPU N270   @ 1.60GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 28
:Number of CPUs: 2
:CPU Speed: 1599
:System Memory: 2004
:System Swap: 3646
:Vendor: MICRO-STAR INTERNATIONAL CO., LTD
:System: U90/U100 Ver.001
:Form factor: Notebook
:Kernel: 3.1.0-7.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10169:5218:272) pci, None, PCI/ISA, 82801GBM (ICH7-M) LPC Interface Bridge
:(6164:1921:5218:26768) pci, rt2800pci, NETWORK, RT2860
:(32902:10158:5218:272) pci, i915, VIDEO, Mobile 945GME Express Integrated Graphics Controller
:(32902:10150:5218:272) pci, None, VIDEO, Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
:(32902:10192:0:0) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:0:0) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(4332:33078:5218:272) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10200:5218:272) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10202:5218:272) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9288:32902:9288) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10181:5218:272) pci, ahci, STORAGE, 82801GBM/GHM (ICH7 Family) SATA AHCI Controller
:(32902:10185:5218:272) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:5218:272) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10156:5218:272) pci, agpgart-intel, HOST/PCI, Mobile 945GME Express Memory Controller Hub
:(32902:10186:5218:272) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:5218:272) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:5218:272) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 7740927 6888595 6809979 1966080 1869443 1869443
:/dev/sda1 /boot ext2 1024 1024 495844 467857 442257 128016 127751 127751
:/dev/sda3 /home btrfs 4096 4096 30146560 26678542 26025158 0 0 0
:

Comment 1 g.plantageneto 2011-11-25 16:18:21 UTC
Same problem here, Shell class of IPython module is missing.

Comment 2 Fedora Update System 2011-11-25 17:13:09 UTC
spyder-2.1.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spyder-2.1.2-1.fc16

Comment 3 Radek Novacek 2011-11-25 17:16:06 UTC
Can you try installing this update [1] and let me know if it fixes the issue. Thanks

[1] https://admin.fedoraproject.org/updates/spyder-2.1.2-1.fc16

Comment 4 g.plantageneto 2011-11-25 21:03:42 UTC
(In reply to comment #3)
> Can you try installing this update [1] and let me know if it fixes the issue.
> Thanks
> 
> [1] https://admin.fedoraproject.org/updates/spyder-2.1.2-1.fc16

Nope. The problem is not connected to spyder, as far as I understand, but to IPython itself. I have the same problem importing IPython.Shell from python command line, and removing spyder as well.

Comment 5 g.plantageneto 2011-11-25 21:09:12 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Can you try installing this update [1] and let me know if it fixes the issue.
> > Thanks
> > 
> > [1] https://admin.fedoraproject.org/updates/spyder-2.1.2-1.fc16
> 
> Nope. The problem is not connected to spyder, as far as I understand, but to
> IPython itself. I have the same problem importing IPython.Shell from python
> command line, and removing spyder as well.

I'm new to Bugzilla and quite clumsy so I couldn't do it myself, but it would make sense to file this bug under ipython, rather than spyder.

Comment 6 Vedran Miletić 2011-11-26 13:56:50 UTC
(In reply to comment #4)
> Nope. The problem is not connected to spyder, as far as I understand, but to
> IPython itself. I have the same problem importing IPython.Shell from python
> command line, and removing spyder as well.

Indeed. But should IPython.Shell be imported at all in newer IPython versions?

Comment 7 g.plantageneto 2011-11-27 21:55:20 UTC
Yes, IPython works without IPython.Shell, but other software still needs it.

Comment 8 Radek Novacek 2011-11-28 07:29:28 UTC
ok, changing component to ipython.

Comment 9 Thomas Spura 2011-12-04 14:51:42 UTC
(In reply to comment #8)
> ok, changing component to ipython.

Why?

IPython was refactored basically everywhere and I announced the upgrade to 0.11 on the devel mailinglist. Because spyder doesn't requires ipython in the spec file, I wasn't aware, that this needs ipython.

As part of the refactoring "IPython.Shell and IPython.iplib have been split and removed as part of the refactor." see:
http://ipython.org/ipython-doc/stable/whatsnew/version0.11.html

This means IPython will move on without IPython.Shell and spyder needs a fix for that.

Reassigning to spyder.

Comment 10 Thomas Spura 2011-12-04 14:54:48 UTC
(In reply to comment #8)
> ok, changing component to ipython.

Why?

IPython was refactored basically everywhere and I announced the upgrade to 0.11 on the devel mailinglist. Because spyder doesn't requires ipython in the spec file, I wasn't aware, that this needs ipython.

As part of the refactoring "IPython.Shell and IPython.iplib have been split and removed as part of the refactor." see:
http://ipython.org/ipython-doc/stable/whatsnew/version0.11.html

This means IPython will move on without IPython.Shell and spyder needs a fix for that.

Reassigning to spyder.

___________________________________________________________________

Can you start spyder from the update above and post a backtrace, what exactly fails?
It seems from looking at the source code, that spyder should support IPython 0.11 even without IPython.Shell...

Trying myself to get it to crash was not successfull...
Can you describe a way to reproduce it?

Comment 11 Fedora Update System 2011-12-12 21:54:19 UTC
spyder-2.1.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Thomas Spura 2011-12-18 16:28:18 UTC
Any news here?

Can you describe how to reproduce this or gettin a new backtrace from spyder-2.1.2-1 above?

Comment 13 Thomas Spura 2011-12-22 22:26:22 UTC
It seems, as there is a solution for spyder:
https://github.com/ipython/ipython/issues/1180

Comment 14 Fedora Update System 2012-01-02 12:35:29 UTC
spyder-2.1.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spyder-2.1.6-1.fc16

Comment 15 Fedora Update System 2012-01-02 21:54:10 UTC
Package spyder-2.1.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spyder-2.1.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0029/spyder-2.1.6-1.fc16
then log in and leave karma (feedback).

Comment 16 Radek Novacek 2012-01-03 10:11:54 UTC
Thomas, thanks to pointing out the solution. Can you test spyder-2.1.6-1.fc16 and check if the issue is fixed?

Comment 17 Fedora Update System 2012-01-19 01:37:58 UTC
spyder-2.1.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.