Bug 751566 - Shape of U+0472/U+0473 wrong
Shape of U+0472/U+0473 wrong
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
16
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-05 13:42 EDT by Alessandro Ceschini
Modified: 2012-03-06 14:38 EST (History)
5 users (show)

See Also:
Fixed In Version: liberation-fonts-1.07.2-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 14:38:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CYRILLIC LETTER FITA (1.69 KB, image/png)
2011-11-07 06:21 EST, Alessandro Ceschini
no flags Details
liberation sans & serif font showing characters (33.74 KB, image/png)
2011-12-21 06:14 EST, Pravin Satpute
no flags Details

  None (edit)
Description Alessandro Ceschini 2011-11-05 13:42:38 EDT
Description of problem:
Hi
U+0472/U+0473 CYRILLIC LETTER FITA look like U+04E8/U+04E9 CYRILLIC LETTER BARRED O. It should rather look like what it is in Times New Roman.
Please tell me if you need a pdf or a png showing the correct glyphs.
Regards
Comment 1 A S Alam 2011-11-05 23:35:41 EDT
current package version:
liberation-mono-fonts-1.07.1-2.fc16.noarch
liberation-sans-fonts-1.07.1-2.fc16.noarch
liberation-fonts-common-1.07.1-2.fc16.noarch
liberation-serif-fonts-1.07.1-2.fc16.noarch
Comment 2 Pravin Satpute 2011-11-06 23:29:54 EST
Alessandro yes image/pdf will be very useful.
Comment 3 Alessandro Ceschini 2011-11-07 06:21:12 EST
Created attachment 532017 [details]
CYRILLIC LETTER FITA

This is my preferred shape.
Comment 4 Pravin Satpute 2011-12-21 06:14:08 EST
Created attachment 549013 [details]
liberation sans & serif font showing characters

looks like your requested shapes are available in Liberation serif fonts.
Comment 5 Alessandro Ceschini 2011-12-23 05:54:28 EST
Hi Pravin

OK for Liberation Serif but not for Liberation Sans because the straight bar creates an awkward homoglyph with U+04E8/U+04E9 CYRILLIC LETTER BARRED O.

Greetings
Comment 6 Pravin Satpute 2011-12-23 06:07:06 EST
Hi Alessandro,

  Sans style does not allow us width variations in glyph. In Serif we have that flexibility.
  Can you suggest some alternative design. i.e. we can keep width same across glyph but some more outline variation
Comment 7 Alessandro Ceschini 2011-12-23 06:22:58 EST
Hi Pravin

You mean you can't have wavy lines on Sans? All right, but could you used a broken bar? That would still be acceptable, it's also used on Serif fonts, by the way, see Unicode specimen http://www.unicode.org/charts/PDF/U0400.pdf

If you want you can adopt that glyph in Liberation Serif too, for consistency reasons.

Greetings
Comment 8 Pravin Satpute 2011-12-23 06:28:11 EST
Yes, this look as per Sans style.
Thanks a lot :)

Next month i will make upstream release with these changes.
Comment 9 Pravin Satpute 2012-01-27 04:56:08 EST
These shapes were not presented in Liberation font. Now added these shapes in Sans and SansNarrow.
Upstream commit in done, so will be available with next release
Comment 10 Fedora Update System 2012-02-09 03:44:42 EST
liberation-fonts-1.07.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-1.fc16
Comment 11 Fedora Update System 2012-02-09 19:55:33 EST
Package liberation-fonts-1.07.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liberation-fonts-1.07.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1501/liberation-fonts-1.07.2-1.fc16
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-02-13 11:03:37 EST
liberation-fonts-1.07.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-2.fc16
Comment 13 Fedora Update System 2012-03-06 14:38:26 EST
liberation-fonts-1.07.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.