Bug 7516 - Can't get pump to work from WinNT DHCP server on LAN
Can't get pump to work from WinNT DHCP server on LAN
Status: CLOSED DUPLICATE of bug 16237
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
http://www.jet.uk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-02 13:01 EST by Alan Hancock
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 19:19:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Hancock 1999-12-02 13:01:13 EST
Pump fails to work when trying to get DCHP lease from WinNT Server 4.0 when
using pump when called by the standard /sbin/ifup and /sbin/ifdown system
scripts. Cannot get pump to work in anyway including trying various hacks
to pump found in references on Bugzilla and elsewhere on the Internet. Have
resorted to changing the ifup & ifdown scripts to call dhcpcd daemon
instead, this works every time to get an IP address assigned from our WinNT
server. This problem appears to be similar or associated to Bugzilla bug
nos. 7011,7003,7486, 7498.

We would like to be able to install many more PC's with RH6.1 but we would
want these systems to get IP addresses via DHCP without having to modify
system scripts.

Also we are investigating the use of RH6.1 running in a virtual machine
using VMware (see http://www.vmware.com) to possibly provide X terminal
services on a host operating system of WinNT Workstation 4. This scheme
would also require to obtain DHCP leases via pump from a WinNT 4 server on
our LAN.
Comment 1 Erik Troan 2000-02-23 15:48:59 EST
Please retry w/ pump 0.7.8 from ftp://people.redhat.com/ewt
Comment 2 Alan Hancock 2000-02-25 04:52:59 EST
I have tried pump versions 0.7.4, 0.7.6, 0.7.8 from ftp://people.redhat.com/ewt
and I am still having problems the 0.7.4 version would work sometimes. My only
test system available at present for Red Hat 6.1 is running under VMware
(http://www.vmware.com) version 2.0 on Windows NT4.0 host OS. Will provide
further strace dumps if this will help to solve the problem. Using dhcpcd with
a static IP address always work fine.
Comment 3 richieb 2000-04-05 14:55:59 EDT
I'm having problems with pump and dhcpcd. The DHCP server is WinNT 4.0
and it is connected to a 100BT switch. When I connect a Linux laptop
to 100BT switch pump (or dhcpcd) do not work. When I connect to a
10BT hub, which is connected to the switch pump and dhcp work OK.

I'm using RH 6.1 on a SONY VAIO F270 laptop, with a XIRCOM realport card.

If I configure the network manually, then things work fine at 100BT.

...richie
Comment 4 Erik Troan 2000-08-08 09:21:02 EDT
What kind of switch is it?
Comment 5 Elliot Lee 2001-07-16 19:19:29 EDT
I wonder if this problem still exists after being neglected for so long :(
Comment 6 Elliot Lee 2001-07-19 17:54:19 EDT

*** This bug has been marked as a duplicate of 16237 ***

Note You need to log in before you can comment on or make changes to this bug.