Bug 75169 - Screen shots fail
Screen shots fail
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 20:40 EDT by Bill McCarty
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 17:43:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill McCarty 2002-10-04 20:40:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; Q312461)

Description of problem:
The source RPM contains a file describing how to make screen shots by using a 
remote X server. However, the procedure fails. Apparently, the libzvt library 
containing the zvt terminal widget is not available to anaconda.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set up networking on the installation host (ifconfig and route)
2. test connectivity (ping)
3. configure remote host to allow X connection (xhost +)
4. issue the command "anaconda -m cdrom://mnt/source --xmode" via VC2
	

Actual Results:  A window briefly opens on the remote X server. Then, anaconda 
terminates with the following error message:

/usr/bin/anaconda, line 563, in ? from gnome import zvt
cannot import name zvt

Expected Results:  The installation should have continued, using the remote X 
server. 

Additional info:
Comment 1 Jeremy Katz 2002-10-07 16:15:05 EDT
We never updated this for the switch to vte and since vte doesn't provide a
forkpty(), it'll be slightly tricky to get going again.
Comment 2 Jeremy Katz 2003-01-08 17:43:00 EST
This mode of operation has been dropped; if you wish to take screenshots of text
mode, boot with 'linux telnet' and telnet into your machine and you can run
through a text-mode installation.  The docs have been updated appropriately as
well to not refer to the older method.
Comment 3 Bill McCarty 2003-01-08 19:52:32 EST
Hi Jeremy,

Thats's cool, since there are other -- perhaps better -- ways of capturing 
screen shots of the text-based installation procedure. But, my real concern is 
how to capture screen shots of the graphical installation procedure. Is that 
capacity no longer supported? If so, is there another way to capture screen 
shots of the graphical installation procedure?

Thanks!
Comment 4 Jeremy Katz 2003-01-08 20:01:06 EST
We've added a built-in screenshot functionality triggered by pressing
shift-printscreen during the installation.  You can also still do a graphical
install and stop it when anaconda starts running with ctrl-S and then go to tty2
and run anaconda by hand with a different DISPLAY set, but the built-in
screenshots will probably be the better bet for most circumstances
Comment 5 Bill McCarty 2003-01-08 20:22:15 EST
Hi Jeremy,

Thanks for the quick reply. This is a MUCH better solution than before. My 
students thank you!

Cheers,

Note You need to log in before you can comment on or make changes to this bug.