This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 751752 - Image names are displayed when tried to do 'Group by Edit?' in Administration->Templates
Image names are displayed when tried to do 'Group by Edit?' in Administration...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.2
Unspecified Unspecified
medium Severity medium (vote)
: ---
: RHQ 4.3.0
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks: rhq-uxd
  Show dependency treegraph
 
Reported: 2011-11-07 08:01 EST by Sunil Kondkar
Modified: 2013-08-31 06:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 06:13:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (94.71 KB, image/png)
2011-11-07 08:02 EST, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2011-11-07 08:01:49 EST
Description of problem:

Selecting a right click option 'Group by Edit?' in 'Edit?' column in the 
Administration->Configuration->Alert Definition Templates and Metric Collection Templates displays the image names like:

'[SKIN]/actions/edit.png' 

Please refer the attached screenshot.


Version-Release number of selected component (if applicable):

Build#698 (Version: 4.3.0-SNAPSHOT Build Number: cb8ad66)
Firefox 3.6.3

How reproducible:

Always

Steps to Reproduce:

1. Login to RHQ.
2. Navigate to 'Administration->Configuration->Alert Definition Templates.
3. Right click on the 'Edit?' column for 'Platforms' or 'Platform Services'.
4. Select the right click option 'Group by Edit?'
  
Actual results:

Image names are displayed.

Expected results:

Image names should not be displayed.

Additional info:
Comment 1 Sunil Kondkar 2011-11-07 08:02:44 EST
Created attachment 532035 [details]
Screenshot
Comment 2 Charles Crouch 2011-11-09 11:14:51 EST
(10:07:06 AM) ccrouch: ips: i thought we had turned group-by off?
(10:07:07 AM) ccrouch: https://bugzilla.redhat.com/show_bug.cgi?id=751752
(10:07:17 AM) ccrouch: or was i thinking of something else
(10:08:23 AM) ips: ccrouch: it is turned off by default in Table
(10:08:54 AM) ips: so either the templates view overrode that, or it doesn't subclass Table
(10:11:02 AM) ips: if that's referring to the grids that list the resourcetypes, they may actually be candidates for allowing groupBy. since there's a fixed # of resourcetypes that's in the 200 range
(10:11:24 AM) ips: unlike most of the other types of entities in RHQ
Comment 3 Charles Crouch 2012-02-16 13:31:52 EST
Unassigning from ips since he's not looking at this currently.
Comment 4 John Sanda 2012-02-27 16:40:31 EST
Committed and pushed fix that does not allow grouping by the edit column.

master branch commit hash: 2d5d9b00387a7761487ae6a5ca63fbf2e7ca732b
Comment 5 Sunil Kondkar 2012-04-10 07:29:29 EDT
Verified in Version: 4.4.0-SNAPSHOT Build Number: 233eac6

Verified that right click option 'Group by Edit?' is not available in Administration->Templates.
Comment 6 Heiko W. Rupp 2013-08-31 06:13:26 EDT
Bulk close of old bugs in VERIFIED state.

Note You need to log in before you can comment on or make changes to this bug.