Bug 751753 - [abrt] kernel: BUG: unable to handle kernel paging request at bffffffc
[abrt] kernel: BUG: unable to handle kernel paging request at bffffffc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
abrt_hash:a8b0a2bdc3fad7b0e288fb40e21...
:
: 753066 753563 755149 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-07 08:03 EST by Jozef Mlich
Modified: 2015-08-02 19:58 EDT (History)
17 users (show)

See Also:
Fixed In Version: kernel-3.1.4-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-05 20:02:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: IMG_1578.jpg (199.14 KB, image/jpeg)
2011-11-07 08:03 EST, Jozef Mlich
no flags Details
File: Xorg.0.log (56.87 KB, text/plain)
2011-11-07 08:03 EST, Jozef Mlich
no flags Details
Xorg.0.log (54.94 KB, text/x-log)
2011-11-07 10:12 EST, Jozef Mlich
no flags Details
/var/log/messages (812.83 KB, application/octet-stream)
2011-11-07 10:13 EST, Jozef Mlich
no flags Details
dmesg output (78.50 KB, application/octet-stream)
2011-11-07 10:14 EST, Jozef Mlich
no flags Details

  None (edit)
Description Jozef Mlich 2011-11-07 08:03:44 EST
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.1.0-7.fc16.i686 root=UUID=05ccf711-311c-4550-9f5d-ba9a10402813 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
comment:        it occurs during "normal work". It occurs about twice per day during various acctions.
kernel:         undefined
reason:         BUG: unable to handle kernel paging request at bffffffc
time:           Sun Nov  6 09:51:32 2011

IMG_1578.jpg:   Binary file, 203915 bytes
Xorg.0.log:     Text file, 58238 bytes

backtrace:
:BUG: unable to handle kernel paging request at bffffffc
:IP: [<f7ddf9e0>] nouveau_sgdma_clear+0x26/0x45 [nouveau]
:*pde = 00000000 
:Oops: 0000 [#1] SMP 
:Modules linked in: ppdev parport_pc lp parport fuse 8021q garp stp llc fcoe libfcoe libfc scsi_transport_fc scsi_tgt ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 ip6_tables xt_state nf_conntrack cdc_ether usbnet mii cdc_phonet phonet cdc_acm e1000e snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm microcode serio_raw snd_timer snd iTCO_wdt iTCO_vendor_support i2c_i801 soundcore snd_page_alloc uinput firewire_ohci firewire_core ata_generic pata_acpi crc_itu_t pata_marvell uas usb_storage nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
:Pid: 1051, comm: Xorg Not tainted 3.1.0-7.fc16.i686 #1 ATComputers AC OFFICEPRO/DG33FB 
:EIP: 0060:[<f7ddf9e0>] EFLAGS: 00213286 CPU: 0
:EIP is at nouveau_sgdma_clear+0x26/0x45 [nouveau]
:EAX: f325f760 EBX: df49a100 ECX: f41b5060 EDX: f3368227
:ESI: f398f400 EDI: f3bc9280 EBP: f16b5d50 ESP: f16b5d48
: DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
:Process Xorg (pid: 1051, ti=f16b4000 task=f1483240 task.ti=f16b4000)
:Stack:
: df49a100 00000000 f16b5d6c f7ddf96c c05d126b ef440a00 00035020 f7cdb6fc
: df49a0c0 f16b5d78 f7d2ae53 f32a3c00 f16b5d88 f7d2b3da 00000001 f32a3c24
: f16b5db4 f7d2c01c 00000000 00000000 f558e560 f64801a8 f32a3c00 00000000
:Call Trace:
: [<f7ddf96c>] nouveau_sgdma_destroy+0x5f/0x6c [nouveau]
: [<c05d126b>] ? list_del+0xb/0x1b
: [<f7cdb6fc>] ? drm_mm_put_block+0x3b/0x42 [drm]
: [<f7d2ae53>] ttm_tt_destroy+0x1c/0x77 [ttm]
: [<f7d2b3da>] ttm_bo_cleanup_memtype_use+0x20/0x55 [ttm]
: [<f7d2c01c>] ttm_bo_release+0xef/0x18f [ttm]
: [<f7d2bf2d>] ? ttm_bo_delayed_workqueue+0x2b/0x2b [ttm]
: [<c05c5253>] kref_put+0x39/0x42
: [<f7d2b6fc>] ttm_bo_unref+0x2c/0x37 [ttm]
: [<f7cd4784>] ? drm_gem_handle_create+0xac/0xac [drm]
: [<f7de2c89>] nouveau_gem_object_del+0x40/0x52 [nouveau]
: [<f7cd47a9>] drm_gem_object_free+0x25/0x27 [drm]
: [<c05c5253>] kref_put+0x39/0x42
: [<f7cd4547>] drm_gem_object_unreference_unlocked+0x29/0x34 [drm]
: [<f7cd461b>] drm_gem_object_handle_unreference_unlocked.part.1+0x24/0x27 [drm]
: [<f7cd46cf>] drm_gem_handle_delete+0x74/0x7d [drm]
: [<f7cd49a1>] drm_gem_close_ioctl+0x26/0x29 [drm]
: [<f7cd334b>] drm_ioctl+0x2a4/0x38a [drm]
: [<f7cd497b>] ? drm_gem_destroy+0x36/0x36 [drm]
: [<c0589d78>] ? inode_has_perm+0x3f/0x46
: [<c0589e21>] ? file_has_perm+0xa2/0xbb
: [<f7cd30a7>] ? drm_copy_field+0x54/0x54 [drm]
: [<c04f7829>] do_vfs_ioctl+0x454/0x485
: [<c058b6df>] ? selinux_file_ioctl+0xac/0xb0
: [<c04f78a2>] sys_ioctl+0x48/0x6a
: [<c0810b0c>] syscall_call+0x7/0xb
: [<c0810000>] ? schedule_hrtimeout_range_clock+0xa4/0xda
:Code: 58 5b 5e 5d c3 55 89 e5 56 53 3e 8d 74 26 00 80 78 24 00 8b 70 0c 89 c3 74 06 8b 50 08 ff 52 0c 80 7b 18 00 75 13 eb 1e 8b 43 10 <8b> 14 90 8b 86 00 02 00 00 e8 8b ff ff ff 8b 43 14 8d 50 ff 85 
:EIP: [<f7ddf9e0>] nouveau_sgdma_clear+0x26/0x45 [nouveau] SS:ESP 0068:f16b5d48
:CR2: 00000000bffffffc

event_log:
:2011-11-07-13:54:53> Smolt profile successfully saved
:2011-11-07-14:02:22> Error sending kernel oops due to missing backtrace
:2011-11-07-14:02:22* (exited with 1)
:2011-11-07-14:02:22> Essential file 'duphash' is missing, can't continue..
:2011-11-07-14:02:22* (exited with 1)
:2011-11-07-14:02:30> Smolt profile successfully saved
:2011-11-07-14:02:34> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-11-07-14:03:37  Kernel oops has not been sent due to Couldn't connect to server
:2011-11-07-14:03:37* (exited with 1)

smolt_data:
:
:
:General
:=================================
:UUID: 7696c6c1-346c-4d56-adbe-683f41e68674
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 5332.26
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E6750  @ 2.66GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2664
:System Memory: 1997
:System Swap: 4098
:Vendor: ATComputers
:System: AC OFFICEPRO OfficePro 3100N mikro (
:Form factor: Unknown
:Kernel: 3.1.0-7.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10688:32902:20548) pci, None, HOST/PCI, 82G33/G31/P35/P31 Express DRAM Controller
:(32902:10689:32902:20548) pci, pcieport, PCI/PCI, 82G33/G31/P35/P31 Express PCI Express Root Port
:(32902:10544:32902:20548) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10528:32902:20548) pci, ata_piix, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller
:(32902:10514:32902:20548) pci, None, PCI/ISA, 82801IH (ICH9DH) LPC Interface Controller
:(32902:10534:32902:20548) pci, ata_piix, STORAGE, 82801I (ICH9 Family) 2 port SATA IDE Controller
:(32902:10572:32902:1) pci, e1000e, ETHERNET, 82566DC-2 Gigabit Network Connection
:(32902:9294:32902:20548) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10549:32902:20548) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:32902:20548) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:32902:20548) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:32902:20548) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:32902:20548) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:32902:20548) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(4523:24833:4523:24833) pci, pata_marvell, STORAGE, 88SE6101/6102 single-port PATA133 interface
:(32902:10564:32902:10564) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:32902:10566) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:32902:10560) pci, pcieport, PCI/PCI, Optiplex 755
:(32902:10562:32902:10562) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10692:32902:20548) pci, None, SIMPLE, 82G33/G31/P35/P31 Express MEI Controller
:(32902:10568:32902:10568) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:32902:2) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:32902:20548) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:32902:20548) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4318:915:4163:33294) pci, nouveau, VIDEO, G73 [GeForce 7300 GT]
:(4172:32803:32902:20548) pci, firewire_ohci, FIREWIRE, TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 59058112 45560899 44961108 15007744 14305133 14305133
:/dev/sdb1 WITHHELD ext4 4096 4096 120180148 70619722 64514903 30531584 30391358 30391358
:
Comment 1 Jozef Mlich 2011-11-07 08:03:50 EST
Created attachment 532036 [details]
File: IMG_1578.jpg
Comment 2 Jozef Mlich 2011-11-07 08:03:54 EST
Created attachment 532037 [details]
File: Xorg.0.log
Comment 3 Matěj Cepl 2011-11-07 09:44:13 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log*; check with grep Backtrace /var/log/Xorg* which logs might be the most interesting ones, send us at least Xorg.0.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Jozef Mlich 2011-11-07 10:12:14 EST
Created attachment 532070 [details]
Xorg.0.log

modified grub2 settings as follows
[imlich@pcmlich ~]$ cat /etc/default/grub 
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Fedora"
GRUB_DEFAULT=saved
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0  KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8 drm.debug=0x04"

/etc/X11/xorg.conf is not available
Comment 5 Jozef Mlich 2011-11-07 10:13:46 EST
Created attachment 532071 [details]
/var/log/messages
Comment 6 Jozef Mlich 2011-11-07 10:14:44 EST
Created attachment 532072 [details]
dmesg output
Comment 7 jaakko.airo 2011-11-18 12:31:21 EST
I got three times similar looking oops "unable to handle kernel paging request at bffffffc", ":IP: [<f87159e0>] nouveau_sgdma_clear+0x26/0x45 [nouveau]" during loading of page

http://www.computeraudiophile.com/content/HD-music-fft-atlas-reference-thread

with Firefox or soon afterwards.

My hardware's smolt page is at
http://www.smolts.org/client/show/pub_eafd4357-c35b-4b7f-8ead-ce167a9052c0

F16 up-to-date in a Dell Inspiron 9300 laptoop with NV41.8 [GeForce Go 6800].
Comment 8 Noel 2011-11-18 23:50:12 EST
*** Bug 755149 has been marked as a duplicate of this bug. ***
Comment 9 Yavor Atanasov 2011-11-19 16:31:21 EST
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Not know...
Comment 10 Yavor Atanasov 2011-11-19 16:33:41 EST
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Not know...
Comment 11 Daniel Thompson 2011-11-21 06:01:09 EST
Another "me too". The only (useful) thing I have to add is my graphics card type which is NV44:
08:00.0 VGA compatible controller: nVidia Corporation NV44 [Quadro NVS 285] (rev a1)
Comment 12 Josh Boyer 2011-11-21 09:43:28 EST
*** Bug 753066 has been marked as a duplicate of this bug. ***
Comment 13 bibo 2011-11-23 17:03:33 EST
*** Bug 753563 has been marked as a duplicate of this bug. ***
Comment 14 bibo 2011-11-23 17:06:02 EST
And there a "me too" from me.

The graphic card as lspci says is as following:
:(4318:471:6058:8293) pci, nouveau, VIDEO, G72M [Quadro NVS 110M/GeForce Go
7300]
Comment 15 Ben Skeggs 2011-11-24 01:28:53 EST
I've managed to reproduce this exactly once so far, so progress in tracking this down is slow.  I'm working on it though.
Comment 16 cje 2011-11-24 10:36:22 EST
FWIW i'm pretty certain i'm getting this daily on:
nVidia Corporation NV34 [GeForce FX 5500] [10de:0326] (rev a1)
Comment 17 jaakko.airo 2011-11-24 11:59:08 EST
(In reply to comment #15)
> I've managed to reproduce this exactly once so far, so progress in tracking
> this down is slow.  I'm working on it though.

I got the oops now for the fifth and sixth time by loading the page

http://www.computeraudiophile.com/content/HD-music-fft-atlas-reference-thread

in Firefox and maybe jumping to page 2 in the thread, and maybe reloading the page 1 again. FWIW.
Comment 18 Noel 2011-11-24 18:13:45 EST
A temporary workaround for me has been forcing fallback mode in Gnome 3 (System Settings > System Info > Graphics > Forced Fallback Mode.) I suspect disabling nouveau's hardware acceleration will also work for other environments (appending nouveau.noaccel=1 to the kernel options.) I've not experienced any freezes since fallback mode was turned on.

lspci:
01:00.0 VGA compatible controller: nVidia Corporation NV41GL [Quadro FX 1400] (rev a2)
Comment 19 Ben Skeggs 2011-11-24 23:57:29 EST
(In reply to comment #17)
> (In reply to comment #15)
> > I've managed to reproduce this exactly once so far, so progress in tracking
> > this down is slow.  I'm working on it though.
> 
> I got the oops now for the fifth and sixth time by loading the page
> 
> http://www.computeraudiophile.com/content/HD-music-fft-atlas-reference-thread
> 
> in Firefox and maybe jumping to page 2 in the thread, and maybe reloading the
> page 1 again. FWIW.

Yep, that was the page that allowed me to reproduce any issue at all.  The trouble is that what I was seeing was a complete hard lockup, not even netconsole was useful - which makes it very difficult to debug this when you can get zero output about what's going on.  I got the lockup once, randomly.

Until today.  I decided to take a different approach and tracked the issue as occuring between 3.1.0-0.rc6.git0.3.fc16.i686, and 3.1.0-0.rc7.git0.0.fc16.i686.  the former seemed to work correctly, and the latter gives me the same backtrace you're all seeing.  So, I have a starting point now at least :)
Comment 20 Ben Skeggs 2011-11-24 23:58:59 EST
(In reply to comment #19)
> (In reply to comment #17)
> > (In reply to comment #15)
> > > I've managed to reproduce this exactly once so far, so progress in tracking
> > > this down is slow.  I'm working on it though.
> > 
> > I got the oops now for the fifth and sixth time by loading the page
> > 
> > http://www.computeraudiophile.com/content/HD-music-fft-atlas-reference-thread
> > 
> > in Firefox and maybe jumping to page 2 in the thread, and maybe reloading the
> > page 1 again. FWIW.
> 
> Yep, that was the page that allowed me to reproduce any issue at all.  The
> trouble is that what I was seeing was a complete hard lockup, not even
> netconsole was useful - which makes it very difficult to debug this when you
> can get zero output about what's going on.  I got the lockup once, randomly.
Err, got the *backtrace* once, randomly.

> 
> Until today.  I decided to take a different approach and tracked the issue as
> occuring between 3.1.0-0.rc6.git0.3.fc16.i686, and
> 3.1.0-0.rc7.git0.0.fc16.i686.  the former seemed to work correctly, and the
> latter gives me the same backtrace you're all seeing.  So, I have a starting
> point now at least :)
Comment 21 Ben Skeggs 2011-11-25 01:14:15 EST
Ok.  I think I have a solution.  This has only been tested on top of the first kernel I found that was bad (3.1.0-0.rc7.git0.0.fc16.i686), but I've prepared a build on top of the latest f16 kernel.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3539966

It hasn't finished building yet so keep an eye out for that, and let me know how you fare!

On Monday I'll confirm myself the fix works on top of latest git, and the latest F16 kernel, and get it sorted out properly.
Comment 22 cje 2011-11-25 10:09:02 EST
i'm using that kernel and tried looking at the killer web page from comment 17 - and got a new (i think) crash on my FX5500.  i wrote down what i hope is the most helpful bit of the error but it shouldn't be too hard to reproduce if you need more data.

so, from the error:

EIP is at kthread_data+0xf/0x13
...
Call Trace:
wq_worker_sleeping
Comment 23 jaakko.airo 2011-11-27 03:57:17 EST
kernel-3.1.3-0.rc1.1.fc16.i686 still gives the oops.  NV41.8 [GeForce Go 6800] (rev a2).
Comment 24 Ben Skeggs 2011-11-27 19:03:03 EST
(In reply to comment #23)
> kernel-3.1.3-0.rc1.1.fc16.i686 still gives the oops.  NV41.8 [GeForce Go 6800]
> (rev a2).

The version of the kernel I posted, or the vanilla f16 kernel of the same version?
Comment 25 Ben Skeggs 2011-11-27 21:30:50 EST
(In reply to comment #24)
> (In reply to comment #23)
> > kernel-3.1.3-0.rc1.1.fc16.i686 still gives the oops.  NV41.8 [GeForce Go 6800]
> > (rev a2).
> 
> The version of the kernel I posted, or the vanilla f16 kernel of the same
> version?

I managed to reproduce a second instance of this bug, with a different backtrace (this is important to know).  So, it's possible this second case is what you were seeing.

I've put the patch covering both instances into an "official" fedora kernel build[1], once again it hasn't finished building at the time of posting this, so keep an eye out.

Thanks,
Ben.


[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3545261
Comment 26 Ben Skeggs 2011-11-27 21:31:48 EST
(In reply to comment #22)
> i'm using that kernel and tried looking at the killer web page from comment 17
> - and got a new (i think) crash on my FX5500.  i wrote down what i hope is the
> most helpful bit of the error but it shouldn't be too hard to reproduce if you
> need more data.
> 
> so, from the error:
> 
> EIP is at kthread_data+0xf/0x13
> ...
> Call Trace:
> wq_worker_sleeping

I'm not sure this is the same bug, was there any more of a backtrace than this?
Comment 27 cje 2011-11-28 08:41:19 EST
(In reply to comment #26)
> (In reply to comment #22)
> I'm not sure this is the same bug, was there any more of a backtrace than this?

there was but i didn't manage to capture it.  i'm going to enable kdump to help if it happens again.

speaking of which, i've installed your 3.1.3-2 kernel and have been happily refreshing the 'killer' page for a while without any problems.  i'll try playing with some heavy 3D apps etc - see what it can cope with.
Comment 28 jaakko.airo 2011-11-28 16:00:06 EST
(In reply to comment #24)
> (In reply to comment #23)
> > kernel-3.1.3-0.rc1.1.fc16.i686 still gives the oops.  NV41.8 [GeForce Go 6800]
> > (rev a2).
> 
> The version of the kernel I posted, or the vanilla f16 kernel of the same
> version?

In comment #23 I tested and got the oops like the one in comment #22
$ rpm -qi kernel-3.1.3-0.rc1.1.fc16 | grep 'Build Date'
Build Date  : Fri 25 Nov 2011 10:17:08 AM EET

Today I tested
$ rpm -qi kernel-3.1.1-2.fc16.i686 | grep 'Build Date'
Build Date  : Mon 14 Nov 2011 07:16:41 PM EET

I got once "[drm] nouveau 0000:01:00.0: GPU lockup - switching to software fbcon" and once "EIP is at nouveau_fence_update+0xe/0xa5 [nouveau]".  But this is likely a separate bug.  To get this, I have glxgears running, and I was loading/reloading the fft-atlas page mentioned above, and hitting Ctrl-Alt-PgUp/PgDn randomly.  These were much harder to hit than the "EIP nouveau_sgdma_clear".
Comment 29 Ben Skeggs 2011-11-28 17:48:09 EST
(In reply to comment #28)
> (In reply to comment #24)
> > (In reply to comment #23)
> > > kernel-3.1.3-0.rc1.1.fc16.i686 still gives the oops.  NV41.8 [GeForce Go 6800]
> > > (rev a2).
> > 
> > The version of the kernel I posted, or the vanilla f16 kernel of the same
> > version?
> 
> In comment #23 I tested and got the oops like the one in comment #22
> $ rpm -qi kernel-3.1.3-0.rc1.1.fc16 | grep 'Build Date'
> Build Date  : Fri 25 Nov 2011 10:17:08 AM EET
> 
> Today I tested
> $ rpm -qi kernel-3.1.1-2.fc16.i686 | grep 'Build Date'
> Build Date  : Mon 14 Nov 2011 07:16:41 PM EET
> 
> I got once "[drm] nouveau 0000:01:00.0: GPU lockup - switching to software
> fbcon" and once "EIP is at nouveau_fence_update+0xe/0xa5 [nouveau]".  But this
> is likely a separate bug.  To get this, I have glxgears running, and I was
> loading/reloading the fft-atlas page mentioned above, and hitting
> Ctrl-Alt-PgUp/PgDn randomly.  These were much harder to hit than the "EIP
> nouveau_sgdma_clear".

Yep, a completely separate bug here.  If you could file a new one and post the entire backtrace (hopefully it appears in your kernel log), that'll be helpful.
Comment 30 jaakko.airo 2011-11-29 01:33:07 EST
(In reply to comment #28)
> Today I tested
> $ rpm -qi kernel-3.1.1-2.fc16.i686 | grep 'Build Date'
> Build Date  : Mon 14 Nov 2011 07:16:41 PM EET

The kernel I tested was the new candidate, not the stock Fedora 3.1.1
$ rpm -qi kernel-3.1.3-2.fc16 | grep 'Build Date'
Build Date  : Mon 28 Nov 2011 06:22:51 AM EET

New bug is filed at https://bugzilla.redhat.com/show_bug.cgi?id=757989
Comment 31 Fedora Update System 2011-11-29 13:50:27 EST
kernel-3.1.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.4-1.fc16
Comment 32 Noel 2011-11-29 15:52:46 EST
kernel-3.1.4-1.fc16 works for me so far. No crashes when I visit and refresh the "killer website."
Comment 33 cje 2011-12-01 05:35:25 EST
yup, kernel-3.1.4-1.fc16.i686 is looking good to me too.  still get one or two 'lock ups' (mouse moves but nothing else happens) per day but looks like that's a separate issue.

thanks Ben! :-)
Comment 34 Fedora Update System 2011-12-02 16:32:09 EST
Package kernel-3.1.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.4-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16645/kernel-3.1.4-1.fc16
then log in and leave karma (feedback).
Comment 35 Fedora Update System 2011-12-05 20:02:20 EST
kernel-3.1.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 36 Trevor Cordes 2011-12-14 06:39:52 EST
So far no crashes in 4 days.  However, sometimes takes 7 days to crash so will report back.  "Killer web page" didn't kill me now (but I didn't test pre-3.1.4 for comparison).

Note You need to log in before you can comment on or make changes to this bug.