Bug 75176 - traceback WirelessInterface:on_finish_page_prepare:285: Unicode Error
Summary: traceback WirelessInterface:on_finish_page_prepare:285: Unicode Error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 74873 81720
TreeView+ depends on / blocked
 
Reported: 2002-10-05 05:35 UTC by Peter L. Thomas
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 12:10:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter L. Thomas 2002-10-05 05:35:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
After many attempts to configure the a D-Link DWL-650 (Intersil PRISM2-based
802.11b card), I was unable to succeed. Eventually the network config tool grew
tired of my impudence and crashed outright.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
Too many steps, not carefully recorded. Fundamentally tried all Lucent-variant
drivers in succession trying to find one that worked with this card.

Actual Results:  No joy in mudville.

Expected Results:  Packets a-blazin'

Additional info:

Traceback (most recent call last):
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/WirelessInterface.py",
line 285, in on_finish_page_prepare
    s = s + str(wl.EssId) + "\n"
UnicodeError: UTF-8 decoding error: unexpected end of data

Local variables in innermost frame:
druid_page: <gnome.ui.DruidPageEdge object (GnomeDruidPageEdge) at 0x8640884>
s: You have selected the following information:

Device: eth1 (Lucent Orinoco/Melco PCMCIA wireless (alternate))
Automatically obtain IP address settings with: dhcp
Mode: Managed
ESSID (Network ID):
hwaddr: 00:00:00:00:00:00
self: <netconfpkg.gui.WirelessInterface.WirelessInterface instance at
0x860a56c>wl: <netconfpkg.NCWireless.Wireless instance at 0x8767d4c>
hardwarelist: [<rhpl.genClass.Hardware instance at 0x84b71b4>,
<rhpl.genClass.Hardware instance at 0x84a8f44>]
hw: <rhpl.genClass.Hardware instance at 0x84a8f44>
druid: <gnome.ui.Druid object (GnomeDruid) at 0x84f3bcc>

Comment 1 Tomasz Kepczynski 2002-10-05 09:00:48 UTC
DWL-650 is bound to wvlan_cs in /etc/pcmcia/config file and this driver is
useless for this card. Try to change entry:
card "Intersil PRISM2 11 Mbps Wireless Adapter"
  manfid 0x0156, 0x0002
  bind "wvlan_cs"
to:
card "Intersil PRISM2 11 Mbps Wireless Adapter"
  manfid 0x0156, 0x0002
  bind "orinoco_cs"
in this file. orinoco_cs still has its problems but at least it works.

Comment 2 Peter L. Thomas 2002-10-05 18:40:12 UTC
Thanks. On loading orinoco_cs, I get an error that there was "Error -110 
reading firmware info. Wildly guessing capabilities." and a serious of 
subsequent errors.

Do I need a new firmware load from D-Link or is this just some of 
the "problems" of the orinoco_cs driver you allude to?

Comment 3 Peter L. Thomas 2002-10-08 04:29:28 UTC
Still no luck, not even with orinoco_cs...I can't find any citation of anyone 
getting the D-Link DWL-650 to work in RedHat 8.0 (or earlier)--or at least 
that seems authoritative or credible.

Comment 4 Harald Hoyer 2003-02-04 16:53:55 UTC
fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.