Bug 75177 - Syntax highlighting colors wrong in RH8.0
Syntax highlighting colors wrong in RH8.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 01:36 EDT by Jordan Russell
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-05 01:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2002-10-05 01:36:46 EDT
Description of problem:
When using vim at the console, the colors used for syntax-highlighted text are 
the "dark" set of colors. Dark text on a black background isn't so easy to 
read, and it is not the correct behavior. To quote the vim manual 
<http://vimdoc.sourceforge.net/cgi-bin/vim2html2.pl?page=usr_06.txt#06.2>:

        Vim guesses the background color that you are using.  If it is black
        (or another dark color) it will use light colors for text.  If it is
        white (or another light color) it will use dark colors for text. 

Red Hat 7.3's vim does it right; it uses the light colors when running from the 
console.

Version-Release number of selected component (if applicable):
vim-enhanced-6.1-14

How reproducible:
Always

Steps to Reproduce:
While logged in at the console, do:
vi /etc/bashrc

Actual Results:  We see the colors brown, dark red, and dark blue.

Expected Results:  As in RH 7.3, we should see the colors yellow, bright red, 
and bright blue.


Additional info:

I'm not entirely sure if the problem is in the vim package or outside...
Comment 1 Jordan Russell 2002-10-05 12:30:27 EDT
Nevermind. This is due to the Unicode font used by default in RH 8.0. (See also 
#75180.)

Note You need to log in before you can comment on or make changes to this bug.