Bug 75178 - Install crashes after partitioning, before product selection
Install crashes after partitioning, before product selection
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 01:39 EDT by Rodolfo J. Paiz
Modified: 2006-02-21 13:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump of error message during crash (50.76 KB, text/plain)
2002-10-05 01:42 EDT, Rodolfo J. Paiz
no flags Details

  None (edit)
Description Rodolfo J. Paiz 2002-10-05 01:39:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Installation on a P/166 and an Athlon/900 fails identically. After partitioning
and language selection, but before package selection, installation comes to a
screeching halt.

Installation has been attempted from ISO files and via FTP (content generated
from same ISO files). ISO files match MD5SUM and "mount -o loop" works as expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run normal installation.
2.Computer crashes.
3.
	

Actual Results:  Anaconda crashed totally, but did offer the opportunity to save
the debug output.

Expected Results:  Install should have proceeded to package selection, I suppose.

Additional info:

So far I have tested this on two machines:

- Athlon/900, 256MB, software RAID-0 on 2 x 20GB IDE drives, RIVA TNT video
w/16MB, 3c59x Ethernet

- Dell P/166, 32MB, 2GB, old but stable

The Dell is currently running Windows 98, and the Athlon is currently on RH-7.2
Enigma. At least five attempts on each, all total crashes. Cannot install
Psyche!!! Have lost mind. :-(
Comment 1 Rodolfo J. Paiz 2002-10-05 01:42:24 EDT
Created attachment 78824 [details]
Anaconda dump of error message during crash
Comment 2 Rodolfo J. Paiz 2002-10-06 01:25:06 EDT
Still utterly unable to install RH-8.0; now _very_ concerned. Went back to the
Athlon to try FTP installs and get more data. Install fails again, with the same
error message.

However, I did note that I get as far as configuring the machine's IP address
before the install conks out. The vsftpd log on the server shows the address
correctly negotiated via DHCP, and also that the Athlon downloads "netstg1.img".
After that, I get stuck on a blue screen with the Anaconda error...

Here are the last couple of lines from my FTP log on the server:

Fri Oct 04 00:23:23 2002 [pid 3345] [ftp] OK LOGIN: Client "192.168.0.100", anon
password "rpaiz@indahaus.com"
Fri Oct 04 20:58:30 2002 [pid 7297] [ftp] OK LOGIN: Client "192.168.0.100", anon
password "rhinstall@"
Fri Oct 04 20:58:30 2002 [pid 7300] [ftp] OK LOGIN: Client "192.168.0.100", anon
password "rhinstall@"
Fri Oct 04 20:58:30 2002 [pid 7303] [ftp] OK LOGIN: Client "192.168.0.100", anon
password "rhinstall@"
Fri Oct 04 20:58:31 2002 [pid 7305] [ftp] OK DOWNLOAD: Client "192.168.0.100",
"/pub/redhat/8.0/RedHat/base/netstg1.img", 8200192 bytes, 10083.61Kbyte/sec
Fri Oct 04 21:18:21 2002 [pid 7386] [ftp] OK LOGIN: Client "192.168.0.100", anon
password "anonymous@localhost.localdomain"
Sat Oct 05 19:50:46 2002 [pid 14632] [ftp] OK LOGIN: Client "192.168.0.100",
anon password "rhinstall@"
Sat Oct 05 19:50:46 2002 [pid 14635] [ftp] OK LOGIN: Client "192.168.0.100",
anon password "rhinstall@"
Sat Oct 05 19:50:46 2002 [pid 14638] [ftp] OK LOGIN: Client "192.168.0.100",
anon password "rhinstall@"
Sat Oct 05 19:50:47 2002 [pid 14640] [ftp] OK DOWNLOAD: Client "192.168.0.100",
"/pub/redhat/8.0/RedHat/base/netstg1.img", 8200192 bytes, 10022.29Kbyte/sec
Sat Oct 05 20:05:38 2002 [pid 14702] [ftp] OK LOGIN: Client "192.168.0.100",
anon password "anonymous@localhost.localdomain"

Since I see netstg1.img being downloaded twice, I will download disc1.iso again
(despite the fact that the MD5 checksum matches correctly) and try this again.
Will keep adding data if I can find something useful.

I _need_ to migrate to 8.0, and this weekend was the perfect time to do all the
dirty work. Arrrgh!
Comment 3 Jeremy Katz 2002-10-07 16:16:03 EDT
Have you followed the instructions for performing a mediacheck at
http://rhlinux.redhat.com/anaconda/mediacheck.html before trying the CD install?
Comment 4 Rodolfo J. Paiz 2002-10-07 18:23:25 EDT
Have not checked media, since I have not made CD's. I have been using the ISO
files and installing from hard drive; as an alternate, I have loop-mounted then
lndir'd them to install from FTP. I get the same error either way.

The MD5SUM does check out perfectly for all three ISO files, though. What else
should I try? (Note: I don't have a CD burner, but could conceivably find one...)
Comment 5 Jeremy Katz 2002-10-07 23:41:58 EDT
Do you happen to be putting the docs CD iso in the same directory as the other
isos for the har drive install?
Comment 6 Rodolfo J. Paiz 2002-10-08 01:05:32 EDT
I have not downloaded the docs ISO at all. As customary with earlier releases, I
have only downloaded the ISO files which contain binary RPM's for my original
install (in this case, discs #1 through #3 but not #4, #5, or docs).

I save time and bandwidth, and leave more space for other people during the
initial download rush. Then, a couple of weeks later, once the peak is past, I
go get the rest of the ISO's.

This has always worked before; should I change something now? Do I need another
ISO beyond 1, 2, and 3?
Comment 7 Jeremy Katz 2002-10-09 11:20:46 EDT
No, just making sure that there wasn't a weird interaction with the docs CD. 
You can actually use mediacheck for hard drive installs.  I'd recommend that,
since it really does have the characteristics of a bad ISO download; the
traceback basically says that librpm reads in an RPM header and it's invalid.
Comment 8 Michael Fulbright 2002-11-05 16:11:32 EST
Closing due to inactivity. Please reopen if you have additional information to
add to this report.
Comment 9 Red Hat Bugzilla 2006-02-21 13:49:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.