Bug 75181 - No Packages chosen during NFS upgrade
No Packages chosen during NFS upgrade
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 02:11 EDT by Rob Blomquist
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 10:09:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The dump file Anaconda generated when my RH8.0 install crashed (63.80 KB, text/plain)
2002-10-08 13:36 EDT, David Charlap
no flags Details

  None (edit)
Description Rob Blomquist 2002-10-05 02:11:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.1) Gecko/20020826

Description of problem:
During an attempted installation of 8.0 over 7.3, any action (reformat drives,
create swapfile, custom package selection, make bootdisk) would elicit a crash.
Skipping these would would cause for no packages would be detected for upgrade,
upgrade would finish without any thing being done.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start NFS install
2.Attempt any form of upgrade
3.Follow menu instructions.
	

Actual Results:  Crash or nothing.

Expected Results:  Install of 8.0 over 7.3

Additional info:
I am running an AMD k6/2 450, connected via 10BaseT to Pentium 133 server
holding iso images of 8.0. I built the machine to 7.3 using this, and wanted to
upgrade instead of wasting all the time with a full install.
Comment 1 Rob Blomquist 2002-10-06 02:17:08 EDT
I double checked my MD5SUMS, and ran --warn, I found that the MD5SUM was not
liked by md5sum, but the isos checked out "OK".

I still am thinking that this is a bug, but I have not heard of others having
this problem.
Comment 2 Jeremy Katz 2002-10-07 16:17:30 EDT
What was the crash given?  Also, if you boot with 'linux mediacheck' and do a
mediacheck following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html, do the isos check out okay?
 (mediacheck works reliably for NFS iso as well as CD baesd installs)
Comment 3 Rob Blomquist 2002-10-08 02:02:06 EDT
I ran mediacheck, which ran a second checksum of the iso images I have, and  
they passed, and I attempted to rerun an upgrade from 7.3 to 8.0. the  
installer, offered to upgrade my previous installation to ext3, which is  
pretty silly, as I am currently running ext3 on both /boot and /, not ext2.  
  
Then I went into a custom installation, and anaconda crashed trying to detect  
my packages. I was able to capture the crash report: 
 
Traceback (most recent call last): 
  File "/usr/lib/anaconda/gui.py", line 635, in nextClicked 
    self.setScreen () 
  File "/usr/lib/anaconda/gui.py", line 834, in setScreen 
    new_screen = apply(self.currentWindow.getScreen, args) 
  File "/usr/lib/anaconda/iw/package_gui.py", line 345, in getScreen 
    self.flat_groups = self.make_group_list(hdList, comps) 
  File "/usr/lib/anaconda/iw/package_gui.py", line 237, in make_group_list 
    if not comps["Core"].includesPackage(header) or displayBase: 
  File "/usr/lib/anaconda/comps.py", line 580, in __getitem__ 
    return self.compsDict[key] 
KeyError: Core 
 
Local variables in innermost frame: 
 
 
Package Group selection status: 
Maximum RPM: 0 
Official Red Hat Linux Customization Guide: 0 
Official Red Hat Linux Getting Started Guide: 0 
Official Red Hat Linux Reference Guide: 0 
Official Red Hat Linux Security Guide: 0 
Official Red Hat Linux x86 Installation Guide: 0 
Everything: 0 
 
 
Individual package selection status: 
maximum-rpm: 0, rhl-cg-en: 0, rhl-gsg-en: 0, rhl-ig-x86-en: 0, rhl-rg-en: 0, 
rhl-sg-en: 0,  
 
 
Dispatcher instance, containing members: 
method: NfsIsoInstallMethod instance, containing members: 
  discImages: {1: psyche-docs.iso, 2: psyche-i386-disc2.iso, 3: 
psyche-i386-disc3.iso, 4: psyche-i386-disc4.iso, 5: psyche-i386-disc5.iso} 
  isoPath: mnt/source 
  mntPoint: /tmp/isomedia/ 
  tree: /tmp/isomedia/ 
  rootPath: /mnt/sysimage 
  imageMounted: 1 
step: 39 
intf: InstallInterface instance, containing members: 
  icw: InstallControlWindow instance, containing members: 
    displayHelp: 1 
    stockButtons: (('gtk-go-back', 'prevButtonStock', '_Back', <bound method 
InstallControlWindow.prevClicked of <gui.InstallControlWindow instance at 
0x85f19fc>>), ('gtk-go-forward', 'nextButtonStock', '_Next', <bound method 
InstallControlWindow.nextClicked of <gui.InstallControlWindow instance at 
0x85f19fc>>), ('gtk-new', 'releaseButton', '_Release Notes', <bound method 
InstallControlWindow.releaseClicked of <gui.InstallControlWindow instance at 
0x85f19fc>>), ('gtk-help', 'showHelpButton', 'Show _Help', <bound method 
InstallControlWindow.helpClicked of <gui.InstallControlWindow instance at 
0x85f19fc>>), ('gtk-help', 'hideHelpButton', 'Hide _Help', <bound method 
InstallControlWindow.helpClicked of <gui.InstallControlWindow instance at 
0x85f19fc>>), ('gtk-execute', 'debugButton', '_Debug', <bound method 
InstallControlWindow.debugClicked of <gui.InstallControlWindow instance at 
0x85f19fc>>)) 
    handle: 91 
    help: <TextViewBrowser object (GtkTextView) at 0x85f1b1c> 
    buttonBox: <gtk.HButtonBox object (GtkHButtonBox) at 0x852a2c4> 
    hideHelpButton: <gtk.Button object (GtkButton) at 0x8687104> 
    nextButtonStock: <gtk.Button object (GtkButton) at 0x84b74a4> 
    help_sw: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0x8699854> 
    dir: 1 
    dispatch: Already dumped 
    reloadRcQueued: 0 
    ii: Already dumped 
    currentWindow: IndividualPackageSelectionWindow instance, containing 
members: 
      updatingIcons: 0 
      comps:  
Exception occurred during state dump: 
Traceback (most recent call last): 
  File "/usr/lib/anaconda/exception.py", line 140, in dumpException 
    dumpClass(dispatch, out) 
  File "/usr/lib/anaconda/exception.py", line 80, in dumpClass 
    dumpClass(value, fd, level + 1) 
  File "/usr/lib/anaconda/exception.py", line 80, in dumpClass 
    dumpClass(value, fd, level + 1) 
  File "/usr/lib/anaconda/exception.py", line 80, in dumpClass 
    dumpClass(value, fd, level + 1) 
  File "/usr/lib/anaconda/exception.py", line 80, in dumpClass 
    dumpClass(value, fd, level + 1) 
  File "/usr/lib/anaconda/exception.py", line 42, in dumpClass 
    fd.write("%s\n" % (instance,)) 
  File "/usr/lib/anaconda/comps.py", line 820, in __repr__ 
    for package in n: 
TypeError: iteration over non-sequence 
 
 
/tmp/syslog: 
<4>Linux version 2.4.18-14BOOT (bhcompile@daffy.perf.redhat.com) (gcc version 
3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 11:55:51 EDT 2002 
<6>BIOS-provided physical RAM map: 
<4> BIOS-e820: 0000000000000000 - 00000000000a0000 (usable) 
<4> BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved) 
<4> BIOS-e820: 0000000000100000 - 0000000007ff0000 (usable) 
<4> BIOS-e820: 0000000007ff0000 - 0000000007ff0800 (ACPI NVS) 
<4> BIOS-e820: 0000000007ff0800 - 0000000008000000 (ACPI data) 
<4> BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved) 
<5>127MB LOWMEM available. 
<4>On node 0 totalpages: 32752 
<4>zone(0): 4096 pages. 
<4>zone(1): 28656 pages. 
<4>zone(2): 0 pages. 
<4>Kernel command line: initrd=initrd.img lang= devfs=nomount 
ramdisk_size=9216 BOOT_IMAGE=vmlinuz mediacheck 
<4>No local APIC present or hardware disabled 
<6>Initializing CPU#0 
<4>Detected 451.029 MHz processor. 
<4>Speakup v-1.00 CVS: Tue Jun 11 14:22:53 EDT 2002 : initialized 
<4>Console: colour VGA+ 80x25 
<4>Calibrating delay loop... 897.84 BogoMIPS 
<6>Memory: 125336k/131008k available (1162k kernel code, 4268k reserved, 359k 
data, 176k init, 0k highmem) 
<6>Dentry cache hash table entries: 16384 (order: 5, 131072 bytes) 
<6>Inode cache hash table entries: 8192 (order: 4, 65536 bytes) 
<6>Mount cache hash table entries: 2048 (order: 2, 16384 bytes) 
<7>ramfs: mounted with options: <defaults> 
<7>ramfs: max_pages=15794 max_file_pages=0 max_inodes=0 max_dentries=15794 
<6>Buffer cache hash table entries: 4096 (order: 2, 16384 bytes) 
<4>Page-cache hash table entries: 32768 (order: 5, 131072 bytes) 
<7>CPU: Before vendor init, caps: 008021bf 808029bf 00000000, vendor = 2 
<6>CPU: L1 I Cache: 32K (32 bytes/line), D cache 32K (32 bytes/line) 
<7>CPU: After vendor init, caps: 008021bf 808029bf 00000000 00000002 
<7>CPU:     After generic, caps: 008021bf 808029bf 00000000 00000002 
<7>CPU:             Common caps: 008021bf 808029bf 00000000 00000002 
<4>CPU: AMD-K6(tm) 3D processor stepping 0c 
<6>Checking 'hlt' instruction... OK. 
<6>Checking for popad bug... OK. 
<4>POSIX conformance testing by UNIFIX 
<4>mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au) 
<4>mtrr: detected mtrr type: AMD K6 
<6>PCI: PCI BIOS revision 2.10 entry at 0xfb360, last bus=2 
<6>PCI: Using configuration type 1 
<6>PCI: Probing PCI hardware 
<3>PCI: 00:07.3: class 604 doesn't match header type 00. Ignoring class. 
<6>PCI: Using IRQ router VIA [1106/0586] at 00:07.0 
<6>Activating ISA DMA hang workarounds. 
<4>speakup:  initialized device: /dev/synth, node (MAJOR 10, MINOR 25) 
<6>Linux NET4.0 for Linux 2.4 
<6>Based upon Swansea University Computer Society NET3.039 
<4>Initializing RT netlink socket 
<4>Starting kswapd 
<6>Detected PS/2 Mouse Port. 
<4>pty: 256 Unix98 ptys configured 
<6>Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ 
SERIAL_PCI enabled 
<6>ttyS0 at 0x03f8 (irq = 4) is a 16550A 
<6>ttyS1 at 0x02f8 (irq = 3) is a 16550A 
<4>block: 240 slots per queue, batch=60 
<6>Uniform Multi-Platform E-IDE driver Revision: 6.31 
<4>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx 
<4>VP_IDE: IDE controller on PCI bus 00 dev 39 
<4>VP_IDE: chipset revision 6 
<4>VP_IDE: not 100% native mode: will probe irqs later 
<4>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx 
<6>VP_IDE: VIA vt82c586b (rev 41) IDE UDMA33 controller on pci00:07.1 
<4>    ide0: BM-DMA at 0xe400-0xe407, BIOS settings: hda:DMA, hdb:DMA 
<4>    ide1: BM-DMA at 0xe408-0xe40f, BIOS settings: hdc:DMA, hdd:DMA 
<4>hda: Maxtor 91360D6, ATA DISK drive 
<4>hdc: MATSHITA CR-583, ATAPI CD/DVD-ROM drive 
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14 
<4>ide1 at 0x170-0x177,0x376 on irq 15 
<6>hda: 26520480 sectors (13578 MB) w/512KiB Cache, CHS=28064/15/63, UDMA(33) 
<4>hdc: ATAPI 8X CD-ROM drive, 128kB Cache 
<6>Uniform CD-ROM driver Revision: 3.12 
<4>ide-floppy driver 0.99.newide 
<6>Partition check: 
<6> hda: hda1 hda2 hda3 
<6>Floppy drive(s): fd0 is 1.44M 
<6>FDC 0 is a post-1991 82077 
<6>NET4: Frame Diverter 0.46 
<4>RAMDISK driver initialized: 16 RAM disks of 9216K size 1024 blocksize 
<6>loop: loaded (max 8 devices) 
<4>ide-floppy driver 0.99.newide 
<6>usb.c: registered new driver usbdevfs 
<6>usb.c: registered new driver hub 
<6>usb-uhci.c: $Revision: 1.275 $ time 11:57:03 Sep  4 2002 
<6>usb-uhci.c: High bandwidth mode enabled 
<6>usb-uhci.c: v1.275:USB Universal Host Controller Interface driver 
<6>usb.c: registered new driver hiddev 
<6>usb.c: registered new driver hid 
<6>hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz> 
<6>hid-core.c: USB HID support drivers 
<6>mice: PS/2 mouse device common for all mice 
<6>md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27 
<6>md: Autodetecting RAID arrays. 
<6>md: autorun ... 
<6>md: ... autorun DONE. 
<6>NET4: Linux TCP/IP 1.0 for NET4.0 
<6>IP Protocols: ICMP, UDP, TCP 
<6>IP: routing cache hash table of 512 buckets, 4Kbytes 
<6>TCP: Hash tables configured (established 8192 bind 16384) 
<6>NET4: Unix domain sockets 1.0/SMP for Linux NET4.0. 
<5>RAMDISK: Compressed image found at block 0 
<6>Freeing initrd memory: 538k freed 
<4>VFS: Mounted root (ext2 filesystem). 
<6>SCSI subsystem driver Revision: 1.00 
<6>8139too Fast Ethernet driver 0.9.25 
<6>PCI: Found IRQ 11 for device 00:09.0 
<7>divert: allocating divert_blk for eth0 
<6>eth0: RealTek RTL8139 Fast Ethernet at 0xc885d000, 00:50:ba:42:60:b1, IRQ 
11 
<7>eth0:  Identified 8139 chip type 'RTL-8139B' 
<6>eth0: Setting half-duplex based on auto-negotiated partner ability 0000. 
<4>nfs warning: mount version older than kernel 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<4>Unable to identify CD-ROM format. 
<4>VFS: Can't find ext2 filesystem on dev loop(7,0). 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<6>Linux agpgart interface v0.99 (c) Jeff Hartmann 
<6>agpgart: Maximum main memory to use for agp memory: 94M 
<7>agpgart: unsupported bridge 
<7>agpgart: no supported devices found. 
<6>md: raid0 personality registered as nr 2 
<6>md: raid1 personality registered as nr 3 
<6>raid5: measuring checksumming speed 
<4>   8regs     :   688.000 MB/sec 
<4>   32regs    :   412.800 MB/sec 
<4>   pII_mmx   :   972.000 MB/sec 
<4>   p5_mmx    :   935.600 MB/sec 
<4>raid5: using function: pII_mmx (972.000 MB/sec) 
<6>md: raid5 personality registered as nr 4 
<6>Journalled Block Device driver loaded 
<6>LVM version 1.0.3(19/02/2002) module loaded 
<6>parport0: PC-style at 0x378 (0x778) [PCSPP(,...)] 
<6>parport0: irq 7 detected 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<7>ISO 9660 Extensions: RRIP_1991A 
<6>cdrom: open failed. 
<6>kjournald starting.  Commit interval 5 seconds 
<6>EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,1), internal journal 
<6>EXT3-fs: mounted filesystem with ordered data mode. 
<6>kjournald starting.  Commit interval 5 seconds 
<6>EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,3), internal journal 
<6>EXT3-fs: mounted filesystem with ordered data mode. 
<6>kjournald starting.  Commit interval 5 seconds 
<6>EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,3), internal journal 
<6>EXT3-fs: mounted filesystem with ordered data mode. 
<6>Adding Swap: 152136k swap-space (priority -1) 
<6>Adding Swap: 110584k swap-space (priority -2) 
 
 
/tmp/anaconda.log: 
* 126896 kB are available 
* modules to insert cramfs vfat sunrpc lockd nfs 
* module(s) cramfs vfat not found 
* inserted /tmp/sunrpc.o 
* inserted /tmp/lockd.o 
* inserted /tmp/nfs.o 
* load module set done 
* modules to insert ide-cd 
* module(s) ide-cd not found 
* load module set done 
* modules to insert scsi_mod sd_mod sr_mod 
* module(s) sr_mod not found 
* inserted /tmp/scsi_mod.o 
* inserted /tmp/sd_mod.o 
* load module set done 
* looking for usb controllers 
* no usb controller found 
* no firewire controller found 
* probing for floppy devices 
* first non-detached floppy is fd0 
* system floppy device is fd0 
* probing buses 
* finished bus probing 
* modules to insert mii 8139too 
* inserted /tmp/mii.o 
* inserted /tmp/8139too.o 
* load module set done 
* 53 keymaps are available 
* loaded 9 keymap tables 
* starting to STEP_URL 
* going to do getNetConfig 
* reverse name lookup failed 
* going to do nfsGetSetup 
* mounting nfs path 192.168.1.3:/mnt/share/computer/RedHat_8.0 
* mntloop loop0 on /tmp/loopimage as /mnt/source/psyche-i386-disc1.iso fd is 
17 
* umounting loopback /tmp/loopimage loop0 
* mntloop loop1 on /mnt/source2 as /mnt/source/psyche-i386-disc1.iso fd is 16 
* mntloop loop0 on /mnt/runtime as /mnt/source2/RedHat/base/stage2.img fd is 
16 
* MD5SUM -> 3218284f8826bf95ccd6f248ad9229f0 
* skipsectors = 15 
* isostatus = 0 
* mntloop loop6 on /tmp/testmnt as /mnt/source/psyche-i386-disc1.iso fd is 17 
* umounting loopback tmp/testmnt loop6 
* MD5SUM -> 3218284f8826bf95ccd6f248ad9229f0 
* skipsectors = 15 
* isostatus = 0 
* MD5SUM -> 3218284f8826bf95ccd6f248ad9229f0 
* skipsectors = 15 
* isostatus = 0 
* mediacheck: /mnt/source/psyche-i386-disc1.iso (Psyche 8.0 disc 1) PASSED 
* value of isostatus iso flag is 0 
* mntloop loop6 on /tmp/testmnt as /mnt/source/psyche-i386-disc2.iso fd is 17 
* umounting loopback tmp/testmnt loop6 
* MD5SUM -> 2768d8b55f03ea567caf42d0f5199221 
* skipsectors = 15 
* isostatus = 1 
* MD5SUM -> 2768d8b55f03ea567caf42d0f5199221 
* skipsectors = 15 
* isostatus = 1 
* mediacheck: /mnt/source/psyche-i386-disc2.iso (Psyche 8.0 disc 2) PASSED 
* value of isostatus iso flag is 1 
* mntloop loop6 on /tmp/testmnt as /mnt/source/psyche-i386-disc3.iso fd is 17 
* umounting loopback tmp/testmnt loop6 
* MD5SUM -> a9a5c9173b19e07d93c56a09a84a0f62 
* skipsectors = 15 
* isostatus = 1 
* MD5SUM -> a9a5c9173b19e07d93c56a09a84a0f62 
* skipsectors = 15 
* isostatus = 1 
* mediacheck: /mnt/source/psyche-i386-disc3.iso (Psyche 8.0 disc 3) PASSED 
* value of isostatus iso flag is 1 
* mntloop loop6 on /tmp/testmnt as /mnt/source/psyche-i386-disc4.iso fd is 17 
* umounting loopback tmp/testmnt loop6 
* MD5SUM -> ef1a8a3109b0f7ab7d94871e788c4960 
* skipsectors = 15 
* isostatus = 1 
* MD5SUM -> ef1a8a3109b0f7ab7d94871e788c4960 
* skipsectors = 15 
* isostatus = 1 
* mediacheck: /mnt/source/psyche-i386-disc4.iso (Psyche 8.0 disc 4) PASSED 
* value of isostatus iso flag is 1 
* mntloop loop6 on /tmp/testmnt as /mnt/source/psyche-i386-disc5.iso fd is 17 
* umounting loopback tmp/testmnt loop6 
* MD5SUM -> 120e30f25adec5a92fe457d224e6d22c 
* skipsectors = 15 
* isostatus = 1 
* MD5SUM -> 120e30f25adec5a92fe457d224e6d22c 
* skipsectors = 15 
* isostatus = 1 
* mediacheck: /mnt/source/psyche-i386-disc5.iso (Psyche 8.0 disc 5) PASSED 
* value of isostatus iso flag is 1 
* mediacheck: skipped checking of /mnt/source/psyche-docs.iso 
* got url nfsiso:/mnt/source 
* getting ready to spawn shell now 
* modules to insert ide-cd 
* module(s) ide-cd not found 
* load module set done 
* modules to insert sr_mod 
* inserted /tmp/sr_mod.o 
* load module set done 
* probing buses 
* finished bus probing 
* modules to insert agpgart 
* failed to insert /tmp/agpgart.o 
* load module set done 
* looking for video cards requiring agpgart module 
* found video card controller unknown 
* modules to insert raid0 raid1 xor raid5 msdos jbd ext3 reiserfs jfs xfs 
lvm-mod 
* module(s) jfs xfs not found 
* inserted /tmp/raid0.o 
* inserted /tmp/raid1.o 
* inserted /tmp/xor.o 
* inserted /tmp/raid5.o 
* inserted /tmp/msdos.o 
* inserted /tmp/jbd.o 
* inserted /tmp/ext3.o 
* inserted /tmp/reiserfs.o 
* inserted /tmp/lvm-mod.o 
* load module set done 
* loading parallel port drivers... 
* modules to insert parport parport_pc 
* inserted /tmp/parport.o 
* inserted /tmp/parport_pc.o 
* load module set done 
* Running anaconda script /usr/bin/anaconda 
* Probing for video card:   Voodoo3 (generic) 
* ddcprobe returned bogus values: 
ID:   ___ffff 
Name: None 
HorizSync: -268377405--268376394 
VertSync:  -268376394--268370092 
 
* Probing for monitor type: Unable to probe 
* Probing for mouse type:   Generic - 2 Button Mouse (serial) 
* forcing dpi = 96 for mode 800x600, heightxwidth = 211.666666667mm by 
158.75mm 
* Started mini-wm 
* anaconda floppy device fd0 
* going to mount hda3 on /mnt/sysimage as ext3 
* Using /tmp/isomedia//RedHat/base/comps.xml 
* Component Maximum RPM needs package maximum-rpm which doesn't exist 
* Component Official Red Hat Linux Customization Guide needs package rhl-cg-en 
which doesn't exist 
* Component Official Red Hat Linux Getting Started Guide needs package 
rhl-gsg-en which doesn't exist 
* Component Official Red Hat Linux Reference Guide needs package rhl-rg-en 
which doesn't exist 
* Component Official Red Hat Linux Security Guide needs package rhl-sg-en 
which doesn't exist 
* Component Official Red Hat Linux x86 Installation Guide needs package 
rhl-ig-x86-en which doesn't exist 
* Upgrade: User selected to use GRUB for bootloader 
* Upgrade: gnome-core was on the system.  Upgrading to GNOME 2 
 
 
/tmp/netinfo: 
DEVICE=eth0 
ONBOOT=yes 
BOOTPROTO=static 
IPADDR=192.168.1.42 
NETMASK=255.255.255.0 
GATEWAY=192.168.1.1 
BROADCAST=192.168.1.255 
 
 
/mnt/sysimage/root/install.log: 
Installing 606 packages 
 
Installing glibc-common-2.2.5-34. 
Installing hwdata-0.14-1. 
Installing indexhtml-7.3-3. 
Installing mailcap-2.1.9-2. 
Installing man-pages-1.48-2. 
Installing redhat-logos-1.1.3-1. 
Installing setup-2.5.12-1. 
Installing filesystem-2.1.6-2. 
Installing basesystem-7.0-2. 
Installing glibc-2.2.5-34. 
Installing bdflush-1.5-17. 
Installing bzip2-libs-1.0.2-2. 
Installing chkconfig-1.3.5-3. 
Installing cracklib-2.7-15. 
Installing db1-1.85-8. 
Installing db2-2.4.14-10. 
Installing db3-3.3.11-6. 
Installing dosfstools-2.8-1. 
Installing e2fsprogs-1.27-3. 
Installing eject-2.0.12-4. 
Installing file-3.37-5. 
Installing gdbm-1.8.0-14. 
Installing glib-1.2.10-5. 
Installing glib2-2.0.1-2. 
Installing hdparm-4.6-1. 
Installing hesiod-3.0.2-18. 
Installing iputils-20020124-3. 
Installing ksymoops-2.4.4-1. 
Installing losetup-2.11n-12. 
Installing mailx-8.1.1-22. 
Installing mingetty-1.00-1. 
Installing mktemp-1.5-14. 
Installing mt-st-0.7-3. 
Installing net-tools-1.60-4. 
Installing parted-1.4.24-3. 
Installing pcre-3.9-2. 
Installing perl-5.6.1-34.99.6. 
Installing perl-CGI-2.752-34.99.6. 
Installing perl-CPAN-1.59_54-34.99.6. 
Installing perl-DB_File-1.75-34.99.6. 
Installing perl-NDBM_File-1.75-34.99.6. 
Installing popt-1.6.4-7x.18. 
Installing pwdb-0.61.2-2. 
Installing reiserfs-utils-3.x.0j-3. 
Installing setserial-2.17-5. 
Installing shadow-utils-20000902-7. 
Installing slang-1.4.5-2. 
Installing newt-0.50.35-1. 
Installing netconfig-0.8.11-7. 
Installing ntsysv-1.3.5-3. 
Installing setuptool-1.8-2. 
Installing specspo-7.3-4. 
Installing syslinux-1.52-2. 
Installing termcap-11.0.1-10. 
Installing libtermcap-2.0.8-28. 
Installing bash-2.05a-13. 
Installing bzip2-1.0.2-2. 
Installing crontabs-1.10-1. 
Installing iproute-2.4.7-1. 
Installing libstdc++-2.96-110. 
Installing groff-1.17.2-12. 
Installing logrotate-3.6.4-1. 
Installing MAKEDEV-3.3-4. 
Installing ncurses-5.2-26. 
Installing info-4.1-1. 
Installing cpio-2.4.2-26. 
Installing diffutils-2.7.2-5. 
Installing ed-0.2-25. 
Installing fileutils-4.1-10. 
Installing at-3.1.8-23. 
Installing findutils-4.1.7-4. 
Installing gawk-3.1.0-4. 
Installing grep-2.5.1-1. 
Installing ash-0.3.7-2. 
Installing dhcpcd-1.3.22pl1-7. 
Installing grub-0.91-4. 
Installing less-358-24. 
Installing gzip-1.3.3-1. 
Installing man-1.5j-6. 
Installing openssl-0.9.6b-18. 
Installing procmail-3.22-5. 
Installing procps-2.0.7-12. 
Installing psmisc-20.2-2. 
Installing raidtools-1.00.2-1.3. 
Installing readline-4.2a-4. 
Installing redhat-release-7.3-1. 
Installing rootfiles-7.2-1. 
Installing sed-3.02-11. 
Installing console-tools-19990829-40. 
Installing kbdconfig-1.9.15-2. 
Installing slocate-2.6-1. 
Installing sysklogd-1.4.1-8. 
Installing tar-1.13.25-4. 
Installing tcsh-6.10-6. 
Installing textutils-2.0.21-1. 
Installing dev-3.3-4. 
Installing mount-2.11n-12. 
Installing mouseconfig-4.25-1. 
Installing time-1.7-16. 
Installing tmpwatch-2.8.3-1. 
Installing usbutils-0.9-5. 
Installing hotplug-2002_04_01-3. 
Installing utempter-0.5.2-6. 
Installing vim-common-6.1-2. 
Installing vim-minimal-6.1-2. 
Installing which-2.13-3. 
Installing words-2-18. 
Installing cracklib-dicts-2.7-15. 
Installing pam-0.75-32. 
Installing authconfig-4.2.8-4. 
Installing cyrus-sasl-1.5.24-25. 
Installing cyrus-sasl-md5-1.5.24-25. 
Installing cyrus-sasl-plain-1.5.24-25. 
Installing gpm-1.19.3-21. 
Installing openldap-2.0.23-4. 
Installing libuser-0.50.2-1. 
Installing passwd-0.67-1. 
Installing sh-utils-2.0.11-14. 
Installing krb5-libs-1.2.4-1. 
Installing modutils-2.4.14-3. 
Installing kudzu-0.99.52-1. 
Installing mkinitrd-3.3.10-1. 
Installing lilo-21.4.4-14. 
Installing mkbootdisk-1.4.3-1. 
Installing sendmail-8.11.6-15. 
Installing SysVinit-2.84-2. 
Installing usermode-1.53-2. 
Installing zlib-1.1.3-25.7. 
Installing rpm-4.0.4-7x.18. 
Installing util-linux-2.11n-12. 
Installing initscripts-6.67-1. 
Installing apmd-3.0.2-10. 
Installing ipchains-1.3.10-13. 
Installing iptables-1.2.5-3. 
Installing kernel-2.4.18-3. 
Installing lokkit-0.50-8. 
Installing pciutils-2.1.9-2. 
Installing quota-3.03-1. 
Installing timeconfig-3.2.7-1. 
Installing vixie-cron-3.0.1-64. 
Installing anacron-2.3-17. 
Installing atk-1.0.1-1. 
Installing audiofile-0.2.3-1. 
Installing cdparanoia-libs-alpha9.8-8. 
Installing esound-0.2.24-1. 
Installing expat-1.95.2-2. 
Installing fortune-mod-1.0-20. 
Installing freetype-2.0.9-2. 
Installing ghostscript-fonts-5.50-3. 
Installing gmp-4.0.1-3. 
Installing gnome-audio-1.4.0-1. 
Installing groff-perl-1.17.2-12. 
Installing htdig-3.2.0-2.011302. 
Installing htmlview-2.0.0-1. 
Installing kdeartwork-locolor-3.0.0-4. 
Installing libcap-1.10-8. 
Installing libjpeg-6b-19. 
Installing libmng-1.0.3-2. 
Installing libogg-1.0rc3-1. 
Installing libpng-1.0.12-2. 
Installing libtiff-3.5.7-2. 
Installing cups-libs-1.1.14-15. 
Installing cups-1.1.14-15. 
Installing libvorbis-1.0rc3-1. 
Installing libxml-1.8.17-3. 
Installing libxml2-2.4.19-4. 
Installing libxslt-1.0.15-1. 
Installing lm_sensors-2.6.1-1. 
Installing LPRng-3.8.9-3. 
Installing m4-1.4.1-7. 
Installing make-3.79.1-8. 
Installing efax-0.9-12. 
Installing mpage-2.5.1-9. 
Installing netpbm-9.24-3. 
Installing netpbm-progs-9.24-3. 
Installing nkf-1.92-6. 
Installing ntp-4.1.1-1. 
Installing Omni-0.5.1-3. 
Installing openssh-3.1p1-3. 
Installing openssh-clients-3.1p1-3. 
Installing ORBit-0.5.13-3. 
Installing perl-DateManip-5.40-15. 
Installing perl-Digest-MD5-2.16-15. 
Installing perl-HTML-Tagset-3.03-14. 
Installing perl-HTML-Parser-3.26-2. 
Installing perl-libnet-1.0901-17. 
Installing perl-libxml-enno-1.02-15. 
Installing perl-MIME-Base64-2.12-14. 
Installing perl-Parse-Yapp-1.05-15. 
Installing perl-Storable-1.0.14-15. 
Installing perl-URI-1.17-16. 
Installing perl-libwww-perl-5.63-9. 
Installing perl-XML-Encoding-1.01-9. 
Installing perl-XML-Grove-0.46alpha-11. 
Installing perl-XML-Parser-2.30-15. 
Installing perl-libxml-perl-0.07-14. 
Installing perl-XML-Dumper-0.4-12. 
Installing perl-XML-Twig-2.02-9. 
Installing foomatic-1.1-0.20020313.3. 
Installing Omni-foomatic-0.5.1-3. 
Installing pnm2ppa-1.04-2. 
Installing portmap-4.0-41. 
Installing psutils-1.17-13. 
Installing a2ps-4.13b-19. 
Installing python-1.5.2-38. 
Installing alchemist-1.0.23-1. 
Installing Distutils-1.0.2-2. 
Installing python2-2.2-16. 
Installing PyXML-0.7-4. 
Installing 4Suite-0.11.1-8. 
Installing switchdesk-3.9.8-2. 
Installing tcl-8.3.3-67. 
Installing unzip-5.50-2. 
Installing watanabe-vf-1.0-5. 
Installing XFree86-libs-4.2.0-8. 
Installing Glide3-20010520-13. 
Installing gtk+-1.2.10-15. 
Installing gdk-pixbuf-0.14.0-8. 
Installing libungif-4.1.0-10. 
Installing imlib-1.9.13-3.7.x. 
Installing gnome-libs-1.4.1.2.90-14. 
Installing libglade-0.17-5. 
Installing locale_config-0.3.4-2. 
Installing openmotif-2.2.2-5. 
Installing pango-1.0.1-1. 
Installing gtk2-2.0.2-4. 
Installing libglade2-1.99.9-2. 
Installing pygtk-0.6.9-3. 
Installing pygnome-1.4.2-3. 
Installing dateconfig-0.7.5-5. 
Installing pygtk-libglade-0.6.9-3. 
Installing pygnome-libglade-1.4.2-3. 
Installing hwbrowser-0.3.8-1. 
Installing ksconfig-2.0-7. 
Installing pygtk2-1.99.8-7. 
Installing pygtk2-libglade-1.99.8-7. 
Installing authconfig-gtk-4.2.8-4. 
Installing qt-3.0.3-11. 
Installing arts-1.0.0-4. 
Installing kdelibs-3.0.0-10. 
Installing kcalc-3.0.0-4. 
Installing kdeadmin-3.0.0-4. 
Installing kdeartwork-screensavers-3.0.0-4. 
Installing kdepasswd-3.0.0-4. 
Installing kdepim-3.0.0-3. 
Installing kdessh-3.0.0-4. 
Installing kedit-3.0.0-4. 
Installing kfloppy-3.0.0-4. 
Installing khexedit-3.0.0-4. 
Installing kjots-3.0.0-4. 
Installing kljettool-3.0.0-4. 
Installing klpq-3.0.0-4. 
Installing koffice-1.1.1-5. 
Installing kontrol-panel-4.2.3-2. 
Installing kregexpeditor-3.0.0-4. 
Installing ktimer-3.0.0-4. 
Installing redhat-config-users-1.0.1-5. 
Installing serviceconf-0.7.0-3. 
Installing switchdesk-kde-3.9.8-2. 
Installing tk-8.3.3-67. 
Installing pilot-link-0.9.5-13. 
Installing kdepim-pilot-3.0.0-3. 
Installing tix-8.2.0b1-67. 
Installing tkinter-1.5.2-38. 
Installing usermode-gtk-1.53-2. 
Installing Xaw3d-1.5-12. 
Installing XFree86-font-utils-4.2.0-8. 
Installing XFree86-xfs-4.2.0-8. 
Installing chkfontpath-1.9.5-2. 
Installing ttfonts-1.0-9. 
Installing ttfonts-ja-1.2-8. 
Installing urw-fonts-2.0-17. 
Installing VFlib2-2.25.6-4. 
Installing ghostscript-6.52-8. 
Installing cups-drivers-1.1-0.20020313.3. 
Installing cups-drivers-pnm2ppa-1.1-0.20020313.3. 
Installing hpijs-1.0.2-8. 
Installing cups-drivers-hpijs-1.1-0.20020313.3. 
Installing printconf-0.3.77-1. 
Installing printconf-gui-0.3.77-1. 
Installing XFree86-100dpi-fonts-4.2.0-8. 
Installing XFree86-75dpi-fonts-4.2.0-8. 
Installing XFree86-base-fonts-4.2.0-8. 
Installing XFree86-4.2.0-8. 
Installing mkxauth-1.7-18. 
Installing Xconfigurator-4.10.7-1. 
Installing XFree86-ISO8859-15-100dpi-fonts-4.2.0-8. 
Installing XFree86-ISO8859-15-75dpi-fonts-4.2.0-8. 
Installing XFree86-tools-4.2.0-8. 
Installing XFree86-twm-4.2.0-8. 
Installing xinetd-2.3.4-0.8. 
Installing xinitrc-3.22-1. 
Installing XFree86-xdm-4.2.0-8. 
Installing kdebase-3.0.0-12. 
Installing kcharselect-3.0.0-4. 
Installing kdeaddons-kate-3.0.0-4. 
Installing kdeaddons-kicker-3.0.0-4. 
Installing kdeaddons-konqueror-3.0.0-4. 
Installing kdeartwork-3.0.0-4. 
Installing kdf-3.0.0-4. 
Installing xloadimage-4.1-21. 
Installing xsri-2.0.3-1. 
Installing zip-2.3-12. 
Installing ark-3.0.0-4. 
Installing libtool-libs-1.4.2-7. 
Installing pspell-0.12.2-8. 
Installing aspell-0.33.7.1-9. 
Installing abiword-0.99.5-1. 
Installing aumix-2.7-8. 
Installing desktop-backgrounds-1.1-4. 
Installing dia-0.88.1-3. 
Installing ee-0.3.12-5. 
Installing extace-1.5.1-3. 
Installing fam-2.6.7-6. 
Installing gal-0.19.1-2. 
Installing gdk-pixbuf-gnome-0.14.0-8. 
Installing gftp-2.0.11-2. 
Installing gnome-audio-extra-1.4.0-1. 
Installing gnome-mime-data-1.0.4-1. 
Installing gnome-user-docs-1.4.1-1. 
Installing gnupg-1.0.6-5. 
Installing gqview-0.8.1-5. 
Installing gtk-engines-0.11-10. 
Installing ImageMagick-5.4.3.11-1. 
Installing imlib-cfgeditor-1.9.13-3.7.x. 
Installing libgal19-0.19.1-2. 
Installing libghttp-1.0.9-2. 
Installing gnorpm-0.96-14. 
Installing libgnomeprint15-0.35-4. 
Installing gnome-print-0.35-4. 
Installing libgtop-1.0.12-8. 
Installing gtop-1.0.13-4. 
Installing libole2-0.2.4-1. 
Installing librep-0.15.1-3. 
Installing librsvg-1.0.2-1. 
Installing libunicode-0.4-6. 
Installing mc-4.5.55-5. 
Installing mozilla-nspr-0.9.9-7. 
Installing mozilla-0.9.9-7. 
Installing mozilla-mail-0.9.9-7. 
Installing mozilla-nss-0.9.9-7. 
Installing mozilla-psm-0.9.9-7. 
Installing oaf-0.6.8-3. 
Installing bonobo-1.0.19-2. 
Installing GConf-1.0.9-4. 
Installing bonobo-conf-0.14-5. 
Installing gnome-spell-0.4.1-0.7x. 
Installing gnome-vfs-1.0.5-4. 
Installing bug-buddy-2.0.6-9. 
Installing control-center-1.4.0.1-31. 
Installing eel-1.0.2-11. 
Installing gedit-0.9.7-8. 
Installing gnome-vfs-extras-0.2.0-1. 
Installing gtkhtml-1.0.2-1. 
Installing Guppi-0.40.3-5. 
Installing patch-2.5.4-12. 
Installing intltool-0.17-1. 
Installing pygnome-gtkhtml-1.4.2-3. 
Installing python-popt-0.8.8-7.x.2. 
Installing python-clap-1.0.0-3. 
Installing python-xmlrpc-1.5.1-7.x.3. 
Installing rep-gtk-0.15-7. 
Installing rep-gtk-gnome-0.15-7. 
Installing rep-gtk-libglade-0.15-7. 
Installing rpm-python-4.0.4-7x.18. 
Installing rhn_register-2.7.21-7.x.3. 
Installing rhn_register-gnome-2.7.21-7.x.3. 
Installing sawfish-1.0.1-9. 
Installing gnome-core-1.4.0.4-54. 
Installing gnome-applets-1.4.0.5-6. 
Installing gnome-pilot-0.1.64-3. 
Installing gnome-utils-1.4.0-9. 
Installing pygnome-applet-1.4.2-3. 
Installing sgml-common-0.6.3-9. 
Installing switchdesk-gnome-3.9.8-2. 
Installing umb-scheme-3.2-21. 
Installing guile-1.3.4-19. 
Installing gnumeric-1.0.5-3. 
Installing up2date-2.7.86-7.x.3. 
Installing up2date-gnome-2.7.86-7.x.3. 
Installing rhn-applet-1.0.6-11. 
Installing xchat-1.8.8-5. 
Installing xml-common-0.6.3-9. 
Installing docbook-dtds-1.0-8. 
Installing openjade-1.3.1-4. 
Installing scrollkeeper-0.3.4-4. 
Installing evolution-1.0.3-4. 
Installing gdm-2.2.3.1-22. 
Installing nautilus-1.0.6-15. 
Installing nautilus-mozilla-1.0.6-15. 
Installing xscreensaver-3.33-4. 
Installing autorun-2.73-1. 
Installing awesfx-0.4.3a-8. 
Installing cdda2wav-1.10-11. 
Installing cdlabelgen-1.5.0-11. 
Installing cdp-0.33-22. 
Installing cdparanoia-alpha9.8-8. 
Installing cdrecord-1.10-11. 
Installing curl-7.9.5-2. 
Installing gnome-media-1.2.3-4. 
Installing kaboodle-3.0.0-3. 
Installing kdemultimedia-arts-3.0.0-3. 
Installing kdemultimedia-kfile-3.0.0-3. 
Installing kdemultimedia-libs-3.0.0-3. 
Installing kmid-3.0.0-3. 
Installing kmix-3.0.0-3. 
Installing kscd-3.0.0-3. 
Installing libao-0.8.2-2. 
Installing magicdev-0.3.6-6. 
Installing mikmod-3.1.6-12. 
Installing mkisofs-1.10-11. 
Installing koncd-3.0.0-3. 
Installing mpg321-0.2.9-3. 
Installing noatun-3.0.0-3. 
Installing playmidi-2.4-16. 
Installing SDL-1.2.3-7. 
Installing kdeaddons-noatun-3.0.0-4. 
Installing SDL_image-1.2.1-4. 
Installing SDL_net-1.2.3-2. 
Installing smpeg-0.4.4-9. 
Installing SDL_mixer-1.2.1-4. 
Installing sox-12.17.3-4. 
Installing sndconfig-0.68-1. 
Installing timidity++-2.11.3-1. 
Installing kmidi-3.0.0-3. 
Installing vorbis-tools-1.0rc3-3. 
Installing xawtv-3.73-3. 
Installing xmms-1.2.7-1. 
Installing xmms-gnome-1.2.7-1. 
Installing autofs-3.1.7-28. 
Installing bind-utils-9.2.0-8. 
Installing cipe-1.4.5-9. 
Installing compat-libstdc++-6.2-2.9.0.16. 
Installing finger-0.17-9. 
Installing firewall-config-0.97-2. 
Installing ftp-0.17-13. 
Installing gq-0.4.0-5. 
Installing kdenetwork-libs-3.0.0-4. 
Installing kdict-3.0.0-4. 
Installing kit-3.0.0-4. 
Installing kmail-3.0.0-4. 
Installing knewsticker-3.0.0-4. 
Installing kdeaddons-knewsticker-3.0.0-4. 
Installing korn-3.0.0-4. 
Installing kpf-3.0.0-4. 
Installing krbafs-1.1.1-1. 
Installing ksirc-3.0.0-4. 
Installing ktalkd-3.0.0-4. 
Installing kxmlrpcd-3.0.0-4. 
Installing libpcap-0.6.2-12. 
Installing lisa-3.0.0-4. 
Installing logwatch-2.6-2. 
Installing micq-0.4.6.p1-2. 
Installing ncftp-3.1.3-3. 
Installing nfs-utils-0.3.3-5. 
Installing nmap-2.54BETA31-1. 
Installing nmap-frontend-2.54BETA31-1. 
Installing nscd-2.2.5-34. 
Installing nss_ldap-185-1. 
Installing openldap-clients-2.0.23-4. 
Installing openssh-askpass-3.1p1-3. 
Installing openssh-askpass-gnome-3.1p1-3. 
Installing pam_krb5-1.55-1. 
Installing pidentd-3.0.14-5. 
Installing qt2-2.3.1-3. 
Installing radvd-0.7.1-1. 
Installing rdate-1.2-1. 
Installing redhat-config-network-1.0.0-1. 
Installing rmt-0.4b27-3. 
Installing rsh-0.17-5. 
Installing sendmail-cf-8.11.6-15. 
Installing stunnel-3.22-1. 
Installing talk-0.17-12. 
Installing tcp_wrappers-7.6-19. 
Installing telnet-0.17-20. 
Installing traceroute-1.4a12-2. 
Installing ucd-snmp-4.2.4-3. 
Installing wget-1.8.1-4. 
Installing whois-1.0.10-1. 
Installing ypbind-1.10-7. 
Installing yp-tools-2.6-4. 
Installing isdn4k-utils-3.1-53. 
Installing kppp-3.0.0-4. 
Installing kpppload-1.04-36. 
Installing lockdev-1.0.0-16. 
Installing lrzsz-0.12.20-12. 
Installing minicom-2.00.0-3. 
Installing ppp-2.4.1-3. 
Installing rp-pppoe-3.3-7. 
Installing statserial-1.1-27. 
Installing wvdial-1.41-16. 
Installing xisdnload-1.38-53. 
Installing elinks-0.3.0-1. 
Installing fetchmail-5.9.0-5. 
Installing gaim-0.53-1. 
Installing galeon-1.2.0-7. 
Installing knode-3.0.0-4. 
Installing libesmtp-0.8.4-2. 
Installing balsa-1.2.4-1. 
Installing licq-1.1.0-0.cvs20020416.1. 
Installing licq-gnome-1.1.0-0.cvs20020416.1. 
Installing licq-kde-1.1.0-0.cvs20020416.1. 
Installing mozilla-chat-0.9.9-7. 
Installing mutt-1.2.5.1-1. 
Installing netscape-common-4.79-1. 
Installing netscape-communicator-4.79-1. 
Installing nmh-1.0.4-9. 
Installing exmh-2.4-2. 
Installing pan-0.11.2-2. 
Installing pine-4.44-7. 
Installing sharutils-4.2.1-9. 
Installing metamail-2.7-28. 
Installing giftrans-1.12.2-11. 
Installing gimp-1.2.3-4. 
Installing gphoto-0.4.3-17. 
Installing kcoloredit-3.0.0-5. 
Installing kfile-pdf-3.0.0-5. 
Installing kfile-png-3.0.0-5. 
Installing kfract-3.0.0-5. 
Installing kghostview-3.0.0-5. 
Installing kiconedit-3.0.0-5. 
Installing kpaint-3.0.0-5. 
Installing kruler-3.0.0-5. 
Installing ksnapshot-3.0.0-5. 
Installing kuickshow-3.0.0-5. 
Installing kview-3.0.0-5. 
Installing kviewshell-3.0.0-5. 
Installing kdvi-3.0.0-5. 
Installing kfax-3.0.0-5. 
Installing libusb-0.1.5-3. 
Installing gphoto2-2.0-4. 
Installing gtkam-0.1.3-0.cvs20020225.2. 
Installing kamera-3.0.0-5. 
Installing sane-backends-1.0.7-6. 
Installing libkscan-3.0.0-5. 
Installing kooka-3.0.0-5. 
Installing sane-frontends-1.0.7-2. 
Installing xsane-0.84-2. 
Installing samba-common-2.2.3a-6. 
Installing samba-client-2.2.3a-6. 
Installing dialog-0.9a-5. 
Installing docbook-style-dsssl-1.76-1. 
Installing docbook-style-xsl-1.49-1. 
Installing perl-SGMLSpm-1.03ii-4. 
Installing docbook-utils-0.6.9-25. 
Installing tetex-fonts-1.0.7-47. 
Installing tetex-1.0.7-47. 
Installing tetex-afm-1.0.7-47. 
Installing tetex-dvilj-1.0.7-47. 
Installing tetex-dvips-1.0.7-47. 
Installing tetex-latex-1.0.7-47. 
Installing jadetex-3.12-2. 
Installing docbook-utils-pdf-0.6.9-25. 
Installing linuxdoc-tools-0.9.16-4. 
Installing w3c-libwww-5.3.2-5. 
Installing tetex-xdvi-1.0.7-47. 
Installing xmltex-20000118-8. 
Installing passivetex-1.12-3. 
Installing xmlto-0.0.8-3. 
Installing emacs-21.2-2. 
Installing psgml-1.2.3-3. 
Installing tamago-4.0.6-5. 
Installing bc-1.06-8. 
Installing dump-0.4b27-3. 
Installing ical-2.2-26. 
Installing karm-3.0.0-3. 
Installing kdepim-cellphone-3.0.0-3. 
Installing klprfax-3.0.0-4. 
Installing knotes-3.0.0-3. 
Installing lsof-4.51-2. 
Installing lv-4.49.4-3. 
Installing pax-3.0-1. 
Installing pinfo-0.6.4-4. 
Installing procinfo-18-2. 
Installing rsync-2.5.4-2. 
Installing screen-3.9.11-3. 
Installing stat-2.5-5. 
Installing sudo-1.6.5p2-2. 
Installing symlinks-1.2-13. 
Installing tree-1.2-17. 
Installing units-1.74-1. 
Installing usbview-1.0-5. 
Installing vim-enhanced-6.1-2. 
Installing xdelta-1.1.3-5. 
Installing xpdf-1.00-3. 
Installing gnome-games-1.4.0.1-5. 
Installing kdegames-3.0.0-2. 
Installing dos2unix-3.1-10. 
Installing lha-1.14i-4. 
Installing mtools-3.9.8-2. 
Installing pam_smb-1.1.6-2. 
Installing unix2dos-2.2-15. 
Installing wine-20020327-1. 
Installing chromium-0.9.12-13. 
Installing freeciv-1.12.0-1. 
Installing gnuchess-4.0.pl80-8. 
Installing joystick-1.2.15-11. 
Installing kdetoys-3.0.0-3. 
Installing kdeartwork-kworldclock-3.0.0-4. 
Installing Maelstrom-3.0.1-18. 
Installing tuxracer-0.61-8. 
Installing xbill-2.0-16. 
Installing xboard-4.2.3-2. 
Installing xpilot-4.4.3-5. 
Installing xsnow-1.42-3. 
Installing plugger-4.0-6. 
 
 
/mnt/sysimage/root/upgrade.log: 
Upgrading 0 packages 
 
 
 
The following packages were available in this version but NOT upgraded: 
rhl-gsg-en-8.0-4.noarch.rpm 
rhl-rg-en-8.0-2.noarch.rpm 
maximum-rpm-1.0-0.20020905.noarch.rpm 
rhl-cg-en-8.0-2.noarch.rpm 
rhl-sg-en-8.0-2.noarch.rpm 
rhl-ig-x86-en-8.0-2.noarch.rpm 
 
  
Comment 4 David Charlap 2002-10-08 13:34:18 EDT
The same thing happened to me today.  I downloaded the ISO files.  I mounted
them and used tar to transfer the contents of discs 1, 2 and 3 and the
documentation disc to a directory on an NFS server.  I then proceeded to do an
NFS install.

The installer didn't ask me to convert my disk partitions the way Rob's
installer did, but the rest is the same.  I chose an upgrade install, asked to
customize package selections, told it to update the boot loader, and then
anaconda crashed.

The traceback is identical to the one Rob posted.  I can attach my anacdump.txt
file if you think it will help.
Comment 5 David Charlap 2002-10-08 13:36:09 EDT
Created attachment 79424 [details]
The dump file Anaconda generated when my RH8.0 install crashed
Comment 6 Jeremy Katz 2002-10-09 11:21:34 EDT
Does it work if you move the docs cd into a different directory (even just a
subdirectory of the directory the other ISO images are in)?
Comment 7 David Charlap 2002-10-09 11:59:36 EDT
I didn't install from the ISO images.  I copied the contents of those CDs (the
RedHat directories and some of the top-level readme files).

I will try again, leaving out the documentation CD, however.  I'll let you know
if that works.  If it fails, I'll also try using the .iso files.
Comment 8 David Charlap 2002-10-09 13:45:29 EDT
OK.  This time, when I prepared my NFS directory to install from, I copied in
the entire contents of discs 1-3.  I copied the contents of the documentation to
a different location.  Then I deleted the TRANS.TBL files (which should only be
needed on CD media), the SRPMS directory, the isolinux directory and the autorun
file.  This should be OK - according to the docs, only the RedHat directory is
required, and it is left unaltered, except for the deleted TRANS.TBL files.

This time, I left all the root-level README and RELEASE-NOTES files intact. 
Previously, I deleted all of the foreign-language versions of these, although I
wouldn't expect this to be the cause of the problem.

It appears to be working now.  I't installing packages.  If I don't submit any
additional comments, you can assume that the installation completed successfully.
Comment 9 David Charlap 2002-10-10 10:09:30 EDT
The installation did complete successfully.  So it appears that (in my case),
the problem was caused by one (or both) of twothings:

- Copying the contents of the documentation CD to the same place as the
installer CDs

- Deleting some root-level files (READMEs and RELEASE-NOTES)

In conjunction with an NFS install.
Comment 10 Rob Blomquist 2002-10-10 22:46:08 EDT
I tried out moving the docs iso to a new subdirectory, and everything worked out great! 
 
Thanks for your help. 
 
Rob

Note You need to log in before you can comment on or make changes to this bug.