This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 751873 - After updates to bundle deployment of helloworld.war to EAP 5.1* cluster cause JBoss undeploy failures.
After updates to bundle deployment of helloworld.war to EAP 5.1* cluster caus...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 2.4.0
Unspecified Unspecified
medium Severity high
: ---
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
: Reopened
: 773663 (view as bug list)
Depends On: 744803
Blocks: jon30-sprint8 jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2011-11-07 16:11 EST by Robert Buck
Modified: 2014-01-02 15:38 EST (History)
6 users (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 744803
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix jboss log spew and undeployment issues (3.40 KB, patch)
2011-11-07 16:12 EST, Robert Buck
no flags Details | Diff

  None (edit)
Description Robert Buck 2011-11-07 16:11:21 EST
When I created an EAP 5.1 cluster comprising two nodes, n01 and n02, on a single host, when I deployed a bundle (having a helloworld.war), if I tried to undeploy the war file on the file system using rm -fr of the deployment in the live system, the helloworld application still ran from memory, and its helloworld.jsp page continued to return results. JBoss does not try to undeploy the application. After I patched RHQ I was able to successfully undeploy via rm -fr.

2011-10-10 10:07:56,813 ERROR
[org.jboss.remoting.transport.socket.ServerThread]
(WorkerThread#1[127.0.0.1:39420]) WorkerThread#1[127.0.0.1:39420] failed
java.io.NotSerializableException:
org.jboss.system.server.profile.repository.NoopProfile

Theory is that the calls into the JBoss deployer put JBoss into a bad state, making it fail to undeploy artifacts thereafter.
Comment 1 Robert Buck 2011-11-07 16:12:28 EST
Created attachment 532137 [details]
Fix jboss log spew and undeployment issues
Comment 2 Robert Buck 2011-11-07 16:17:18 EST
commit e0cd4a2e9a6f6e78da88b23803cd367102aba710
Author: Robert Buck <rbuck@redhat.com>
Date:   2011-11-07 16:14:45 -0500

    [BZ 751873] Prevent JBoss log spew and undeploy issues; w/o this fix after a bundle is deployed to an EAP cluster and a war is updated, it is no longer possible to undeploy via rm -fr on the command line.

This is on branch: bug/751873
Comment 3 John Mazzitelli 2011-11-16 13:20:55 EST
setting the assignment field to rbuck since he worked on the fix
Comment 4 Ian Springer 2012-01-30 13:04:07 EST
*** Bug 773663 has been marked as a duplicate of this bug. ***
Comment 5 Charles Crouch 2012-02-21 12:29:30 EST
Unassigning from rbuck. Its not immediately clear to me whether this ever got merged into master. Targeting it for JON3.1.0 for investigation and retesting/merging as appropriate.
Comment 6 John Mazzitelli 2012-04-04 16:15:27 EDT
this was already committed to master:

commit 8d5f78b194c2e957f2d5778e3a4ead1fdd98713c
Author: Robert Buck <rbuck@redhat.com> 2011-11-07 16:14:45
Committer: Robert Buck <rbuck@redhat.com> 2011-11-08 07:03:01
Parent: de2e667b239e40f261e9de116c5149889f217e64 (More wildcard updates propagated upwards from the agent api.)

[BZ 751873] Prevent JBoss log spew and undeploy issues; w/o this fix after a bundle is deployed to an EAP cluster and a war is updated, it is no longer possible to undeploy via rm -fr on the command line.
Comment 7 Armine Hovsepyan 2012-08-02 07:47:05 EDT
reopened.

When jboss eap5.1 is started in clustered mode with 2 nodes, after bundle deployment server is being un-deployed, bin directory is being removed.
Comment 8 Larry O'Leary 2012-11-27 18:49:03 EST
(In reply to comment #7)
> reopened.
> 
> When jboss eap5.1 is started in clustered mode with 2 nodes, after bundle
> deployment server is being un-deployed, bin directory is being removed.

Armine, do you have any details on this what you mean by this? From the sound of it, perhaps you deployed a bundle to JBOSS_HOME or some other directory and the manageRootDirectory was not set to false in your recipe?
Comment 9 Armine Hovsepyan 2012-11-28 10:19:23 EST
Hi Larry,

The manageRootDirectory is missing in the recipe but i am not sure if I've deployed the bundle to JBOSS_HOME so for being sure please let me re-test the bug and come back to you.

Armine H.
Comment 10 Armine Hovsepyan 2012-12-03 11:43:25 EST
hi Larry,

sorry, my answer took a while.

The but is not visible anymore, initial case is verified --  yes, the case with bin removal must have been something with deploying into jboss home directory -  so marking bug as verified.

Thanks,
Armine H

Note You need to log in before you can comment on or make changes to this bug.