Bug 751879 - solid hardware does not detect NFS drives, related to halectomy patch?
Summary: solid hardware does not detect NFS drives, related to halectomy patch?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-07 21:40 UTC by Rudd-O DragonFear
Modified: 2011-12-19 19:21 UTC (History)
9 users (show)

Fixed In Version: kdelibs-4.7.3-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-19 14:46:04 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 261359 None None None Never

Description Rudd-O DragonFear 2011-11-07 21:40:01 UTC
In Ubuntu:


~@arianna.twilio α:
strace -ff -efile solid-hardware query 'IS StorageAccess' 2>&1 | grep -v ENOENT | grep open | grep -v /lib ; solid-hardware query 'IS StorageAccess'
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/etc/localtime", O_RDONLY)        = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/home/rudd-o/.kde/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/kubuntu-default-settings/kde4-profile/default/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/home/rudd-o/.kde/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/etc/udev/udev.conf", O_RDONLY|O_CLOEXEC) = 6
open("/etc/fstab", O_RDONLY)            = 7
[pid 24130] open("/proc/stat", O_RDONLY|O_CLOEXEC) = 10
udi = '/org/freedesktop/UDisks/devices/sda4'
udi = '/org/freedesktop/UDisks/devices/dm_2d2'
udi = '/org/freedesktop/UDisks/devices/sda1'
udi = '/org/freedesktop/UDisks/devices/sda2'
udi = '/org/freedesktop/UDisks/devices/sda3'
udi = '/org/kde/fstab///10.254.102.1/shared'
udi = '/org/kde/fstab///172.16.1.185/sdcard'


IN CONTRAST, in Fedora:


[testuser@karen ~]$ strace -ff -efile solid-hardware query 'IS StorageAccess' 2>&1 | grep -v ENOENT | grep open | grep -v /lib ; solid-hardware query 'IS StorageAccess'
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/proc/filesystems", O_RDONLY)     = 3
open("/etc/localtime", O_RDONLY)        = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/etc/nsswitch.conf", O_RDONLY)    = 3
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/etc/passwd", O_RDONLY|O_CLOEXEC) = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/kde-settings/kde-profile/default/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/etc/udev/udev.conf", O_RDONLY|O_CLOEXEC) = 7
open("/dev/urandom", O_RDONLY|O_CLOEXEC) = 9
open("/proc/stat", O_RDONLY|O_CLOEXEC)  = 10
open("/proc/stat", O_RDONLY|O_CLOEXEC)  = 13
udi = '/org/freedesktop/UDisks/devices/sda1'


Someone has patched the solid libraries to skip processing fstab, apparently.

Packages: kde-redhat, from kde47 repo (version 4.7.3)

Comment 1 Rudd-O DragonFear 2011-11-07 21:40:39 UTC
More info;

https://bugs.kde.org/show_bug.cgi?id=269301

Comment 2 Kevin Kofler 2011-11-07 22:04:24 UTC
> Someone has patched the solid libraries to skip processing fstab, apparently.

Yes, that's exactly what's going on.


Lukáš, can we drop that patch which drops the fstab backend? Why do we have that patch in the first place? The fstab backend is clearly good enough for upstream and for most if not all other distributions…

Comment 3 Rudd-O DragonFear 2011-11-07 22:22:15 UTC
Yes for the love of god, that bug has lingered in the kde bug database without anyone being able to figure out what's wrong, precisely because we patch it.

The fstab backend is ESSENTIAL for many KDE services, including NETWORK removable device detection for the indexer and various multimedia applications such as Amarok.  The patch BROKE several functionalities of these applications (such as, for example, proper indexing of media files in network-attached servers).  It also BROKE KDE's auto detection of network mounts which allows dolphin and konqueror to display network-friendly behavior on mounts that could go away at any point.

Comment 4 Rudd-O DragonFear 2011-11-07 22:31:58 UTC
kdelibs-4.6.80-halectomy.patch:-


grep fstab *
kdelibs-4.6.80-halectomy.patch:-   backends/hal/halfstabhandling.cpp
kdelibs-4.6.80-halectomy.patch:-   message(STATUS "Building Solid fstab backend." )
kdelibs-4.6.80-halectomy.patch:-   backends/fstab/fstabmanager.cpp
kdelibs-4.6.80-halectomy.patch:-   backends/fstab/fstabdevice.cpp
kdelibs-4.6.80-halectomy.patch:-   backends/fstab/fstabnetworkshare.cpp
kdelibs-4.6.80-halectomy.patch:-   backends/fstab/fstabstorageaccess.cpp
kdelibs-4.6.80-halectomy.patch:-   backends/fstab/fstabhandling.cpp
kdelibs-4.6.80-halectomy.patch:-   backends/fstab/fstabwatcher.cpp
kdelibs-4.6.80-halectomy.patch:-#include "backends/fstab/fstabmanager.h"


This is the problematic patch.

Guys, HALectomy does not imply removing fstab support.

Comment 5 Rudd-O DragonFear 2011-11-07 22:33:10 UTC
I think the solution is to simply compile with --without-hal or the equivalent CMake option that kdelibs provides.  It HAS to be a compile-time option because there are platforms out there, such as solaris, that do NOT sport HAL.

Comment 6 Rudd-O DragonFear 2011-11-07 22:35:01 UTC
Also, the patch removes UPower.  WHY?  It's not a halectomy, it's a lobotomy!

If the patch is going to do three or four things, better roll three or four separate patches.

Comment 7 Kevin Kofler 2011-11-07 23:22:22 UTC
Uhm, no, it doesn't remove UPower, only the comma at the end of the UPower line because it removes the fstab line below. :-)

Still, I don't think removing the fstab backend is a good idea, upstream ships it for a reason.

Comment 8 Rudd-O DragonFear 2011-11-08 00:34:56 UTC
from irc


[16:32] <rudd-o> Kevin_Kofler: the fstab backend is the fallback in solid.  it should be included *regardless*
[16:32] <rudd-o> if ltinkl considers it "not good enough" for some reason, he should (1) have made TWO different patches, one to remove hal and other to remove fstab (2) made and upstreamed fixes to the fstab backend
[16:32] <rudd-o> that's what SHOULD have happened
[16:32] <Jucato> rudd-o: thanks :)
[16:33] <rudd-o> atm I just want the patch to be removed / altered to exclusively neuter HAL, but leave the fstab backed in
[16:33] <ltinkl> rudd-o: feel free to assign that bug to me, I will have a look at it tomorrow
[16:34] <rudd-o> k, lukas
[16:34] <rudd-o> I will
[16:34] <ltinkl> no time / too sleepy now
[16:34] <rudd-o> it is already assigned to you

Comment 9 Rex Dieter 2011-11-14 13:21:57 UTC
re-assigning to kdelibs.

Comment 10 Rex Dieter 2011-11-14 14:35:33 UTC
Fwiw, looks like some history of this patch, and why the fstab backend is ommited comes from upstream bug http://bugs.kde.org/261359 "using device notification to mount usbpen results in 100% cpu usage"

But, also seems that fixing http://bugs.kde.org/show_bug.cgi?id=261541 may also have fixed the deadlock.

so, let's drop it, and give it a whirl.

Comment 11 Kevin Kofler 2011-11-14 20:57:17 UTC
Should we really drop the whole patch, as opposed to just the part which removes the fstab backend? I think removing the HAL backend entirely still makes sense…

Comment 12 Rex Dieter 2011-11-14 21:20:18 UTC
OK, that's the new plan (confirmed with ltinkl on irc).  will revive halectomy patch to only omit hal, nothing more.

Comment 13 Rudd-O DragonFear 2011-11-14 21:36:30 UTC
YEAH!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Comment 14 Fedora Update System 2011-11-16 15:58:51 UTC
kdelibs-4.6.5-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kdelibs-4.6.5-8.fc15

Comment 15 Fedora Update System 2011-11-16 15:59:40 UTC
kdelibs-4.6.5-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kdelibs-4.6.5-8.fc14

Comment 16 Fedora Update System 2011-11-17 23:27:25 UTC
kdelibs-4.6.5-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-11-17 23:39:37 UTC
kdelibs-4.6.5-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Rudd-O DragonFear 2011-11-17 23:55:39 UTC
This is NOT FIXED in Fedora 16:

~@karen.dragonfear α:
rpm -q kdelibs
kdelibs-4.7.3-2.fc16.x86_64

Comment 19 Rudd-O DragonFear 2011-11-18 00:00:56 UTC
I see nothing in admin.fedoraproject.org indicating that an update for Fedora 16 was pushed, is pending, or is even slated for rebuild.

Comment 20 Rudd-O DragonFear 2011-11-18 00:06:43 UTC
~@karen.dragonfear α:
yum list kdelibs --enablerepo='kde*'
Loaded plugins: auto-update-debuginfo, downloadonly, fastestmirror, fs-snapshot, presto, priorities, refresh-packagekit, remove-with-leaves, rpm-
              : warm-cache, show-leaves, upgrade-helper, verify, versionlock
Loading mirror speeds from cached hostfile
 * fedora: mirrors.kernel.org
 * fedora-debuginfo: mirrors.kernel.org
 * kde: kdeforge.unl.edu
 * kde-testing: kdeforge.unl.edu
 * kde-unstable: kdeforge.unl.edu
 * rpmfusion-free: mirror.web-ster.com
 * rpmfusion-free-debuginfo: mirror.web-ster.com
 * rpmfusion-free-updates: mirror.web-ster.com
 * rpmfusion-free-updates-debuginfo: mirror.web-ster.com
 * rpmfusion-nonfree: mirror.web-ster.com
 * rpmfusion-nonfree-debuginfo: mirror.web-ster.com
 * rpmfusion-nonfree-updates: mirror.web-ster.com
 * rpmfusion-nonfree-updates-debuginfo: mirror.web-ster.com
 * updates: mirrors.kernel.org
 * updates-debuginfo: mirrors.kernel.org
kde-unstable                                                                                                               | 1.9 kB     00:00     
kde-unstable/primary_db                                                                                                    |  21 kB     00:00     
Installed Packages
kdelibs.x86_64                                                     6:4.7.3-2.fc16                                                     @kde-testing
Available Packages
kdelibs.i686                                                       6:4.7.3-2.fc16                                                     updates

Comment 21 Kevin Kofler 2011-11-18 00:07:24 UTC
It's fixed in kdelibs >= 4.7.3-4.fc16, but we haven't filed an update for it yet. (Rex, do we want to file -4 or -5? -5 has the restored patch to remove the HAL backend (but not the fstab one) entirely, but it looks like you and Lukáš more or less agreed on IRC to just drop that patch, so maybe just go with -4?)

Comment 22 Rudd-O DragonFear 2011-11-18 00:12:44 UTC
Yes. I found http://koji.fedoraproject.org/koji/buildinfo?buildID=274525 indicating the build.  I downloaded -5 and I am testing it.

--------------------------------

~/tmp@karen.dragonfear α:
solid-hardware query 'IS StorageAccess'
udi = '/org/freedesktop/UDisks/devices/sda1'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Software'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Entertainment/TV'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Entertainment/Miro'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Knowledge'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Entertainment/Music'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Entertainment/Movies'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Entertainment'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Incoming'
udi = '/org/kde/fstab/10.254.102.1:/export/shared/Entertainment/Jokes'

--------------------------------

Mmmmmgoood.  You http://i.imgur.com/TbiNz.jpg the package :-)  Thanks.

Comment 23 Kevin Kofler 2011-11-18 00:19:40 UTC
No update has been pushed (in fact, not even filed) for Fedora 16, so closing the bug as ERRATA doesn't make sense.

Also, you're not Rex Dieter, so why have you cleared the needinfo for him? I still need him to answer my question (or to just file the version he wants to push as an update himself).

Comment 24 Rudd-O DragonFear 2011-11-18 00:44:57 UTC
Sorry, I fail at bugzilla :-)

Comment 25 Fedora Update System 2011-11-18 18:36:33 UTC
kdelibs-4.7.3-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kdelibs-4.7.3-5.fc16

Comment 26 Fedora Update System 2011-11-20 23:56:10 UTC
kdelibs-4.7.3-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Rex Dieter 2011-12-19 14:46:04 UTC
closing now that kdelibs-4.7.3-5.fc16 is out in the wild

Comment 28 Rudd-O DragonFear 2011-12-19 19:21:52 UTC
I confirm, it works.


Note You need to log in before you can comment on or make changes to this bug.