Bug 75190 - installer can't mount root partition
installer can't mount root partition
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 05:01 EDT by david mottram
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 01:14:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david mottram 2002-10-05 05:01:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
My computer has 2 redhat root partitions, on hda5 and hda3.  When selecting the
upgrade option, the installer allows you to select the root partition to install
to.  However, when I choose hda3 (hda5 is far too small) hda5 is mounted anyway.
 It does 
appear to be reading my hda3 fstab though because there is a line in the fstab
which mounts hda5 and anaconda produces an error message which says it cannot
mount /dev/hda5 as it is already in use.  Removing this line from the hda3 fstab
stops this message appearing but doesn't solve the overall problem.

I have done the media check several times on this first install disk and it
passes every time.

I tried hiding hda5 partition by changing the partion's system 
id to 'EMPTY' with fdisk.  When selecting hda3 in anaconda, which was now the
only root option, it produced an error message saying there was probably a bug
in the code.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot anaconda off first install cd
2. choose upgrade option
3. select hda3 for root partion
	

Actual Results:  anaconda immediately produced error message - see bug file

Expected Results:  should have progressed to next option screen in anaconda

Additional info:

To summarise: anaconda seems unable to mount hda3, and instead mounts hda5 when
available (not hidden).  I have previously installed RH7.1 and RH7.3
successfully on same partition.
Comment 1 Jeremy Katz 2002-10-07 16:19:11 EDT
Do both partitions have a label of '/'?
Comment 2 david mottram 2002-10-16 00:37:03 EDT
Problem solved. 
 
The installer didn't like the following line from my fstab file: 
 
LABEL=/          /        ext3    defaults,noatime        1    1 
 
so I changed it to: 
 
/dev/hda3        /        ext3    defaults,noatime        1    1 
 
and the installer worked fine after that.  This line had worked fine for 
previous upgrades when the file sytem was ext2 not ext3.
Comment 3 david mottram 2002-10-17 02:16:59 EDT
Only '/dev/hda3' had a label of '/'.
Comment 4 Jeremy Katz 2003-01-03 01:14:08 EST
There is more checking which should handle this case in our current codebsa.e

Note You need to log in before you can comment on or make changes to this bug.