Bug 75193 - problems searching for non alphabetic characters in unicode locale
problems searching for non alphabetic characters in unicode locale
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2002-10-05 05:50 EDT by Michael Wardle
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-22 16:44:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Wardle 2002-10-05 05:50:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When viewing a manual page using less as the pager, I like to search
for command parameters by typing: slash-hyphen-flag (such as /-N).
In Red Hat 7, this worked, but after a clean install of Red Hat 8, it
does not.

There are also problems searching for other non-alphabetic characters
such as single quotes.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. man wget
2. /-N

Actual Results:  less displays the error message "Pattern not found"

Expected Results:  cursor is moved to the next instance of "-N"

Additional info:

I notice that Red Hat 8 now uses the Unicode character set in many
places by default.  I tried changing $LANG from en_AU.UTF-8 (this
was selected when I chose English-Australia as the default language
during installation) to en_AU, and I was again able to search for
special characters such as the hyphen.

The same problem appears to exist in the equivalent en_US locales.
Comment 1 Karsten Hopp 2002-11-04 06:15:02 EST
not a bug in less, but in man/nroff (try man -P more manpage to see that the 
same occurs with more)
Comment 2 Florian La Roche 2002-11-26 08:44:23 EST
groff-1.18.1-1 or newer should have a patch that changes the hyphen
character, so that you can search it in "less" again.


Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.