Bug 75199 - rhn-applet falsely reports openssl needs updating
Summary: rhn-applet falsely reports openssl needs updating
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-05 11:24 UTC by adler
Modified: 2007-04-18 16:47 UTC (History)
2 users (show)

Fixed In Version: 2.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 17:10:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description adler 2002-10-05 11:24:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
rhn-applet reports that openssl095a and openssl096 need updating. When running
up2date, up2date claims that the system is up2date. The rhn-applet button
continues to flash red.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Update from 7.3 to 8.0
2.
3.
	

Additional info:

I updated my system at work from 7.3 to 8.0 and I don't have this problem there.
The one difference is that my system at home is using a red hat network
enterprise lisense where as I'm using the free update from home.

To be specific, rhn-applet says that I have openssl095a-0.9.5a-16 installed and
openssl095a-0.9.5a-18: is available and openssl096-0.9.6-11 is installed and
openssl096-0.9.6.13: is available. I do take note of the ":" at the end of the
"available" package name string.

Comment 1 Harm Verhagen 2002-10-19 21:47:02 UTC
I'm seeing the same kinda stuff here.

I upgraded 7.3 to 8.0.
now rhn_applet flashes red and claims I need to upgrade xinetd
(xinetd-2.3.7-2 -> xinetd-2.3.9-0.83)  (2.3.7-2 is indeed installed)
up2date says i don't have anything to upgrade.
checking updates.redhat.com shows that I don't have to upgrade xinetd.

I noticed that if I run rhn_applet as root is says my system is up-to-date.
If I run rhn_applet as a user it claims i need to upgrade xinetd.

This used to work fine in RH 7.3

I tried removing rhn_* up2date* and reinstalling it from 8.0 cd

Comment 2 Daniel Veillard 2002-12-03 15:56:08 UTC
Seems a problem of RPM database cache incoherency left after an
upgrade. We have a fix for that which will be propagated in
rhn-applet >= 2.0.4

Daniel

Comment 3 Robin Norwood 2005-10-07 17:10:10 UTC
This seems to be fixed.


Note You need to log in before you can comment on or make changes to this bug.