Bug 75202 - After installing ttf in ~/.fonts, not visible via xlsfonts
After installing ttf in ~/.fonts, not visible via xlsfonts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 09:37 EDT by Yusuf Goolamabbas
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-05 09:37:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yusuf Goolamabbas 2002-10-05 09:37:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020922

Description of problem:
I installed various truetype fonts via the webfonts4linux shell script. I placed
the fonts in ~/.fonts. Then I ran fc-cache (as root). They were immediately
available to GTK2 and QT applications. In order to make them available to normal
X applications and Mozilla, I added /home/yusufg/.fonts to /etc/X11/fs/config
and then did 

service xfs reload

then I typed xlsfonts. The fonts in ~/.fonts were not visible in the output of
xlsfonts

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add ttf files to ~/.fonts
2. Add /home/yusufg/.fonts to /etc/X11/fs/config
3. Run /etc/rc.d/init.d/xfs reload
4. Type xlsfonts
	

Actual Results:  The output of xlsfonts was similar to that prior to adding the
newpath

Expected Results:  I expected to see the microsoft truetype fonts in the output
of xlsfonts


Additional info:
Comment 1 Mike A. Harris 2002-10-05 18:01:23 EDT
This is not a bug.  You have not properly configured these fonts to
be visible to xfs, which is why they do not work properly.

Please read one of the many font HOWTO's that are available on the
web, or ask for help on one of the Red Hat or XFree86 mailing lists.
Comment 2 R.K.Aa. 2002-10-16 07:17:44 EDT
I have the opposite problem: All my fonts are "revealed" with xlsfonts, but none
of the truetype fonts (that xlsfonts and xfs, mozilla and other can use) are
available to KDE or Gnome2. Instead they fall back to various ugly fonts - and
if i add the truefonts to ~/.fonts, they are suddenly seen, but become blurred -
or, if antialiased, their edges become like "barbed wired". "m" looks like "rn"
etc - all unevem even if hinting is turned on.

Note You need to log in before you can comment on or make changes to this bug.