This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 752021 - <videoobject> does not display in Firefox
<videoobject> does not display in Firefox
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: 4.2
: ---
Assigned To: Jeff Fearn
Martin Lopes
: Reopened
Depends On:
Blocks: 1133742
  Show dependency treegraph
 
Reported: 2011-11-08 06:13 EST by Joshua Wulf
Modified: 2014-10-19 18:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1133742 (view as bug list)
Environment:
Last Closed: 2014-08-31 23:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
html-single xsl style sheet (1003 bytes, application/xslt+xml)
2011-11-08 06:13 EST, Joshua Wulf
no flags Details
html xsl style sheet (994 bytes, application/xslt+xml)
2011-11-08 06:14 EST, Joshua Wulf
no flags Details

  None (edit)
Description Joshua Wulf 2011-11-08 06:13:23 EST
Created attachment 532268 [details]
html-single xsl style sheet

When the <videoobject> tag is rendered as <embed>, it will not display in Firefox. It works fine in Google Chrome.

When it is rendered as an <iframe> it works in both Google Chrome and Firefox.

Can we change the stylesheet to make <videoobject> render as an <iframe>.

html-single.xsl and html.xsl for the change attached. 

Complete brand that demonstrates it here: https://svn.devel.redhat.com/repos/ecs/toolkit/publican-redhat-video

Docbook fragment that utilises the functionality:

<formalpara>
  <title>Create an account for Zanata Video tutorial</title>
  <para><mediaobject>
  <videoobject>
     <videodata contentdepth="413" contentwidth="660"
 fileref="http://player.vimeo.com/video/30704252?title=0[1844952446]byline=0[1844952446]portrait=0"/>
   </videoobject>
    <caption/>
 </mediaobject>
        <ulink url="http://vimeo.com/30704252">View this tutorial full-sized on vimeo.com</ulink></para>
</formalpara>
Comment 1 Joshua Wulf 2011-11-08 06:14:00 EST
Created attachment 532269 [details]
html xsl style sheet
Comment 2 Michael Hideo 2012-02-01 18:46:01 EST
Adding Isaac.

Isaac, this is what we need to enable Mike Esser's brand request.
Comment 3 Joshua Wulf 2012-02-28 00:12:47 EST
The issue is that a videoobject will display as an embedded video in Google Chrome on Linux, however in Firefox it says "Plugin required" and it won't play.

The change to the html fixes it (works around it?).

I'm not particularly attached to the solution that I proposed above (I discovered it while troubleshooting the issue to see what was causing it). I would like videoobjects to reliably display embedded video in browsers on Linux other than Google Chrome.
Comment 4 Ruediger Landmann 2012-02-28 00:28:34 EST
Which book or product is this intended for?
Comment 6 Jeff Fearn 2012-02-28 01:00:06 EST
http://www.w3schools.com/html/html_videos.asp
Comment 8 Ruediger Landmann 2012-02-28 01:23:45 EST
(In reply to comment #2)

> Isaac, this is what we need to enable Mike Esser's brand request.

Isaac, do you have a book or product that would benefit from a change like this? If so, which one?
Comment 9 Joshua Wulf 2012-03-22 01:29:04 EDT
I read the article that Jeff posted and cross-browser support for embedded video seems like a tricky one. 

According to this recent article on slashdot: http://news.slashdot.org/story/12/03/13/2027215/mozilla-debates-supporting-h264-in-firefox-via-system-codecs

Mozilla are talking about adding to Firefox the kind of support that Google Chrome has right now, and Google are talking about taking it out of Chrome...

:S
Comment 11 Ruediger Landmann 2013-07-29 21:40:10 EDT
One of Publican's primary design goals is shipping docs in self-contained RPM packages, either to a Publican-managed internet or intranet website or to desktop. 

We can't know what restrictions exist on cross-domain content in the environments in which the packages will be deployed (but we expect them to be commonplace in enterprise environments). Also, as pointed out in comment #9 video support in different browsers is apparently still a moving target. Therefore, best practice is to include the multimedia files in the package itself. 

I've just verified that video shipped in the package itself works in Firefox 22 when included with the code show in DocBook: The Definitive Guide under the <videoobject> tag: http://www.docbook.org/tdg/en/html/videoobject.html
Comment 12 Jeff Fearn 2014-04-09 23:53:24 EDT
We should switch to iframe since it will work for shipped or linked videos.
Comment 13 Joshua Wulf 2014-04-29 02:59:57 EDT
This is how I did it:

<!-- Make videos work in Firefox -->
<xsl:template match="videoobject">
  <xsl:apply-templates select="videodata"/>
</xsl:template>

<xsl:template match="videodata">
  <xsl:call-template name="process.image">
    <xsl:with-param name="tag" select="'iframe'"/>
    <xsl:with-param name="alt">
      <xsl:apply-templates select="(../../textobject/phrase)[1]"/>
    </xsl:with-param>
  </xsl:call-template>
</xsl:template>
Comment 14 Jeff Fearn 2014-05-15 23:23:52 EDT
Switched common-db5 from video tag to iframe. Tested with these urls:

http://clips.vorwaerts-gmbh.de/VfE.webm

http://player.vimeo.com/video/30704252?title=0[1844952446]byline=0[1844952446]portrait=0

http://youtube.com/embed/B-Wd-Q3F8KM

To ssh://git.fedorahosted.org/git/publican.git
   c777525..7b464d2  devel -> devel
Comment 20 Martin Lopes 2014-08-26 00:17:47 EDT
Verified. Confirmed that videoobject works using the common-db5 brand. Raised BZ#1133742 for the RH brand.
Comment 21 Jeff Fearn 2014-08-31 23:40:35 EDT
A fix for this shipped in Publican 4.2.0.

Note You need to log in before you can comment on or make changes to this bug.